20:06:03 <alagalah> #startmeeting GroupBasedPolicy Status
20:06:03 <odl_meetbot> Meeting started Thu May  8 20:06:03 2014 UTC.  The chair is alagalah. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:06:03 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:06:03 <odl_meetbot> The meeting name has been set to 'groupbasedpolicy_status'
20:06:04 <tbachman> lol!
20:06:20 <tbachman> dave_tucker: am counting on it! ;)
20:06:51 <alagalah> #chair regXboi dconde
20:06:51 <odl_meetbot> Current chairs: alagalah dconde regXboi
20:07:15 <alagalah> #link https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting
20:07:37 <alagalah> #topic First commit/merge - Special thanks to Ryan and Rob!
20:08:22 <alagalah> #info Corollary: Suggested commit process.
20:10:07 <regXboi> #info to scribes: actions should be stand alone
20:10:09 <dconde> #info actions ought to be standalone
20:11:54 <dconde> #info does every commit require multiple code reviews?
20:12:38 <dconde> #info one commiter per team. but generally have one other person to review code
20:12:53 <dconde> #info if other person is a commiter, you can push it through.
20:15:18 <alagalah> #agreed Commit process is that each push will only need one committer. It is to their discretion if they seek other committers opinion, and/or another reviewer who may not be a committer... K.I.S.S.
20:15:33 <dconde> #info votes are not cumulative
20:16:51 <dconde> #action regxboi to figure out how to do the + votes
20:17:06 <alagalah> #action Q was raised "What happens when there is a -2?" Does the merge not happen until it is removed, even if there is a +2? regXboi
20:17:40 <alagalah> #action to validate
20:18:16 <alagalah> #topic Who is going to OpenStack summit and what are the implications to team meetings next week?
20:18:29 <dconde> #info at openstack
20:19:31 <dconde> #info S3wong is going to OpenStack and so is Dvorkin
20:19:42 <dconde> #info so we will have critical mass to keep meeting next week
20:20:09 <alagalah> #info Meetings to proceed
20:20:12 <dconde> #info regxboi says there is a conflict with the Neutron GBP meeting that conflicts.
20:20:33 <alagalah> #topic regXboi There is a conflict between ODL GBP and Neutron GBP (ie Thur 1pm Pac), resolution discussion
20:21:26 <dconde> #info we want the OTHER meeting to move, but what to do?
20:22:02 <dconde> #info shall we use Doodle again to find a free time slot?
20:22:27 <dconde> #info how about Monday PM?
20:23:09 <dconde> #info let's not use Doodle.  We will use IRC instead.
20:23:54 <alagalah> #idea alagalah proposes Mon 1p-4p(fin) Pac, Tue 1:30p-4p(fin) Pac, Fri 1p-4p(fin)
20:24:36 <dconde> #info Monday is OK with me 1 pm
20:25:20 <regXboi> #info 1-2 pm monday 1-2:30 pm tuesday nothing wed
20:25:21 <tbachman> #info Monday at 1pm is fine with me
20:27:05 <alagalah> #action regarding moving meeting: alagalah to reschedule STATUS meeting to 5/19 13:00 Pac recurring (1hr)
20:27:18 <dconde> #info yes, 1:30 is OK
20:28:13 <alagalah> #action 13:00 struck down.... regarding moving meeting: alagalah to reschedule STATUS meeting to 5/19 13:30 Pac recurring (1hr)
20:28:34 <dconde> #agreed new time for meeting
20:28:43 <dconde> #info be careful of -2 votes
20:29:12 <dconde> #info only way to remove -2 is the original reviewer to change it.
20:29:14 <alagalah> #action re: regXboi action item on gerrit review vote of -2... -2 blocks merge until removed.
20:29:39 <s3wong> well, to be fair, the Neutron GBP IRC meeting doesn't really conflict with ODL GBP status meeting (one is 11am PDT, and the other is 1pm); but I am not complaining about the time change
20:29:51 <alagalah> #topic Plan of Record
20:30:21 <alagalah> #link https://docs.google.com/a/noironetworks.com/spreadsheets/d/1Tp2dblnizQ4xi_4xcQgHP8dRPiqxdgC9pqlRdEuP6_I/edit#gid=0
20:31:30 <dconde> Look at https://wiki.openstack.org/wiki/Meetings/Neutron_Group_Policy
20:32:54 <s3wong> Coming to Noiro office, need to drop off from IRC/meeting for a moment
20:35:26 <dconde> #info we agreed to ignore the prior meeting change discussion.
20:37:08 <dconde> #info Liem set down to zero for resources due to some conflicts.
20:37:26 <dconde> #info regxboi wants to fill in and float in
20:38:01 <dconde> #ifo alagalah says that is ok
20:38:33 <dconde> #info uyen is working on use cases together with lenrow
20:38:50 <dconde> #uyen working on model side
20:39:03 <dconde> #info uchau working on model
20:40:39 <dconde> #action plan of record is agreed upon
20:41:34 <mickey_spiegel> #action Each developer/contributor to review tabs and self assign themselves to a sub-project that they would like to work on
20:42:19 <tbachman> #info we're at our limit of 10 on hangout
20:42:25 <dconde> #action please a question mark on column A if you are not sure which subgroup you can work on, if you do know, please that in column a
20:43:03 <alagalah> #topic Trello accounts
20:43:34 <dconde> #info trello accounts are driven from Google accounts. Trello is a kanban board. it is used to see who is working on what.
20:43:50 <dconde> #info we are not using it for full Agile method.
20:43:58 <dconde> #info trello for day-to-day
20:44:19 <dconde> #action will people #info their names and ID into the IRC so we can set up Trello accounts.
20:44:32 <dconde> #info this applies to committers.
20:45:18 <regXboi> #info regXboi@gmail.com
20:45:21 <jmedved> #info Jan Medved = jmedved
20:45:25 <dconde> #info regxboi asks is that Google ID?
20:45:41 <dconde> #info alagalah says just use your email. cn be gmail or whatever.
20:45:57 <regXboi> #info oops regxboi@gmail.com
20:46:07 <rexpugh-HP> #info rex pugh = rex.pugh@hp.com
20:47:07 <tbachman> #info Thomas Bachman tbachman@yahoo.com
20:48:15 <dconde> #info you need to install scrum for trello
20:48:18 <alagalah> #info please install scrumfortrello.com
20:48:51 <dconde> #info there are chrome/ffox or safari extensions
20:49:28 <dconde> #info note, we are not doing formal scrums. We're just using these tools.
20:51:44 <dconde> #info alagalah sharing desktop
20:52:11 <dconde> #info we are showing the renderer whiteboard diagram.
20:52:50 <tbachman> #info when regXboi is happy, life is good
20:53:02 <alagalah> #topic YANG review - Rob Adams (and our first commit)
20:53:09 <dconde> #ifo readams is describing what he achieved.
20:53:28 <dconde> #info a yang model has rough approx of policy model
20:53:56 <dconde> #info changed some model elements in clause/object area.
20:54:07 <dconde> #info added cross tenant contracts
20:54:22 <dconde> #info policy model is separate from end point repo
20:54:51 <dconde> #info they generate code. less horrific java code. and got it to a local minima of horribleness
20:55:15 <dconde> #info toaster example does not work yet.
20:55:51 <dconde> #info in theory, all of this (i.e REST calls) should work, but who knows why it does not work today.
20:56:04 <dconde> #info jmedved asks "did you try archetype?
20:56:16 <dconde> #info stock ODL is run by readams. and they do not work
20:56:36 <dconde> #info there is another example that may be better suited.
20:57:30 <dconde> #info some people are supposed to be fixing it. like people from brocade.
20:58:26 <dconde> #info jmedved not sure if those changes were merged yet. may be in gerrit
20:58:51 <alagalah> #action readams says that the YANG model is not working, but also the "Toaster" example doesn't work. jmedved says it should work, so asked readams to email alias. jmedved to link archetype as well. Email alias controller-dev@ and discuss@
20:59:05 <jmedved> https://wiki.opendaylight.org/view/OpenDaylight_Toolkit:MD-SAL-Simple_Archetype
20:59:09 <dconde> #info jmedved is cpoying to IRC on some other ideas.
20:59:57 <dconde> #info it does provide skeletons for provider and consumer.
21:00:09 <dconde> #info readams just wants config to work. jmedved says you need a provider.
21:00:23 <dconde> #info regxboi leaving.
21:00:48 <dconde> #info harman singh is working on that
21:00:53 <jmedved> Harman singh
21:00:55 <alagalah> jmedved: can you #info his details here please ?
21:01:03 <alagalah> jmedved: email or IRC nick please
21:02:44 <dconde> #info jmedved thinks harman singh does not come to IRC.
21:02:47 <jmedved> harmasin@cisco.com
21:03:15 <alagalah> #info harmasin@cisco.com is a contact for readams to contact for YANG Toaster etc
21:03:35 <dconde> #info jmedved says toaster may be out of his hands, but with archetype can be something he can assist on
21:04:52 <alagalah> #topic JSON generation from Use Case - Keith (due for ARCH/MODEL sub-group)
21:05:15 <dconde> #info whiteboard session for use-cases
21:05:24 <dconde> #info looking at screen share now.
21:05:44 <dconde> #info dvorkinista laid out a use case and diagram.
21:06:38 <dconde> #info he went through qualities, conditions, etc. and a related YANG model
21:06:47 <dconde> #info with right tags, etc.
21:07:12 <dconde> #info so write up the example in the policy model.  it has all the right objects.
21:08:37 <dconde> #action if you need clarification on the model alagalah described, please spek up.
21:08:47 <mickey_spiegel> #action Keith to write up detailed 3-tier example with contracts, break that down through the yang model, create JSON input
21:10:49 <alagalah> #endmeeting