17:05:16 <dconde> #startmeeting MODEL
17:05:16 <odl_meetbot> Meeting started Fri May  2 17:05:16 2014 UTC.  The chair is dconde. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:05:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:16 <odl_meetbot> The meeting name has been set to 'model'
17:05:21 <dconde> #chair alagalah
17:05:21 <odl_meetbot> Current chairs: alagalah dconde
17:05:42 <dconde> #info jmedved was to convert model to YANG
17:05:50 <dconde> #info and workarounds and changes to model
17:06:11 <dconde> #info recap coming w/ requirements of model
17:06:23 <dconde> #info YANG cannot expressed self contained constructs
17:06:33 <alagalah> #topic Discussion of YANG and UML capabailities
17:06:36 <dconde> #info linear chains are preferred to mimic containment
17:06:42 <alagalah> #info jmedved was to convert model to YANG
17:06:46 <alagalah> #info and workarounds and changes to model
17:06:51 <alagalah> #info recap coming w/ requirements of model
17:06:55 <alagalah> #info YANG cannot expressed self contained constructs
17:07:04 <dconde> #info how to implement nested logical stmts
17:07:20 <dconde> #info we can either keep formulas as blobs or str
17:07:24 <alagalah> #info specifically for matchers
17:07:31 <dconde> #info for simplify the matchers.
17:07:39 <dconde> #undo
17:07:39 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1608ad0>
17:07:47 <dconde> #info to simplify the matchers
17:09:00 <dconde> #info we will use YANG as a authoritative description of model, rather than diagram
17:09:08 <dconde> #info from readams
17:09:29 <dconde> #info ought to extend YANG?
17:09:29 <alagalah> #action dvorkinista (Mike D) to modify Matcher logic to be either ANDs, ORs, with Label EXCLUDE for negation. This will be a single level ie (A AND B AND C), (A OR B OR C), EXCLUDE (A AND B)
17:09:43 <dconde> #info but that is second phase.
17:10:17 <dconde> #info dvorkinista recommends no circumstances and scoring.
17:10:29 <dconde> #info assume there exists a governance system to update the endpoints.
17:10:38 <dconde> #info as an external input
17:10:48 <mickey_spiegel> #info here
17:11:14 <dconde> #info it will not reduce the attractiveness of the model.
17:11:47 <dconde> #info lenrow says we don't need to do all the use-cases.
17:12:27 <dconde> #info no matter what we do, we have to architect for extensibility.
17:12:41 <alagalah> #topic MD-SAL / YANG requirements discussion - broader discussion
17:13:33 <dconde> #info best thing for community is to look at readams's paper on how we can achieve goals for simplification.
17:13:46 <dconde> #info paper to be finalized and shared next week.
17:14:02 <dconde> jmedved
17:14:05 <dconde> are you there?
17:14:37 <dconde> #info we will assume jmedved is in agreement. since he wasn't on this moment.
17:15:37 <dconde> #info we can look at what readams has transcribed.
17:15:59 <dconde> #topic review of readams's yang model for 0.97
17:16:35 <dconde> #info we are reviewing the doc now on hangout screen share now.
17:16:39 <jmedved> readams: when wil lthe paper be available?
17:17:41 <dconde> #info early next week
17:17:43 <alagalah> jmedved: Tue latest
17:17:47 <alagalah> jmedved: COB
17:18:14 <dconde> #info trying to get inhr and obj modl to map to UML doc.
17:18:25 <dconde> #info challenge. model is complex
17:19:29 <dconde> #info starting w/ jmedved's model and adding constructs - issues are complexity and decipher the  "runes" w.r.t. inconsistencies that readams will rsolve w/ dvorkinista
17:19:42 <dconde> #info same type @ two levels of hier.
17:20:26 <dconde> #info he is using grouping but still needs to be mapped to a different location.
17:22:35 <dconde> #info running into restrictions Java that is generated.
17:23:15 <dconde> #info other challenge. relator object
17:23:52 <dconde> #info inheritance is problematic.  children override values, so what should be in base class?
17:24:21 <dconde> #info are you using AUGMENT?  readams is using groupings.
17:25:21 <dconde> #info discussing whether we are overriding base types.  how best to do that?
17:26:22 <dconde> #info if super class has restrictions, we can reason at that level? or shall we use REFINE stmt?  It's all tricky.
17:27:23 <dconde> #info dvorkinista says we used to have match type in relator in original. so we have a vestigial item that needs to resolved.
17:28:01 <dconde> #info it's possible to just have a relator. use a target, selector, and that's it. can be named or not-named.
17:29:52 <dconde> #info dvorkinista is fine not using inheritance.
17:30:15 <dconde> #info relator can be a providing selector or a consumer selector. do not treat them as separate things.
17:31:18 <lenrow> Is this GBP arch meeting or GBP model meeting (or are they one and the same now)?
17:31:33 <dconde> thi sis the MODEL meeting.
17:31:45 <raghu67> ARCH meeting follows at 11
17:32:01 <lenrow> Great thanks. I'll update the Wiki.
17:32:33 <dconde> #info once we have a proper model, it will be resolved in a concrete yang model
17:32:51 <dconde> #info yang becomes authoritative.
17:33:36 <dconde> #info but let us remembe that UML is easier to read...
17:34:19 <dconde> #action alagalah will write a whitepaper that describes the UML model.
17:35:01 <dconde> #info and text is ambiguous. so we do not want to replace UML
17:35:36 <dconde> #info should we annotate UML? dvorkinista prefers that.
17:36:20 <dconde> #info we will disucss how best to do it
17:36:32 <dconde> #action we will annotate UML instead -- alagalah
17:37:07 <dconde> #info lenrow has a "for dummes" draft in progress.
17:38:25 <dconde> #topic open forum.
17:39:09 <dconde> #info mickey_spiegel notices that many pages of model refers to same thing. dvorkinista says it is used to describe concept.
17:39:26 <dconde> #info alagalah says each page tries to express a concept in context.
17:40:24 <dconde> #action dvorkinista to restruct model in structure, definition use
17:40:47 <dconde> #info lenrow questions.
17:41:19 <dconde> #info is traffic chaining expression difficult?
17:41:41 <dconde> #info we are missing some items. like sensitivities !
17:42:09 <dconde> #info dvorkinista will update model according to how it was expressed in YANG.
17:42:44 <dconde> #info we meant to say service chaining, not traffic chaining.
17:43:29 <dconde> #info let us try to model this. we are trying to pull in people from L4-L7 companies for their perspective.
17:44:39 <dconde> #info let's have a discussion on what to include --
17:45:12 <dconde> #info we are speculating what RADware wants to do, or F5.
17:45:23 <dconde> #info there is a project proposal for service chaining and see if it's common or not.
17:46:35 <dconde> #info new svc chaining encapsulation type -- being proposed.
17:47:04 <raghu67> #link https://wiki.opendaylight.org/view/Project_Proposals:Service_function_chaining
17:47:30 <dconde> #info project is service function chaning that is being proposed.
17:47:38 <dconde> #info visions from ETSI and IETF, etc.
17:48:43 <dconde> #info there are lots of projects with some overlap
17:48:53 <dconde> #info we can render to it.
17:49:56 <dconde> #info mickey_spiegel says - is this a matter of rendering, or referring to their model?
17:51:32 <dconde> #info they are concentrating on instance. GBP can focus on policy. this is complementary.
17:52:11 <dconde> #info we will have a conversation.
17:52:35 <dconde> #action alagalah will talk w/ ewarnicke
17:53:03 <dconde> #action alagalah will talk w/ ed warnicke regarding service chaining.
17:54:30 <lenrow> typing is muting you guys
17:54:42 <dconde> ack
17:55:29 <dconde> #info their diagram has more stuff than svc chaining ought to have.
17:56:19 <dconde> #endmeeting