17:05:23 <regXboi> #startmeeting model subgroup
17:05:23 <odl_meetbot> Meeting started Fri May 16 17:05:23 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:05:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:23 <odl_meetbot> The meeting name has been set to 'model_subgroup'
17:05:33 <regXboi> #chair tbachman
17:05:33 <odl_meetbot> Current chairs: regXboi tbachman
17:05:40 <tbachman> topic?
17:05:42 <regXboi> #chair readams alagalah
17:05:42 <odl_meetbot> Warning: Nick not in channel: alagalah
17:05:42 <odl_meetbot> Current chairs: alagalah readams regXboi tbachman
17:05:51 <tbachman> he's got a "_"
17:05:52 <tbachman> fancy
17:05:56 <regXboi> #nochair alagalah
17:05:56 <alagalah_> #link https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:MODEL#Team_Meeting
17:06:01 <regXboi> #chair alagalah_
17:06:01 <odl_meetbot> Current chairs: alagalah alagalah_ readams regXboi tbachman
17:06:15 <regXboi> #unchair alagalah_
17:06:15 <odl_meetbot> Current chairs: alagalah readams regXboi tbachman
17:06:22 <tbachman> #topic white board diagram of 3-tier to JSON
17:06:28 <tbachman> regXboi: lol
17:07:29 <tbachman> #info alagalah created JSON of 3-tier model
17:07:48 <alagalah> #info Regarding action of 3 tier app softcopy and JSON generation find information here:
17:07:53 <alagalah> #action https://drive.google.com/folderview?id=0BztNICcppsJKY0tMRl8tVlBQN2s&usp=sharing
17:08:24 <alagalah> #info work in progressw
17:08:38 <tbachman> #topic Create power point of 3-tier
17:08:50 <tbachman> #info work in progress -- task takes time
17:08:55 <alagalah> #info action from last meeting: alagalah to instead of writing whitepaper or annotating the UML to write a PPT with animations that describes the UML model with annotations.
17:09:01 <alagalah> #info WIP : blocked on time
17:09:24 <alagalah> #info Action: dvorkinista to restruct model in structure, definition use - has not had time.
17:09:31 <alagalah> #info no update, Mike at OS summit
17:09:44 <alagalah> #info Action: alagalah regXboi edwarnicke to discuss service chaining, specifically their datastore/subscription requirements and how they are planning on addressing this with MD-SAL etc
17:10:16 <tbachman> #topic Action Items (though look to other topics on resolution -- didn't get topics right at first)
17:10:35 <alagalah> #action alagalah to schedule meeting with edwarnicke and regxboi (possibly ChrisPrice) to discuss Action: alagalah regXboi edwarnicke to discuss service chaining, specifically their datastore/subscription requirements and how they are planning on addressing this with MD-SAL etc
17:11:29 <alagalah> #info Action: alagalah meeting with Uyen, Rex, Dave Lenrow, regXboi to discuss Use-Case -> UML -> JSON "conversion" ... 14:30 Pac Fri May9
17:12:10 <tbachman> #info meetings have been ongoing -- Unified communications use case with proactive flows. Team has been working on mapping use case to the model
17:13:21 <tbachman> #info Microsoft Lync uses many ports, so the question has been of how to provide information for classifier so that renderer can install flows between session peers.
17:13:42 <tbachman> (uchau: feel free to amend these if I get them wrong ;)
17:14:08 <uchau> not what alagalah is saying
17:14:15 <uchau> but more of what we decided on :)
17:16:27 <tbachman> #info plan is to manage call setup of 200+ per second
17:16:56 <tbachman> #info readams says that changing the config dynamically is not the way to do this
17:17:22 <tbachman> #info classifier represents dynamic concept, such as lookup in database (i.e. look up of metadata)
17:21:04 <tbachman> #info readams recommends move lookup of 5-tuple to different store, which better supports the applications needs
17:23:59 <tbachman> #info readams says operational data doesn't belong in the policy, which is a configuration store
17:28:32 <tbachman> #info mickey_spiegel notes that we're maybe talking about two APIs here.
17:29:10 <tbachman> #info readams asks if there is an orchestration system for the UC&C application to orchestrate this
17:29:26 <tbachman> #info uchau says there's an application on the controller (idea is based on ONF use case)
17:29:54 <tbachman> #info user app is integrated with UC&C system, network app that is part of the contoller, and is policy based system
17:32:09 <tbachman> #info readams says that GBP does not make sense as a generic midlleware layer
17:33:24 <tbachman> #info GBP model is different from the way normal network management is done.
17:35:00 <tbachman> #info mickey_spiegel notes asks for definition of what uchau means by policy
17:35:31 <tbachman> #info losing audio
17:36:49 <tbachman> #info regXboi is concerned about narrow definition of what GBP is trying to provide (e.g. SFC)
17:37:23 <tbachman> #info if there are orchestration systems NB with a different definition of policy model, he doesn't want us to say "oh we can't talk to you"
17:37:50 <tbachman> #info readams notes that if the model is based on fundamentally different principles, this might not make sense.
17:38:49 <tbachman> #info regXboi notes that this has to work with other orchestration systems (cough cough *openstack* cough cough)
17:38:53 <alagalah> ping we have network issues here... its seems new sessions cant be made
17:40:41 <tbachman> #info readams asserts that in cases where user sees endpoints and communication between these groups of endpoints, then GBP works well
17:41:45 <regXboi> uchau: not everybody is near the mike
17:41:49 <regXboi> er mic
17:43:03 <tbachman> #info uchau says that there are users who want to establish link calls
17:43:34 <tbachman> #info losing audio
17:53:03 <tbachman> #info there are two broad categories of data: operational state data and configuration data
17:53:17 <tbachman> #info for example, a new session could be considered operational state data
17:53:35 <tbachman> #info the policy needed by a session is considered configuration data
17:54:05 <tbachman> #info define a classifier that is "link communication", as "anything that is communication on an active link session"
17:55:47 <tbachman> #info semantics around operational and configuration state data are different
17:55:58 <tbachman> #info persistence, transactionality, referential integrity
17:56:16 <tbachman> #info This affects how we represent this data
17:57:14 <tbachman> #info question of can we change actions, classifiers, or tenants in a dynamic fashion?
18:00:17 <tbachman> #info it's 11am PST
18:00:26 <tbachman> we're officially over folks
18:00:33 <regXboi> we are going to bleed over
18:00:58 <tbachman> should we continue this in the next hangout?
18:01:57 <regXboi> let me break in and ask :)
18:02:01 <regXboi> and thanks for scribing
18:02:14 <tbachman> regXboi: no problem!
18:02:22 <tbachman> you carry the burden most of the time!
18:06:15 <tbachman> #endmeeting