17:04:53 <dconde> #startmeeting ODL-GBP-MODEL
17:04:53 <odl_meetbot> Meeting started Fri May 23 17:04:53 2014 UTC.  The chair is dconde. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:04:53 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:04:53 <odl_meetbot> The meeting name has been set to 'odl_gbp_model'
17:05:49 <dconde> Advertisement from Google!  You want to buy a new keyboard
17:06:12 <alagalah_> hey
17:06:28 <alagalah_> click click click
17:06:46 <dconde> #chair regxboi
17:06:46 <odl_meetbot> Current chairs: dconde regxboi
17:07:09 <alagalah_> ejkwklj/fsaklaklsaklslkkl;asl;asf;safkl;safkl;sakl;csakl;Tyoping noises
17:07:16 <alagalah_> tap tap tap tap
17:07:22 <tbachman> #info it’s Friday
17:07:42 <dconde> #chair alagalah
17:07:42 <odl_meetbot> Warning: Nick not in channel: alagalah
17:07:42 <odl_meetbot> Current chairs: alagalah dconde regxboi
17:07:43 <dvorkinista> #info Friday morning typing experiment.
17:07:53 <dconde> #chair alagalah_
17:07:53 <odl_meetbot> Current chairs: alagalah alagalah_ dconde regxboi
17:08:11 <dconde> #topic review model
17:08:19 <s3wong> we have both alagalah and alagalah_ as chairs
17:08:24 <dconde> #info questions on model? by readams
17:08:39 <dconde> #info one thing that may be useful is to look at the latest file
17:08:58 <dconde> #info jan wants deleta
17:09:02 <dconde> #info adding context
17:09:08 <dconde> #info rename role into requirements
17:09:13 <dconde> #info moving stuff around to the back
17:09:17 <dconde> #info change to structure of document
17:09:22 <dconde> #info no semantic change
17:09:46 <dconde> #info change not pushed into repo is the removing of namespace inheritance mapper in the parameters.
17:10:15 <dconde> #info the way inheritance working is that it does not add much. name can be in te matcher itself
17:10:27 <dconde> #info no useful way of using it.
17:11:07 <dconde> #info matcher quality vs. matcher xyz on the same name space was not too useful.  It's best to define a different matcher with different semantics.
17:11:19 <dconde> #info you can still over-ride it.
17:11:42 <dconde> #info when you inherit a matcher. there are matcher labels with the addition of NS parameters (NS=name space)
17:11:57 <dconde> #info a lebel in the child EPG inheri fro parent EPG
17:12:12 <dconde> #info if the label with the same name in the child, it replaces it.
17:12:45 <dconde> #info if it is defined in the child, it over-rides the parent matcher.
17:12:57 <dconde> #info can you exclude a label? Yes.
17:13:49 <dconde> #info if you define a label in child of anything, it will override the parent UNLESS you set hte inheritance to exclude, then the label will not be there.
17:13:58 <dconde> #info that is called the inclusion rule.
17:14:39 <dconde> #info dvorkinista says it's like the polymoprhism.
17:15:44 <dconde> #info we can add overrides later.  We should not import all semantics of programming languages into this this, just because you can.
17:16:21 <dconde> #info uchau is talking about complex typse.
17:16:37 <dconde> #info yang tools do not support that? can jan confirm that?
17:16:46 <dconde> #info it's just not implemented in ODL? asks uchau
17:17:07 <dconde> #info can we just put chd inside parent in complex types.
17:17:27 <dconde> #info dvokinista says that is discourged in obj oriented systems.
17:17:33 <dconde> #info the model is reasonable, says readams.
17:17:44 <dconde> #info janmedved was there when it was defined.
17:18:10 <dconde> #info this is the best we can do. we can explore extension to YANG. it does complicate things.
17:18:36 <dconde> #info tree structure and the simple way to create it is lending itself to a simple implementation. we are exploring extension to YANG.
17:19:24 <dconde> #info there aer advantages in lookup behavior in doing it that way.
17:20:00 <dconde> #info uchau it is simpler from tree traversal point of view.  it would be nice, dvokinista agrees it would be nice.
17:20:30 <dconde> #info we can return link to parent in REST API, for example.
17:20:34 <dconde> #info said readams.
17:20:50 <dconde> #info when you have a ref to someting in a subtree, we can include an actual URI.
17:21:00 <dconde> #info regxboi gets clarified.
17:21:27 <dconde> #info regxboi says RESTconf does not do that today. it's a pointer, not a URI
17:21:45 <dconde> #info we can do an extension , says readams
17:22:12 <dconde> #topic traffic
17:22:19 <dconde> #info traffic within an EPG
17:22:27 <dconde> #info 1) always allowed.
17:22:39 <dconde> #info 2) traffic not allowed, and we need to enable it via a CONTRACT
17:23:02 <dconde> #info dvorkinista says allow is like how VLANs work.
17:23:12 <dconde> #info not allowed is like VDI.
17:23:24 <dconde> #info or do a contract, that satisfied HP requirements.
17:23:57 <dconde> #info challenge - how to define the policy in multi-cast and broadcast. Between EPG we can do unicast
17:24:10 <dconde> #info if we ignore multicast, we can have a peering contract.
17:24:44 <dconde> #info define a set of sibjects within EPG
17:24:49 <dconde> #info or define a peer.
17:25:34 <dconde> #info we need a way to apply a contract by stating it's a peer -- no direction.
17:26:06 <dconde> #info we can say something like EPG -- all elements are allowed, or we can say all classifiers are interpreted as bidi as a peer.
17:26:18 <dconde> #info since we do not want to define a new type of classifier with no direction.
17:26:55 <dconde> #info we can prefabricate things, and put tha tinto the group itself.
17:27:06 <dconde> #info but that complicates things, says dvorkinista
17:27:15 <dconde> #info we need a differet model
17:27:24 <dconde> #info we need a new MODE.
17:27:43 * tbachman thinks regXboi might be raising his hand
17:28:16 <dconde> #info regxboi says - his gut reaction is lot of complexity for small incr. gain.
17:28:29 <dconde> #info readams -- outside a Datacenter, we need it.
17:28:34 <dconde> #info regxboi cries fowl
17:28:53 <tbachman> foul even :)
17:29:12 <dconde> #info dvorkinista says we have requirements for different use cases from yesterday.
17:29:15 <dconde> cluck
17:29:18 <tbachman> lol
17:29:57 <dconde> #info less moving parts is better?
17:30:15 <dconde> #info regxboi says -- to degenerate conclusion, we need to to talk about contracts on EP?
17:30:23 <dconde> #info people say no, it's a group attribute.
17:30:45 <dconde> #info you either turn all OFF or ON, or provide a contract.
17:31:10 <dconde> #info we can have a bunch of app servers, and allow no HTTP or SSH, and only allow control protocols.
17:31:40 <dconde> #info we need a model on the EPG for allow or deny.
17:32:18 <dconde> #info dvorkista this enables unified communications - sessions between different callers (End Pts)
17:32:49 <dconde> #info boundaries are a TENANT.
17:33:07 <dconde> #info cross tenant mutations -- have particular mechanisms for that.
17:33:27 <dconde> #info uchau needs clarification.
17:33:54 <dconde> #info EP are producer/consumer. we are introducing a ShORTcut since it's highly inconvenient.
17:34:00 <dconde> #info we want to emulate VLAN behavior.
17:34:15 <dconde> #info ans also the VDI behavior when no endpoint can talk to each other.
17:34:34 <dconde> #info traffic belongs are defined as something within a group.
17:34:50 <dconde> #info that makes it easier to understand.
17:34:58 <dconde> #info we are folding contract concept within an EPG?
17:35:13 <dconde> #info you will need to select contract by name
17:35:30 <dconde> #info so we cannot enable anyone else to name and consume traffic.
17:36:06 <dconde> #info are we stepping into restrictions?
17:36:22 <dconde> #info it's not an issue of who gets to consume or not.
17:36:32 <dconde> #info semantics for peer A can talk to Peer B
17:36:47 <dconde> #info where does that get folded? in a contract.
17:36:59 <dconde> #info uchau says do we have a special selector
17:37:17 <dconde> #info we will have a special peer thing. for unified comm. we want to specify it once.
17:38:03 <dconde> #info a select pts to a contract and then within a contract . how do we do the peer-to-peer association
17:38:08 <dconde> #info a group specified a session.
17:38:23 <dconde> #info if there are two EP, then there are 2 EP in a group.
17:39:28 <dconde> #info we define a contract for the ENTIRE group.
17:39:38 <dconde> #info we are not talking about End point to End point contracts.
17:40:03 <dconde> #info uchau needs clarification
17:40:21 <dconde> #info subgorup of two users?  Not really.
17:40:47 <dconde> #info lets say. session represents a group
17:40:56 <dconde> #info a set of ports that members of the group will be talking to.
17:41:24 <dconde> #info they will use the contracts that ….specify
17:41:35 <dconde> #info we are switching to the whiteboard.
17:42:40 <dconde> #info INTRA group comm via a PORT is a simple use-case
17:43:08 <dconde> #info now a diff example
17:43:18 <dconde> #info a DB cluster
17:43:29 <dconde> #info a contract called SQL is applied
17:43:46 <dconde> #info we want to restrict - to clustering protocol only.
17:44:04 <dconde> #info we say there is a peer within group pointing to clustering protocol contract.
17:44:24 <dconde> #info it is similar to contracts. it is scoped to group only
17:44:56 <dconde> #info what about direction?
17:45:55 <dconde> #info if a contracts has requirements/capability matchers. how do we eval them?
17:49:13 <dconde> her regxboi can you scribe?
17:49:21 <dconde> s/her/hey/
17:50:15 <dconde> #info any reason for a peer target selector? no
17:51:20 <dconde> #agreed name selectors are sufficient.
17:51:37 <dconde> #info how do we have tie breaker rules?
17:52:07 <dconde> #info if there are two, then we apply them in order.
17:52:17 <dconde> #info multiple contracts in scope is OK.
17:53:24 <dconde> #info under rule application, go read that. let readams if that's wrong.
17:53:39 <dconde> #agreed we need to go read it and then talk next week
17:54:06 <dconde> #info subject have order.
17:54:19 <dconde> #info we have ordering rules for how they are applied
17:54:31 <dconde> #info no mixing of rules in ACLs. that will not work.
17:54:43 <dconde> #info read rule applicaton secton and subjects under inheritance.
17:55:17 <dconde> #info regxboi says we are running out of time. he cannot make it to that one.
17:55:28 <dconde> #info regxboi delegates to mspiegel.
17:56:05 <dconde> #help
17:56:38 <dconde> #info uchau wants policu def in JSON fmt.
17:56:55 <dconde> #info please read Wiki and bring it up under RESTCONF now.
17:57:22 <dconde> #info ask readams postings under mailing list.
17:59:29 <dconde> #info if you go into swagger api docs, if you look at what it says, then only a small subset will work. so jan will look
17:59:47 <dconde> #info put and post have different impl, and we think semantics are slightly different.
17:59:57 <dconde> #info not high priorities.
18:00:38 <dconde> #info go look in YANG model for the fields in a JSON obj under relevant type
18:01:07 <dconde> #info use FireFox not Chrome
18:02:35 <dconde> #action readams will send link to mailing list on the use of REST API. -- it's better than curl from cmd line.
18:03:13 <dconde> #endmeeting