17:08:10 <dconde> #startmeeting ODL-GBP-MODEL
17:08:10 <odl_meetbot> Meeting started Fri Jun 13 17:08:10 2014 UTC.  The chair is dconde. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:08:10 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:08:10 <odl_meetbot> The meeting name has been set to 'odl_gbp_model'
17:08:19 <dconde> #chair dlenrow alagalah_
17:08:19 <odl_meetbot> Current chairs: alagalah_ dconde dlenrow
17:08:34 <dconde> #topic service_insertion
17:09:29 <dconde> #info we need to determine whether GBP does the plumbing for other service insertion projects
17:10:16 <dconde> #info readams says a pair of EP talking via a FW -- but we are restricted from dealing with this in a pairwise fashion.
17:11:34 <dconde> #info ways to reason about it.
17:11:52 <dconde> #info dvorkin says - group provides a contract … (he's drawing on board) then another group consumes a contract.
17:12:11 <dconde> #info within this grop, there is a subject to the conversation., let's say it's for HTTP for sake of argument
17:12:22 <dconde> #info action is specified to redirect to a service GRAPH
17:12:31 <dconde> #info let's actually call it a chain.
17:13:05 <dconde> #info there's an entry point an an out. and we stick devicess iside. for service functions. we may have direct return too.
17:13:28 <dconde> #info expressed from consumer's POV, we enter the service and we pop-out. It's VERY easy, right?
17:13:36 <dconde> #info but now, for the details.
17:13:46 <dconde> #info what if we try to do the following:
17:13:58 <dconde> #ifo a FW followed by a LB
17:14:05 <dconde> #info we have two VIPs in LB
17:14:37 <dconde> #info we have two poolls. grp 1 belongs to pool1, grp 2 belongs to pool 2
17:14:57 <dconde> #info it's no longer a chain, it's a GRAPH.
17:15:02 <dconde> #info so new semantics.
17:15:41 <dconde> #info if we have a WAF betwen pool 2 and grp 2
17:15:51 <dconde> #info if WAF a member of EPG or something else.
17:16:24 <dconde> #info as dlenrow said we treat service function as a group
17:17:11 <dconde> #info so we are drawing  group graph view
17:17:57 <dconde> #info do we don't wnt to get stuff confused with application intent.
17:20:22 <dconde> #info do we treat them as regular rules to redirect?
17:21:46 <dlenrow> #info probably need to treat tranparent functions differently from non-transparent
17:23:27 <dconde> #info we want these to be auto provisioned too.
17:23:31 <dconde> #info are we a plumber or what?
17:29:12 <tbachman> Is someone trying to speak on the hangout?
17:29:15 <tbachman> (mickey_spiegel maybe?)
17:29:31 <mickey_spiegel> Yes, trying to get some words in
17:30:08 <mickey_spiegel> Don't follow non-transparent as just endpoint group, since the packet between web and app has dest IP address of app, not firewall
17:31:15 <mickey_spiegel> But endpoint group web is still sending packets to app, happens to go through the firewall because that is default gateway
17:31:31 <mickey_spiegel> Contract still exists between web and app
17:32:31 <tbachman> mickey_spiegel: land-line?
17:32:47 <dconde> mickey_spiegel: we can call you
17:32:57 <dconde> mickey_spiegel: if you type in phone #
17:34:09 <dconde> #info mickey_spiegel says no everything is transparent.
17:40:45 <dconde> #info https://blueprints.launchpad.net/neutron/+spec/adv-services-in-vms
17:46:38 <dconde> #agreed we need to bring in others who are more familiar with the services world (Quinn)
17:48:14 <dconde> #info we are talking about http://tools.ietf.org/html/draft-quinn-sfc-arch-04
17:52:47 <dconde> ARCH meeting URL is https://plus.google.com/hangouts/_/calendar/ZHZvcmtpbkBub2lyb25ldHdvcmtzLmNvbQ.bps9id27mhd0pnqqljgjkckoqk?authuser=1
17:53:09 <dconde> #endmeeting