20:01:00 <dconde> #startmeeting ODL-GBP-REQUIREMENTS
20:01:00 <odl_meetbot> Meeting started Mon Jun  2 20:01:00 2014 UTC.  The chair is dconde. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:01:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:00 <odl_meetbot> The meeting name has been set to 'odl_gbp_requirements'
20:01:08 <dconde> #chair lenrow
20:01:08 <odl_meetbot> Current chairs: dconde lenrow
20:01:09 <lenrow> dconde thx
20:01:15 <Bhushan_> Are we using WebEx or Hangout?
20:01:25 <dconde> Bhushan_: we are using Hangout
20:01:29 <dconde> do you need link?
20:01:32 <lenrow> webex
20:01:38 <dconde> webex?
20:01:46 <dconde> I am on Hangout. so I will need to switch to it.
20:02:03 <lenrow> #info https://meetings.webex.com/collabs/#/meetings/detail?uuid=M4NPPO6UULL1B0DFPK2HQ9VZX8-9VIB&rnd=563175.79385
20:02:21 <lenrow> I expect first meeting will exceed hangout limit. Sorry dan
20:03:16 <dconde> OK. I will let peopl in hangout know.
20:07:50 <dconde> #topic goals
20:08:25 * regXboi is lurking on IRC so may inject questions into the stream
20:08:36 <dconde> lenrow is going through PPT
20:09:18 <dconde> goal is to try to make GBP the common NBI for declarative intent
20:10:06 <dconde> #info  new invitation sent from Mike with WebEx
20:10:19 <dconde> #info email came from dvorkinista
20:10:50 <dconde> #info want scale and perf requirements
20:12:12 <dconde> #info need three requirements that lenrow is showing
20:13:34 <dconde> #info 1. how powerful the model is? 2. rate of change and 3. expose declarative intent NBI to expose traffic sterring and redirection
20:15:13 <dconde> #info chrispriceab wants to avoid duality.
20:16:24 <dconde> #info dvokiinista wants to avoid duplicating what is in affinity group and other projects
20:17:07 <dconde> #info dvorkinista it can be rendered to affinity groups is needed
20:18:00 <dconde> #info lenrow agrees. given he write original proposal for affinity project
20:18:42 <dconde> #info dvorkinista shall we combine with affinity project?
20:19:40 <dconde> #info lenrow says affinity does not have activity
20:23:35 <dconde> #info chrisprice has concerns the if existing declarative API in ODL is not good enough if GBP there to fix it?
20:25:12 <dconde> #info point 4.
20:25:40 <dconde> #info dvorkinista wants transportable policy at a high level w/ operational policy that is enforced
20:27:36 <dconde> #info dconde asked about alignment w/ Neutron
20:27:59 <dconde> #info we want to create a general declarative model.
20:28:52 <dconde> #info lenrow says putting ikeeping network state in black box is better
20:28:57 <regXboi> #info not on call but if you are talking about general declarative model, are you looking more at Congress?
20:29:27 <dconde> #info dvorkinista says neutron mixes some concepts.
20:29:56 <regXboi> dconde: see about info from me with question
20:30:13 <regXboi> s/about/above/
20:30:39 <dconde> regXboi: no, we know about congress but we are not talking about it right now
20:30:47 <regXboi> ok
20:31:11 <dconde> regXboi: it's more about neutron
20:31:58 <dconde> #info alagalah says if we talking about steering, that's OK, but computation is different.
20:32:05 <dconde> #info then it's about Congress
20:32:48 <dconde> #info VMware says Congress is governance not orchestration (Heat)
20:32:57 <dconde> #info says dvorkinista
20:33:29 <dconde> #topic questions to answer
20:33:43 <dconde> #info seeing lenrow 's next slide
20:34:25 <regXboi> dconde: will the slides be put on the wiki?
20:34:34 <regXboi> dconde: or are they on the wiki with a #link here?
20:34:35 <regXboi> :)
20:34:36 <dconde> #info I presume so. It's lenrow who has it
20:35:07 <dconde> #info who is the audience for GBP?
20:35:34 <dconde> #info dvorkinista intent, governance and operational are three separate things. to be reasoned differently.
20:37:35 <dconde> #info dvorkinista says policies were defined without identifiers. EP's enable items to be attached to it.
20:38:23 <dconde> #info the group is persistent
20:38:42 <dconde> #info dvorkinista policies are meant to be devoid of identifiers.
20:41:33 <dconde> #info dvorkinista explained function of the end point registry.
20:42:16 <dconde> #info lenrow then direct vs. indirect approach may not be relevant as shown in slide #5.
20:42:39 <dconde> #info lenrow tallks about federation of controller. dvorkinista wants to solve it, but it's difficult.
20:42:53 <dconde> #info dvorkinista says unlikely to be in first cut
20:43:21 <dconde> #topic other items to discuss
20:43:59 <dconde> #info prove policies for regulatiotory compliance? asks lenrow re: financial customers.
20:44:42 <dconde> #info dvorkinista that's tracability of rendering.
20:45:19 <dconde> #info dvorkinista that's not enough. people from Univ of Illinois are looking at that. wish we can do that but that's beyond scope.
20:46:10 <dconde> #info dvorkinista says it's a big deal, but worried "if you step wide, then your pants will run"
20:48:31 <dconde> #info we can do some user-side valdation of use cases
20:48:45 <dconde> #info dconde says we can have some canonical use casss we can show to customers.
20:49:26 <dconde> #info sanjay making comments on analytics and provability.
20:50:03 <dconde> #info it will items on reachability, routing, etc. that are beyond policy
20:50:35 <dconde> #info dvorkinista once we get into L4-L7 it beomes very complex.
20:51:13 <dconde> #info lenrow it would be great to get those validated from the "buy" side - as opposed to vendors
20:51:45 <dconde> #info sanjay agrawal says that it could be done here (the analytics part) but not the probing part.
20:52:07 <dconde> #info stuff like these EPs' will never talk to each other.  That cab be analyzed.
20:52:40 <dconde> #info dvorkinista says there can be many more use cases wehre it will be useful, beyond GBP.
20:54:41 <dconde> #topic audience slide
20:54:45 <dconde> #into to be skipped
20:54:51 <dconde> #topic methodology
20:54:58 <dconde> #info proposal 5 use cases
20:55:58 <dconde> #info of 5 use cases, 3 chosen by ONF
20:56:39 <dconde> #info multi-tier, NetVirt, DDOS traffic steerign are the three
20:56:52 <dconde> #info next two are UC&C and IETF SFC
20:57:10 <regXboi> dconde: how is IETF SFC different from multi-tier?
20:57:26 <dconde> regXboi: lenrow will talk in a moment
20:57:37 <regXboi> dconde: I'm not on the call :)
20:57:46 <regXboi> need to get the differences into the minutes
20:57:50 <dconde> regXboi: please wait -- I will type
20:58:25 <s3wong> SFC is service function chaining, right?
20:58:26 <dconde> sfc = service function chaining, regXboi
20:58:44 <dconde> #info dconde asks itns NETVIRT a huge, broad topic?
20:59:21 <regXboi> I know what SFC is... I see that as a super-set of multi-tier (without more clairification)
20:59:23 <dconde> #info lenrow says netvirt of connectivity is simple.  when you layer on SLA, QOS, ACL then it's policy
21:01:05 <dconde> #info dvorkinista and others saying we ought to drill down into what Netvirt means.
21:01:22 <dconde> #info dconde says if we choose a more concrete subset, it's OK.
21:01:52 <dconde> #info dvorkinista says lets put some bullet points under net virt
21:02:37 <dconde> regXboi: we are stating that SFC dicussion is a subset .
21:02:53 <dconde> #info sanjay wants to add global enterprise app access as a use case
21:03:05 <regXboi> hmm... I'll need to see the use cases and slides and make comments on the ML
21:03:19 <s3wong> well - network virtualization seems more like a possible enabling technology for GBP, but don't see how GBP is used for network virtualization
21:03:19 <regXboi> still looking for that #link :)
21:03:25 <dconde> #nfo users come based on location, net posture, etc.
21:03:40 <dconde> regXboi: lenrow is doing screen share so will ask at end
21:03:49 <dconde> #info sanjay is taling about enteprise access control
21:04:05 <regXboi> #info users come based on location, net posture, etc.
21:04:34 <dconde> #info talking of more WAN use cases. lenrow says maybe chrisprice can add those?
21:05:00 <dconde> #info sanjay says enterprise WAN, but Chris may want service provider use cases too.
21:06:00 <dconde> regXboi: the slide is just 5 bullet points, so it's basic. I think there are more detailed stuff lenrow has.
21:06:25 <dconde> #info chrisprice says let's look at enterprise first before doing service provider (100's of millions)
21:06:36 <dconde> #agreed that we ought to do enterprise first as priority
21:08:08 <dconde> #info dconde asked about regXboi 's question on SFC
21:08:34 <dconde> #info multi tier IAAS is similar to ONF
21:08:57 <dconde> #info based on dvorkinista and Micorosft use cases. dvorkinista also talks of media companies' use cases tehre for IaaS
21:09:20 <dconde> #info multi-tier has snapshot/coine
21:10:53 <dconde> #info dconde asks about how we prioritize them?
21:11:16 <dconde> #info lenrow says ONF had done some prioritization already to avoid too much analysis paralysis.
21:12:57 <dconde> #info we ask whether these 5 are eough. Sanjay says these 5 covers the enterprise for the time being.
21:13:19 <dconde> #info lenrow as long as we describe them well, we are OK, sine UC&C use case is complete.
21:14:12 <dconde> #info we can spend a few hours over next two weeks to elaborate on the use-cases
21:14:32 <dconde> #info sanjay asks should we start with the description, rather than PPT?
21:15:07 <dconde> #info lenrow is open to methodology.
21:15:29 <dconde> #info dvorkinista says let's not create bureaucracy for sake of it.
21:15:59 <dconde> #info mickey_spiegel can we let people do doc ahead of time and meet to go over?
21:16:20 <dconde> #info lenrow concerned we will add tons of use cases in call.
21:17:07 <dconde> #info lenrow is willing to contribute some of thee use cases that have been examined for a long time.
21:17:26 <dconde> #info dvorkinista expected format?
21:17:46 <dconde> #info lenrow will do a sample based on ONF use-case doc.
21:18:17 <dconde> #info lenrow will make sure ONF doc is public (vs. private )
21:18:29 <dconde> #action lenrow will check if ONF use cases can be shared
21:21:34 <dconde> #info uchau1 are we describing it in terms of precise GBP starting points, or?
21:22:01 <dconde> #info dvorkinista let's descrbie the principles and then how it can be mapped into GBP. Quantitative /Qualittative requirements.
21:22:24 <dconde> #info so use first order principlles first. says dvorkinista
21:25:58 <dconde> #info dvorkinista next time let's do the UC&C
21:27:46 <dconde> #info if UC&C is done, let's try others as examples. but uchau1 asks about where we look at mapping into GBP from model standpoint
21:29:47 <dconde> #info uchau1 says diagram is enough, not JSON or YANG
21:31:19 <dconde> #agreed next time we step through UC&C and see if requierements are at correct level
21:31:42 <dconde> #info not sure we can do that in two hours.
21:33:22 <dconde> #endmeeting