20:17:14 <dconde> #startmeeting ODL-GBP-STATUS
20:17:14 <odl_meetbot> Meeting started Thu May 22 20:17:14 2014 UTC.  The chair is dconde. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:17:14 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:17:14 <odl_meetbot> The meeting name has been set to 'odl_gbp_status'
20:17:32 <dconde> #chair alagalah
20:17:32 <odl_meetbot> Current chairs: alagalah dconde
20:17:50 <dconde> #info revisit the goals and look at use cases
20:18:18 <dconde> #info we need to create a subgroup that focuses on requirements and use cases
20:18:33 <dconde> #info that will add displine and structure to the project.
20:19:28 <dconde> #info bhushan will help lead
20:19:52 <dconde> #info lenrow wants to join.
20:20:08 <dconde> #info lenrow wants to add an ease-of-use leader too.
20:20:25 <dconde> #info sanjay wants to participate too.
20:20:41 <uchau> would like to be part of this also
20:20:51 <dconde> #info adding uchau to that group
20:21:12 <dconde> #info we also need to have reprsentative from each party involved.
20:21:32 <dconde> #info from some people it's L4-7, for others it is switching, so let's make sure it's tangible and implementable
20:22:31 <dconde> #info kiran yedavilli wants to join
20:22:46 <dconde> #info mspegel asks the diff between the new group and the model group
20:22:56 <dconde> #info requirements are to be kept different from implementation
20:23:07 <dconde> #info the new group will review and approve with the model.
20:23:32 <dconde> #info we will call this group "REQUIREMENTS" group
20:24:04 <dconde> #info lenrow says this will avoid mistakes that may have happened in vairous ODL Groups.
20:24:21 <dconde> #info dvorkinista says we need to crystallize these concepts and for usability.
20:24:44 <dconde> #info dvorkini_ says that even though we have code written, but we will course correct.
20:25:14 <dconde> #info lenrow says we need to move quickly since we don't want to stop, so we need to get use cases for solution space.
20:25:48 <dconde> #info dvorkini_ says we want separate of this from other projects.  like affinity services different purposes
20:26:09 <dconde> #info add prasadv into this group.
20:26:33 <mspiegel> #info please add me to the group
20:26:49 <dconde> #info we will need to figure out if we need to augment model or put into a different activity if we cannot agree into fitting into this model.
20:27:04 <dconde> #info we need to keep our mind open on this.
20:27:28 <dconde> #info this will be good to figure out what works in helium or can be done later as something we can evolve.
20:27:56 <dconde> #info we will look at extensibility than structural changes.  That would lead to potpourri of APIs.
20:28:28 <dconde> #info it would be good to add security, multi-tenancy and such into the architecture group.
20:28:37 <dconde> #info but can involve other parts of the ODL group.
20:28:47 <dconde> #info dconde willl join this group too
20:28:57 <dconde> #info everyone's opinions are welcome in the requirements group
20:29:13 <dconde> #info lenrow says that this can map into work in the ONF NBI group too.
20:29:20 <mscohen> please add me to the use case group as well
20:29:22 <dconde> #info that has its declarative intents
20:29:38 <dconde> #info mscohen is joining REQUIREMENTS Group
20:30:10 <dconde> #info lenrow -- let effort follow interest. for a declarative intent API and rendering behind it.
20:30:28 <dconde> #info dvorkini_ if  you ask any party here, they will probably agree.
20:30:43 <dconde> #info lenrow prioritizing by committee may be difficult.
20:31:07 <dconde> #info dvorkini_ wants to see us be open minded -- we need to address needs for each company as well who we work for.
20:31:14 <tbachman> #info tbachman will join the REQUIREMENTS Group
20:31:57 <dconde> #info lets add items needed and then go into cleanup mode. We're all engineers and we can over engineer, so we need to take things out when necessary.
20:32:24 <dconde> #info things can get added for philosophical reasons, not because it's needed. IF we do all that, we can kick-ass
20:33:19 <dconde> #info everyone needs to be on ODL GBP mailing list, read wiki.  if you need access, ask alagalah, lenrow or dconde
20:33:40 <dconde> #info we don't want this group to be as big as the STATUS group so let us be focused too.
20:33:47 <dconde> #info alagalah asks lenrow for use cases
20:33:58 <dconde> #info we need to pick a time that works. and who are the members.
20:34:31 <dconde> #info we will collect compile use cases and move forward. everyone is responsibilie for adding use cases, or if you are not a member, you can contact a team member and do it in a democrative way.
20:35:15 <dconde> #info lenrow says it's great to be inclusive. but we got here by getting stuck in requirements in a few use cases in a smaller group which talked about Unified Comm use case
20:35:35 <dconde> #info should we look at high speed/dynamic use cases as part of the workflow. and put tha tinto the intent API?
20:35:56 <dconde> #info dvorkini_ says we can try.  We are limited by rules of physics. so let's try.
20:36:02 <Kiran> I have joined the groupbasedpolicy-announce and groupbasedpolicy-users lists, any other list to join?
20:36:16 <dconde> #info lenrow - if we put in performance requirements, we will be explicit.
20:36:40 <dconde> Kiran you can join -dev group.
20:36:46 <dconde> Kiran I will send to you in a moment.
20:36:53 <Kiran> ok, thanks
20:37:00 <dconde> kiran groupbasedpolicy-dev
20:37:06 <Kiran> ok
20:37:10 <mscohen> dconde - i think you missed adding the comment about mike’s wife to the notes
20:37:51 <dconde> #info lenrow says we can have a "naive" people timer and see if we can explain to them in 5 minutes
20:38:06 * tbachman ducks
20:38:07 <dconde> #info just kidding --
20:38:22 <dconde> #info mspiegel says that we will have to explain in phases.
20:38:46 <dconde> mscohen gee, I guess that adds color to the notes!
20:39:09 <dconde> #info enterprise people care about some items and we need set of examples.
20:39:34 <dconde> #info readams tried to do that, but we need to have others.
20:40:18 <dconde> #info dconde says we need to add in true customer requirements -- avoid hypothesizing
20:40:27 <Kiran> We are developing the intent based policy for APIC-EM, which emerged from enterprise usecases - we can share the usecases
20:40:42 <dconde> #info dvorkini_ says we need to separate areas: Data center vs. enterprise security vs. other needs
20:41:24 <dconde> #info dcone says we need a categories or taxonomy.
20:41:31 <dconde> #info we need to set up a time.
20:41:56 <dconde> #info we can take over end point registry time -- 9 am Monday PAcific
20:42:14 <dconde> #info does not collide with lunch for East Coasters?
20:42:29 <dconde> #info we can work it out.
20:42:32 <Kiran> the coming monday is memorial day
20:42:45 <dconde> #info alagalah says 8 am Monday is OpenFlow call.
20:43:01 <dconde> #info alagalah says that meeting is 60 min
20:43:04 <python27> are we assuming anything about Orchestration?
20:43:17 <dconde> #info dvorkoni_ says 9 am Tue?
20:43:34 <tbachman> 9am Tuesday is the MD-SAL meeting
20:43:39 <dconde> #info is Monday 1 pm PAcific OK?
20:43:56 <dconde> #info Monday  1 pm Pacific chosen
20:44:08 <dconde> # info we will compile list AFTER MEmorial day
20:44:10 <python27> conflicts w OpenStack networking
20:44:22 <python27> is 2PM an option?
20:45:39 <dconde> #info if we cannot get requirements by November we are screwed. So let's use 1 pm PACIFIC and be DONE by November.
20:46:04 <banix> python27: openstack networking meeting is at 2pm Pacific.
20:46:17 <dconde> #info so we can meet more frequently if needed.  Until then, send email or use Wiki
20:46:20 <Kiran> 2 PM Pacific is good
20:46:27 <dconde> #info lenrow says 13:00 Pacific
20:46:35 <lenrow> #info If you use case is in the GBP google doc or in the ONF A&F or NBI use cases please don't feel the need to send it in
20:46:45 <dconde> #info we can meet next Tuesday
20:46:45 <s3wong> Kiran: we are now in PDT, so OpenStack networking weekly meeting is @2pm PDT
20:46:52 <Bhushan> Bhushan will participate
20:46:57 <Kiran> ok
20:47:05 <Kiran> 1 PM PDT is good as well
20:47:08 <dconde> #action dconde will compile list of members.
20:47:09 <Bhushan> #info I will participate in the Mon 1300 call
20:47:45 <dconde> #info alagalah birthday today
20:48:11 <dconde> #agreed 1 pm Pacific
20:48:20 <dvorkini_> #info happy birthday @alagalah!
20:48:34 <dconde> #action Alagalah will set up a WebEx
20:48:46 <tbachman> #info tbachman hands alagalah a birthday scotch
20:49:09 <dconde> #info ghangout limitation is a problem, so we need to go to WebEx.
20:50:02 <dconde> #info so let's make sure we have ONE webEx link next time.
20:50:09 <dconde> #info all done!
20:50:15 <dconde> #endmeeting