20:08:18 <regXboi> #startmeeting policy status
20:08:18 <odl_meetbot> Meeting started Thu May 29 20:08:18 2014 UTC.  The chair is regXboi. Information about MeetBot at http://ci.openstack.org/meetbot.html.
20:08:18 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:08:18 <odl_meetbot> The meeting name has been set to 'policy_status'
20:08:24 <regXboi> #chair alagalah
20:08:24 <odl_meetbot> Current chairs: alagalah regXboi
20:08:29 <regXboi> #topic requirements
20:08:40 <regXboi> #link https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:REQUIREMENTS#Requirements_Sub-Group
20:08:57 <regXboi> #chair tbachman
20:08:57 <odl_meetbot> Current chairs: alagalah regXboi tbachman
20:09:18 <regXboi> #info requirements meeting to be set up
20:09:29 <regXboi> #action dvokinista to set up requirements meetings
20:10:43 <regXboi> #info for those joining, the hangout is coming
20:10:50 <regXboi> #link https://plus.google.com/hangouts/_/noironetworks.com/odl-gbp-status
20:12:08 <regXboi> #topic functional spec
20:12:12 <Youcef> functional spec URL?
20:13:14 <Youcef> Is it this one: https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model?
20:13:28 <dconde> that'is right youcef
20:13:32 <Youcef> thanks!
20:13:41 <regXboi> #link https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model
20:13:54 <dconde> also look at https://wiki.opendaylight.org/view/Group_Policy:Architecture
20:13:57 <tbachman> #info folks need to read the functional spec and comment, as implementation is under way
20:14:17 <Youcef> I'm half way through it :)
20:14:36 <tbachman> #info The Architecture page has a link to the Policy Model page
20:14:55 <tbachman> Youcef:  :)
20:17:15 <regXboi> #info the main wiki page now has a subpages section
20:19:13 <tbachman> #info readams is working on renderer-commons framework
20:19:40 <regXboi> #question when do we think we'll be able to fill in the policy and status repository?
20:19:47 <tbachman> #info Trying to get to a point where a renderer can map a parir of endpoints into endpoint groups
20:20:43 <regXboi> #question what is the use case for the demo renderer?
20:20:55 <tbachman> #info demo-renderer will demonstrate that the basic framework “works"
20:21:08 <regXboi> #question what does that mean specifically
20:21:17 <regXboi> #info likely a simple overlay
20:22:20 <regXboi> #info readams says anybody who wants to take a swing at it can feel free
20:22:47 <regXboi> #info readams thinks that will be more easily filled in as we understand what the renderers expect
20:27:41 <Bhushan_> checking if I'm still connected
20:27:57 <Youcef> Bhushan_: yep you are
20:28:29 <tbachman> #link https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2014-May/000193.html <— dlenrow mentioning the renderer group
20:28:30 <Bhushan_> saw no activity so was worried. I'd lost internet connectivity for a brief time earlier
20:30:32 <tbachman> #info regXboi recalls that dvorkinista made a statement that portions of the model are optional
20:31:03 <tbachman> #info If that is true, regXboi looked at the current YANG in the repo, but nothing is tagged as a yang feature, which would indicate that it was optiona
20:31:32 <tbachman> #info readams notes that entire pieces of the model aren’t necesarrily optional, but that the renderer may not be able to render parts of the model
20:31:45 <tbachman> #info which would result in an exception, then having retries
20:32:14 <tbachman> #info resulting in parts of the model not being required to fulfil the policy requirement
20:32:40 <tbachman> #info dvorkinista says that there are things that require change of placement, and stuff that does not.
20:32:57 <tbachman> #info If there are endpoints that can’t be satisified, then the endpoint must be moved somewhere else
20:33:06 <tbachman> #info because we can’t move workloads
20:35:09 <tbachman> #info We may want the option to have a way of expressing whether the policy has to be “all-or-nothing”
20:36:23 <regXboi> ok - sort of back
20:36:25 <tbachman> #info dvorkinista feels that this can fall on the renderer. The renderer is responsible for achieving the desired state.
20:38:07 <regXboi> #info sanjay asks if the renderer architecture been decided on?
20:38:41 <tbachman> #info readams says that we’re creating a demo-renderer
20:38:43 <regXboi> #info readams says that demo will be based on *something*
20:40:32 <regXboi> #info regXboi points out that *something* is a bit nebulous
20:40:52 <regXboi> #info and that it should be nailed down by the to-be reconstituted renderer meetings
20:41:03 <regXboi> #agreed renderer meetings will be restarted
20:42:31 <regXboi> #endmeeting