#opendaylight-group-policy: gbp_status_arch

Meeting started by tbachman at 18:00:58 UTC (full logs).

Meeting summary

  1. agenda (tbachman, 18:01:03)
    1. https://meetings.webex.com/collabs/meetings/join?uuid=M4PO9GTADM5ZZWKPF30D5WC98O-9VIB (alagalah, 18:01:24)
    2. Meeting is here: https://meetings.webex.com/collabs/meetings/join?uuid=M4PO9GTADM5ZZWKPF30D5WC98O-9VIB (alagalah, 18:01:30)
    3. https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000940.html Email describing today’s agenda (tbachman, 18:01:46)
    4. we changed WebEx (and this is reflected on the wiki, the odl meeting page etc) due to there being fraud on the last webex (alagalah, 18:01:53)
    5. https://meetings.opendaylight.org/opendaylight-group-policy/2015/gbp_status_arch/opendaylight-group-policy-gbp_status_arch.2015-02-13-18.00.html last week’s meeting minutes (tbachman, 18:02:26)

  2. Agenda (alagalah, 18:04:14)
    1. Agenda: https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting (alagalah, 18:04:22)

  3. SFC Update (alagalah, 18:04:31)
    1. https://git.opendaylight.org/gerrit/#/c/15521/ Initial gerrit for GBP SFC integration (tbachman, 18:07:03)
    2. https://git.opendaylight.org/gerrit/#/c/15255 expansion of GBP SFC integration (tbachman, 18:07:17)
    3. tbachman is working with repenno on integration the two pieces. Still some details as to whether to keep the existing static method or convert to an RPC (tbachman, 18:11:07)
    4. tbachman invites anyone interested to reach out to himself or reinaldo (tbachman, 18:11:51)

  4. Code Merges (alagalah, 18:11:59)
    1. https://git.opendaylight.org/gerrit/gitweb?p=groupbasedpolicy.git;a=summary (alagalah, 18:13:59)
    2. https://bugs.opendaylight.org/show_bug.cgi?id=2689 Bug: cast exception when serialiing L3Address from groupbasedpolicy policy.yang (tbachman, 18:17:56)
    3. https://bugs.opendaylight.org/show_bug.cgi?id=2657 Bug: Flow present in configuration data store but not operational when running groupbasedpolicy POC test (tbachman, 18:18:33)
    4. note that 2689 is fixed with gerrit: https://git.opendaylight.org/gerrit/#/c/15558/1 (tbachman, 18:18:57)
    5. abhijitkumbhare suggests that we CC: groupbasedpolicy-XXX (dev?) on bugs so we can track (alagalah, 18:19:14)
    6. ACTION: tbachman to CC: groupbasedpolicy-XXX on bugs (alagalah, 18:19:29)

  5. Trello Board (tbachman, 18:19:57)
    1. https://trello.com/b/yc0xHFlv/opendaylight-groupbasedpolicy-lithium Group Based Policy Lithium Trello Board (tbachman, 18:20:14)
    2. alagalah went through trello, removed duplicates, cleaned things up, added new cards (tbachman, 18:21:03)
    3. cards at top of the category are higher priority than those lower in the category (tbachman, 18:21:21)
    4. alagalah says the super-cala-fragalistic important is the best list for folks to pick cards up from (tbachman, 18:21:36)
    5. The ‘Create SFC + GBP Use case’ card has been addded, moved to ‘done since last meeting’ (tbachman, 18:22:40)
    6. alagalah added the port-name field to the endpoint yang model, to help with openstack integration (tbachman, 18:23:11)
    7. Sanjay asks if we need the access switch name or IP, along with the port name (tbachman, 18:23:36)
    8. alagalah says he’s considering port-name to be more like a “locator”, as port-name may not support all the use cases (tbachman, 18:24:08)
    9. alagalah asks what community would want as a generic way of providing this information on an endpoint (tbachman, 18:24:46)
    10. Sanjay says he feels that having a node,port-name is the best solution — with virtualized switches, with different ways of getting to the switch, might be best (tbachman, 18:25:54)
    11. alagalah says we need to be generic enough — e.g. a lambda, or what have you (tbachman, 18:26:09)
    12. Sanjay says it can just be a string (tbachman, 18:26:23)
    13. alagalah asks if Sanjay can pick up this trello card (tbachman, 18:28:17)
    14. Sanjay says yes (tbachman, 18:28:20)
    15. Meenakshi asks if it can also take a mask (tbachman, 18:29:14)
    16. alagalah says he’s aware of the use case; knows that it’s nice if an EP can be a CIDR block for “grey-list” access; that will be a separate work item (multi-EPG work) (tbachman, 18:29:56)
    17. alagalah created a new category for “Testing” (tbachman, 18:31:48)
    18. alagalah has verified that multi-tenancy works, using POC (tbachman, 18:32:52)
    19. alagalah says there’s a minor fix needed for intra-EPG policy resolution — will submit a gerrit (tbachman, 18:33:17)
    20. alagalah has a working copy of the multi-EPG operation, but needs some additional work; will submit when that’s done (tbachman, 18:33:59)
    21. neutron API mapping is being covered by martin_sunal (tbachman, 18:34:20)
    22. martin_sunal is hoping to provide a gerrit this weekend that provides an initial mapping (tbachman, 18:35:16)
    23. yapeng is looking into adding multi-renderer support (tbachman, 18:36:48)
    24. edwarnicke asks if this work effort is to handle things where renderers don’t step on each other (tbachman, 18:37:10)
    25. alagalah says there are a few things here — we first need to add support for being able to have multiple renderers loaded (currently not supported); there are other levels of supporting this (tbachman, 18:38:17)
    26. alagalah says there’s another piece where a rendere can be guaranteed a single-writer, optionally a single writer, or guaranteed to never be the single writer (tbachman, 18:41:43)
    27. alagalah is looking into the FD/BD/Subnet selection to EP (tbachman, 18:44:56)
    28. alagalah says we should revamp the wiki a bit — wants it to be more useful to different audiences (tbachman, 18:45:28)
    29. for example, end-users, developers, architects, etc. (tbachman, 18:45:39)
    30. alagalah has a beta version, but needs a bit more work before making it the actual project home page (tbachman, 18:46:20)
    31. alagalah asks if yapeng can work on porting openstack API support to the generic endpoint (tbachman, 18:52:29)
    32. yapeng says since there’s already something released in openstack, we’ll need to address backwards-compatibility (tbachman, 18:52:50)
    33. alagalah asks if the URI used by OpenStack is in a separate file, or embeded in the code (tbachman, 18:53:44)
    34. yapeng says it’s embedded in the code; the fix for this is pretty quick/easy, but the harder part is addressing backwards compatibility (tbachman, 18:54:18)
    35. https://git.opendaylight.org/gerrit/#/c/9752/ original gerrit to create tunnels in GBP using OVSDB (tbachman, 19:06:29)
    36. https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000886.html email from mickey_spiegel describing multiple actions (tbachman, 19:16:53)
    37. alagalah says we can talk about the actions, but we’d need good definitions of what those are (tbachman, 19:17:17)
    38. mickey_spiegel says we need a well-known way, in terms of syntax, for things that are common (tbachman, 19:17:59)
    39. mickey_spiegel says things like allow are pretty straightforward (tbachman, 19:18:11)
    40. mickey_spiegel says that right now these items are populated in the operational data store by the openflow renderer (tbachman, 19:19:07)
    41. alagalah says we can do this as a “top-down”, where we define these across all renderers, or “bottom-up”, where each renderer provides the definitions (tbachman, 19:19:37)
    42. mickey_spiegel asks if we can have a common list of subject-features, and each renderer could list which ones it supports. (tbachman, 19:20:00)
    43. alagalah asks how we handle cases where a renderer can’t handle a given subject-feature (tbachman, 19:20:16)
    44. s3wong asks if realistically, do we approve renderer that cannot match on L4 ports and can't do ALLOW (or conversely DENY)? (tbachman, 19:21:47)
    45. tbachman says one possibility is that something not supported by a renderer could result in the renderer reporting this to the exception repo, with the appropriate action taken (tbachman, 19:22:32)
    46. ACTION: alagalah to follow up on mickey_spiegel’s email (https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000886.html) on best approach for how subject-features will be supported across renderers (tbachman, 19:31:55)
    47. edwarnicke is trying to chase down a resource for tempest testing (tbachman, 19:44:50)


Meeting ended at 19:46:23 UTC (full logs).

Action items

  1. tbachman to CC: groupbasedpolicy-XXX on bugs
  2. alagalah to follow up on mickey_spiegel’s email (https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000886.html) on best approach for how subject-features will be supported across renderers


Action items, by person

  1. alagalah
    1. alagalah to follow up on mickey_spiegel’s email (https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000886.html) on best approach for how subject-features will be supported across renderers
  2. tbachman
    1. tbachman to CC: groupbasedpolicy-XXX on bugs


People present (lines said)

  1. tbachman (87)
  2. alagalah (11)
  3. s3wong (11)
  4. odl_meetbot (7)
  5. abhijitkumbhare (4)
  6. dbainbri (4)
  7. edwarnicke (1)


Generated by MeetBot 0.1.4.