#opendaylight-group-policy: gbp_status_arch

Meeting started by tbachman at 18:02:30 UTC (full logs).

Meeting summary

  1. Agenda (alagalah, 18:02:59)
    1. https://wiki.opendaylight.org/view/Group_Policy:Sub-Groups:STATUS#Team_Meeting (alagalah, 18:03:03)

  2. Code Merges (alagalah, 18:03:11)
    1. https://meetings.opendaylight.org/opendaylight-group-policy/2015/gbp_status_arch/opendaylight-group-policy-gbp_status_arch.2015-02-20-18.00.html Minutes from last week’s meeting (tbachman, 18:03:23)
    2. ACTION: tbachman to follow up with mickey_spiegel re: this email: https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000886.html (tbachman, 18:05:02)
    3. tbachman followed up on how to track other projects bugs that affect us. Feedback was: create a 'megabug' that we link the external bugs to the 'megabug' and get notifications that way (alagalah, 18:06:08)
    4. ACTION: tbachman to file metabug for the Lithium release to track bugs outside of the groupbasedpolicy project (e.g. openflowplugin, controller), and link bugs to this metabug (tbachman, 18:08:05)
    5. Daniel Konig-Schieber says that deny-all and allow-specific might be too-light a definition for multiple renders — wonders if we can define a set for renderers to support (tbachman, 18:09:27)
    6. edwarnicke says that in yang, the enum types is not extensible (tbachman, 18:09:42)
    7. edwarnicke says you can achieve the same effect using identities (tbachman, 18:09:54)
    8. edwarnicke says the overlay project uses this for tunnel types (tbachman, 18:10:19)
    9. ACTION: alagalah to look into replacing enums in GBP modesl with identities (tbachman, 18:10:54)
    10. edwarnicke says it also brings in augmentations for the tunnel type (tbachman, 18:11:22)
    11. alagalah says when we get into event and exception management/reporting, this allows renderers to specify whatever they want (tbachman, 18:12:36)
    12. alagalah says he can see a middle-ground case where the model can supports a lot of different classifier types, etc. but have an agreement on a base set of types to start with in the model (tbachman, 18:14:05)
    13. mickey_spiegel says when we modify the model, the question is whether there are common ones and renderer-specific ones (tbachman, 18:14:30)
    14. https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000830.html email from Daniel on subject-feature-definitions (tbachman, 18:15:18)
    15. https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000886.html email from mickey_spiegel on the same topic (tbachman, 18:15:37)
    16. ACTION: alagalah to follow up on this (tbachman, 18:15:43)
    17. Sanjay says that we haven’t had a model discussion in the meeting, and wanted to bring up some of the topics — priority, etc. Should we have a discussion and whether or not they will be added to the model now (tbachman, 18:16:20)
    18. alagalah says we will try to fit it at the end of today (tbachman, 18:16:34)
    19. alagalah says if not in today’s meeting then next week’s meeting (tbachman, 18:16:49)

  3. Code merges (tbachman, 18:17:49)
    1. Good job tbachman & edwarnicke :) (abhijitkumbhare, 18:19:09)

  4. Trello (tbachman, 18:22:30)
    1. alagalah is working on setting up a lab environment that’s externally accessible (tbachman, 18:23:00)
    2. The environment would have VMs that would be set up to run the POC, so that people in the community can test things like neutron integration and SFC integration (tbachman, 18:23:48)
    3. https://trello.com/b/yc0xHFlv/opendaylight-groupbasedpolicy-lithium Trello board link (tbachman, 18:23:58)
    4. port range was completed this weekend (tbachman, 18:24:21)
    5. alagalah is going to document the inter-EPG policy on the wiki before moving to done (tbachman, 18:24:50)
    6. martin_sunal is workin gon the Neutron API mapping — provided a patch that’s WIP (tbachman, 18:25:55)
    7. https://git.opendaylight.org/gerrit/#/c/15621 Gerrit that provides the neutron to GBP mapping (tbachman, 18:26:41)
    8. ACTION: alagalah to provide weekly updates on the neutron to GBP mapping (tbachman, 18:27:15)
    9. alagalah says we have about 95% unit test coverage on GBP inheritance (tbachman, 18:27:48)
    10. https://wiki.opendaylight.org/view/Group_Policy:Architecture/Policy_Model#Inheritance Link that describe how inheritance is supposed to work in GBP — what needs to be tested functionally (tbachman, 18:28:46)
    11. alagalah has linked the common tenant and inheritance tasks on the trello board, as implementing the common tenant may be achievable using inheritance (tbachman, 18:29:36)
    12. alagalah says to meet the needs of security groups, it was simpler to allow EPs to join multiple EPGs, rather than leverage conditions (tbachman, 18:31:01)
    13. alagalah tried out conditions and multi-EPGs (tbachman, 18:31:11)
    14. alagalah says after testing both, multi-EPG seems to be the right path (tbachman, 18:31:32)
    15. alagalah says conditions can do things that muilti-EPG can’t, so both have their use cases (tbachman, 18:31:58)
    16. mickey_spiegel says if you allow multiple EPGs per endpoint, you can have conflicts — has that been addressed (tbachman, 18:33:33)
    17. alagalah says his initial thoughts are based on the fact that one of the reasons at including multi-EPG is to meet a requirement for neutron security groups (tbachman, 18:34:35)
    18. alagalah says one of the ideas is looking at things at the same level as the classifier, at the same level you can do an OR, since you won’t have a conflict (tbachman, 18:35:53)
    19. mickey_spiegel says this is probably a longer discussion; openstack got away with it b/c it’s only allow (tbachman, 18:36:42)
    20. mickey_spiegel says with more actions, it becomes more complicated (tbachman, 18:36:53)
    21. alagalah says he’d like to see us get to the point where we do more than just “give me a chain by name” — like provide the list of services desired (tbachman, 18:40:44)
    22. alagalah says some of this might be part of a post-Lithium discussion (tbachman, 18:41:08)
    23. Daniel asks if he should provide the precedence on the classifiers (tbachman, 18:42:06)
    24. alagalah says for SFC, we can use whatever encap we want, but when it reaches the tunnel, it does the NSH encap (tbachman, 18:44:38)
    25. yapeng has a draft that he’s pushed on the simultaneous renderer support (tbachman, 18:46:55)
    26. ACTION: start a design doc for supporting simultaneous renderers, link to trello card, and contact all parties invovled (tbachman, 18:51:12)
    27. alagalah sasys the card “Move FD/BD/Subnet selection to EP” has to do with supporting the data plane using the constructs in the EP (tbachman, 18:53:24)
    28. yapeng has tested the URI change in openstack to use the new URI — it works. He just needs the final name to be used (tbd) (tbachman, 18:55:52)
    29. alagalah is looking at revamping the wiki to make it more consumable (tbachman, 18:59:19)
    30. ACTION: tbachman to retest performance and reach out to jmedved and moizer on the results (tbachman, 19:07:23)

  5. Documentation (tbachman, 19:07:26)
    1. alagalah to be the guineau pig for documentation project (tbachman, 19:07:37)

  6. Endpoint Model discussion (tbachman, 19:07:43)
    1. https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000953.html email from alagalah on the port name parameter when registering Endpoints (tbachman, 19:08:25)
    2. alagalah says that for the openstack use case, neutron knows the tap port name at the time of port registration (tbachman, 19:10:33)
    3. https://docs.google.com/a/noironetworks.com/document/d/1VGvRZxLaKqt_bqjriRlIjLDjXJPBFvZ5_9puNUj3I94/edit Google doc showing the existing ML2 mechanism driver sequence diagram and sequence diagram for OpenStack GBP/ODL GBP integration (tbachman, 19:11:05)
    4. alagalah is proposing moving the port-name construct to an augmentation, and adding the node and the bridge to that augmentation (tbachman, 19:12:38)
    5. Sanjay says there’s an implementation for a different vSwitch, which is slightly different (tbachman, 19:13:23)
    6. Sanjay says instead of using a nova agent to create and attach a virtual port to the bridge, and then notify neutron, they are having nova create the port on the VM and then have neutron notify ODL from the neutron interface (tbachman, 19:14:11)
    7. Sanjay says you can specify the host ID in the create/update port command (tbachman, 19:14:35)
    8. alagalah points out that we don’t have a neutron integration yet (tbachman, 19:15:18)
    9. Sanjay says that OVS is a special implementation where nova attaches the host port (tbachman, 19:15:59)
    10. http://developer.openstack.org/api-ref-networking-v2.html Link that Sanjay is using to show the neutron API (tbachman, 19:16:26)
    11. Sanjay says the only entity that knows where the VM was created is nova (tbachman, 19:16:58)
    12. Sanjay says there’s no way to tell where the port is created among all the hypervisors, but they discovered the ability to get the host ID (tbachman, 19:18:06)
    13. Sanjay says that allows them to take the port name and attach it to their virtual switch (tbachman, 19:18:44)
    14. alagalah asks how moving a field from the general endpoint to an augmentation in the renderer affects this (tbachman, 19:19:32)
    15. Sanjay says the property of which renderer is using information that’s relevant to the NB application (tbachman, 19:20:46)
    16. alagalah agrees with Sanjay that we need a separation of concerns between northbound semantics and southbound semantics (tbachman, 19:37:46)
    17. alagalah asks if Sanjay is okay with the existing proposal, with the caveat that the northbound/southbound semantics need to be addressed (tbachman, 19:38:32)
    18. Sanjay feels that location should be in the base endpoint model (tbachman, 19:38:46)
    19. edwarnicke disagrees somewhat. He says that VMs are only one piece of this picture (tbachman, 19:39:15)
    20. edwarnicke says he suggests having a common location augmentation that could be used by multiple northbound applications (tbachman, 19:39:43)
    21. Sanjay says that the string may be different, but there has to be a location (tbachman, 19:40:23)
    22. edwarnicke says there are cases where there isn’t location information but we want to control the EP (tbachman, 19:41:17)
    23. Sanjay asks the case where you have two renderers, how do you augment the endpoint registry model in a coordinated way (tbachman, 19:43:45)
    24. alagalah says that’s the simultaneous renderer problem, which is being addressed (tbachman, 19:44:17)
    25. Daniel asks how you can apply a policy to something that has only a location (tbachman, 19:48:50)
    26. alagalah isn’t sure how that will work when there’s no L2/L3 keys (tbachman, 19:49:02)
    27. Daniel says that if we have another index that covers location, that might help (tbachman, 19:49:36)


Meeting ended at 19:49:43 UTC (full logs).

Action items

  1. tbachman to follow up with mickey_spiegel re: this email: https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000886.html
  2. tbachman to file metabug for the Lithium release to track bugs outside of the groupbasedpolicy project (e.g. openflowplugin, controller), and link bugs to this metabug
  3. alagalah to look into replacing enums in GBP modesl with identities
  4. alagalah to follow up on this
  5. alagalah to provide weekly updates on the neutron to GBP mapping
  6. start a design doc for supporting simultaneous renderers, link to trello card, and contact all parties invovled
  7. tbachman to retest performance and reach out to jmedved and moizer on the results


Action items, by person

  1. alagalah
    1. alagalah to look into replacing enums in GBP modesl with identities
    2. alagalah to follow up on this
    3. alagalah to provide weekly updates on the neutron to GBP mapping
  2. tbachman
    1. tbachman to follow up with mickey_spiegel re: this email: https://lists.opendaylight.org/pipermail/groupbasedpolicy-dev/2015-February/000886.html
    2. tbachman to file metabug for the Lithium release to track bugs outside of the groupbasedpolicy project (e.g. openflowplugin, controller), and link bugs to this metabug
    3. tbachman to retest performance and reach out to jmedved and moizer on the results


People present (lines said)

  1. tbachman (97)
  2. s3wong (8)
  3. alagalah (6)
  4. odl_meetbot (5)
  5. yapeng (4)
  6. edwarnicke (2)
  7. abhijitkumbhare (1)


Generated by MeetBot 0.1.4.