15:02:15 <tbachman> #startmeeting gbp_status_arch
15:02:15 <odl_meetbot> Meeting started Wed Jul 29 15:02:15 2015 UTC.  The chair is tbachman. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:02:15 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:15 <odl_meetbot> The meeting name has been set to 'gbp_status_arch'
15:02:30 <alagalah> tbachman: Hey all
15:02:43 <tbachman> #chair alagalah
15:02:43 <odl_meetbot> Current chairs: alagalah tbachman
15:02:43 <tbachman> alagalah: hey!
15:03:05 <tbachman> #info committers please #info in
15:03:07 <tbachman> #info tbachman
15:03:13 <alagalah> #info alagalah
15:03:32 <tbachman> #topic agenda
15:03:41 <alagalah> https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Team_Meeting
15:03:42 <tbachman> #link https://wiki.opendaylight.org/view/Group_Based_Policy_(GBP)/Team_Meeting Link to agenda
15:03:43 <tbachman> al
15:03:44 <tbachman> lol
15:03:54 <tbachman> #link https://meetings.opendaylight.org/opendaylight-group-policy/2015/gbp_status_arch/opendaylight-group-policy-gbp_status_arch.2015-07-22-15.00.html Minutes from last week’s meeting
15:04:01 <tbachman> #topic ODL Summit
15:04:10 <tbachman> alagalah: record?
15:04:34 <tbachman> alagalah: up to you
15:05:31 <tbachman> #info alagalah says when the CFP came out for ODL summit, we were in the middle of heavy development for Lithium (SFC and neutron integration) — we weren’t sure what we’d be able to get done at the time
15:06:15 <tbachman> #info alagalah said that we did have OpenStack GBP integrated with ODL GBP, so we knew we could demonstrate that.
15:06:47 <tbachman> #info alagalah demonstrated the GBP neutron integration at the summit — went off great, with minor hitch of external connectivity, which he fixed by the end of the session
15:15:34 <tbachman> #info The summit has had some great sessions — including a panel with edwarnicke, ebrjohn, dfarrell07, colindixon, and ttkacik
15:16:12 <tbachman> #info There was also a session that alagalah was on with policy, including Tim Hinrichs, mlemay
15:16:46 <tbachman> #info alagalah says there were a lot of discussion on GBP and SFC collaboration — folks were referencing that as a great example of cross-project collaboration
15:16:57 <tbachman> #topic IETF Prague
15:17:15 <tbachman> #info alagalah says it was his first time attending the IETF
15:19:04 <tbachman> alagalah: use cases, demos from hackfest?
15:19:13 <tbachman> lol
15:20:08 <tbachman> #info alagalah says that one of the issues with the existing vagrant demo is the time it takes to stand up the VMs. He changed the setup at the summit to include a box file, which makes it quicker to stand up the VMs.
15:20:34 <tbachman> #info alagalah says this allows the 6 VMs to be stood up in 5 minutes — a huge improvement
15:21:08 <tbachman> #info alagalah is going to check with dfarrell07 about possible ways of improving the packaging
15:21:56 <tbachman> #info Dave Dolson from Sandvine helped improve the existing GBP+SFC demo as well
15:22:42 <tbachman> #info alagalah said folks from Qosmos were looking into L4-L7 classification for GBP
15:23:07 <tbachman> #info alagalah says the biggest feedback for the demo was that it gave a demo environment that people could use for development iteration
15:23:38 <tbachman> #info alagalah says he’s thinking of creating 3 levels of entry for hackfest — reflecting skill-set and knowledge of those getting involved
15:24:23 <tbachman> #info The idea is that each level has a different type/depth of instruction — those at the first level (entry-level) would require more background, those at the last level (expert) would require less
15:24:47 <tbachman> #info alagalah says there’s a tool in webex that alllows folks to break out into different “training rooms”. This may be helpful for hackfests as well
15:25:44 <tbachman> #info For level 2, alagalah would like to come up with a predefined set of coding tasks that are achievable in a 2-day period for the hackfests — also looking into tracking things like this with trello.
15:25:57 <tbachman> #info Level 3 would be pretty deep/involved development tasks
15:26:28 <tbachman> #info alagalah says that GBP is getting involved with the OPNFV SFC project.
15:27:32 <tbachman> #info alagalah says there are other things in OPNFV that are also of interest to GBP — he’s going to propose GBP as an OPNFV project, which provides a platform for policy and integration of GBP in OPNFV
15:27:57 <tbachman> #info alagalah believes the SFC project in OPNFV is going to be the marquee feature in the “B” release for OPNFV
15:28:37 <tbachman> #info alagalah says the [SFC] tag on the OPNFV has had a lot of discussion — folks interested should subscribe and follow
15:29:13 <tbachman> #info alagalah says he’d like to look into a vCPE use case in OPNFV, with GBP
15:30:11 <tbachman> #info A CPE at home has a lot of features, which don’t need to be in the CPE itself, and could be moved to the carrier equipment — simpler devices at the edge
15:30:32 <tbachman> #info You could then leverage GBP and SFC to create the behaviors that you want
15:30:39 <tbachman> GBPi net :)
15:32:05 <tbachman> #info alagalah encourages folks with thoughts on vCPE type use cases to email the groupbasedpolicy-dev or opnfv-tech mailing list (with [SFC] tag)
15:32:42 <tbachman> :)
15:32:58 <tbachman> lol
15:33:45 <tbachman> r0ckst@rs :)
15:34:04 <tbachman> alagalah: he is here :)
15:34:07 <tbachman> I’ll let him know
15:34:08 <tbachman> yes
15:34:08 <tbachman> :)
15:34:21 <tbachman> #topic Beryllium Release Plan
15:34:37 <tbachman> #info alagalah is going to work out an unconference for tomorrow to discuss the Beryllium release plan for GBP
15:35:21 <tbachman> #info alagalah says if people are interested, he’d like to start the release plan tomorrow with suggestions from folks with interests/suggestions of what they’d like to see in Beryllium
15:35:55 <tbachman> #info alagalah says that it’s important to bring resources along with their idea, in order to commit the resources for the Beryllium release
15:36:07 <tbachman> alagalah: and dileep
15:36:10 <tbachman> and yamahata
15:36:29 <tbachman> #info alagalah says he’s going to look into two webex sessions to handle different time zones
15:37:50 <tbachman> #topic Stable Lithium
15:40:32 <tbachman> #info tbachman has been talking with the LF folks on options for standing up ubuntu resources — we may be able to fix that, but LF is also moving to a private cloud which solves some of the problems
15:44:15 <tbachman> #info tbachman has stood up clustering setups and verified that it can work — need to bring up a single node first so that it’s the leader of all the shards
15:44:36 <tbachman> #action tbachman to talk with moizer and/or pantellis to ask if we can configure co-location of shards
15:44:46 <tbachman> #topic Trello
15:45:21 <tbachman> #info alagalah was hoping to keep things at a high-level “User Story” level for Trello tasks
15:46:26 <tbachman> #info alagalah says that for documentation, wonders if we can move the project’s documentation from the docs project to the groupbasedpolicy repo
15:47:11 <tbachman> #info alagalah says having the documentation in the local repo may help keep documentation from being an afterthought — would like to see iteration on docs on the same order as we do for code
15:47:33 <tbachman> #info alagalah says that if we submit code, we should think about submitting patches to docs explaining the code/feature, if relevant
15:49:42 <tbachman> #info alagalah was going to talk with colindixon about the possibility of the documentation project pulling from projects
15:51:53 <tbachman> #info martin_sunal says it allows us to track changes in groupbasedpolicy and not the docs project, and have editorial control
15:53:03 <tbachman> #info Dileep asks whether the time is fixed for the unconference — is interested in attending other sessions and wants to know if there are any scheduling conflicts
15:54:02 <tbachman> #info alagalah says that he thinks that folks get together at the start of the summit, and you can propose an unconference; topics are picked based on top interests (alagalah encourages folks to vote for GBP topic)
15:54:22 <tbachman> #info alagalah says that even if we don’t have an unconference room, we’ll find a place at the summit to hold our sessions
15:56:09 <tbachman> #endmeeting