16:21:58 <catohornet1> #startmeeting Integration Hack Fest @Brocade
16:21:58 <odl_meetbot> Meeting started Mon Jun 16 16:21:58 2014 UTC.  The chair is catohornet1. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:21:58 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:21:58 <odl_meetbot> The meeting name has been set to 'integration_hack_fest__brocade'
16:23:37 <catohornet1> #chair CASP3R LuisGomez
16:23:37 <odl_meetbot> Warning: Nick not in channel: LuisGomez
16:23:37 <odl_meetbot> Current chairs: CASP3R LuisGomez catohornet1
16:24:19 <catohornet1> #topic Introductions
16:33:11 <CASP3R> #Action LuisGomez to upload slides to Wiki
16:33:23 <CASP3R> #info History of the Integration group
16:34:34 <CASP3R> Hey Madhusudhan you can hear fine?
16:35:16 <Madhusudhan> yep, its good
16:35:30 <Madhusudhan> thanks for checking
16:36:31 <CASP3R> #info Integration strategy - each project handles JUnit and PAX-Exam test
16:37:24 <CASP3R> #info Integration group builds the distribution that triggers the CSIT which uses Robot framework.
16:38:35 <CASP3R> #info Community lab is the last step of the Integration group to do testing outside of Linux Foundation
16:42:05 <CASP3R> #info Tools used by the Integration group - Git/Gerrit, Nexus(Artifface Repo), Jenkins (Distribution Build), Robot (Test Automation), Bugzilla (Bug management),  Testopia (Test management)
16:43:55 <CASP3R> #info Linux Foundation lab setup, Jenkins, Robot, Controller 1&2, Mininet Slave 1&2
16:47:24 <CASP3R> #info Test work flow,    Document test case in Testopia -- Write automation via Robot -- test locally -- upload to GIT repo
16:49:27 <CASP3R> #info Test Repo - Testopia Product = Integration, Test plan = ODL Distribution , Test Case = Feature under test
16:49:55 <CASP3R> #info Git project = Integration,  Test Suites = test/csit/suites
16:51:10 <CASP3R> #info Deliverables for Hydrogen release
16:55:50 <CASP3R> #info Deliverables for Helium release
16:56:26 <CASP3R> #info M3 - Test Documentation and report in Testopia, OpenFlow 1.3 FlowMod test, OpenFlow 1.3 Performance test and NetConf
16:56:58 <CASP3R> #info M5 Neutron Test, Cluster Test, Tenancy Test, Longevity Test
17:06:28 <catohornet1> #chair
17:06:28 <odl_meetbot> Current chairs: CASP3R LuisGomez catohornet1
17:06:42 <catohornet1> #chair catohornet
17:06:42 <odl_meetbot> Current chairs: CASP3R LuisGomez catohornet catohornet1
17:06:44 <CASP3R> Start type now :P
17:08:49 <CASP3R> #topic Tools
17:14:31 <CASP3R> #info GIT/Gerrit for code review
17:15:00 <CASP3R> #Info Jenkins,  Job Events are based on projects Merge
17:15:09 <catohornet1> #info checkout updated Integration test workflow
17:15:59 <catohornet1> #info https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Test_Tools
17:16:12 <CASP3R> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Test_Tools
17:16:31 <CASP3R> need the hashtag link for  to make it clickable
17:17:44 <dfarrell07> (unrelated to hack fest but kinda pressing for my CBench work): What happend to this job: https://jenkins.opendaylight.org/integration/job/integration-project-centralized-integration/
17:18:02 <dfarrell07> I think a lot of people were using it to download built zips
17:18:21 <dfarrell07> via https://jenkins.opendaylight.org/integration/job/integration-project-centralized-integration/lastSuccessfulBuild/artifact/distributions/base/target/
17:19:10 <CASP3R> dfarrell07 we moved to it's new name i believe
17:19:13 <CASP3R> let me check what it is now
17:19:51 <CASP3R> https://jenkins.opendaylight.org/integration/job/integration-hydrogen-project-centralized-integration
17:19:55 <CASP3R> https://jenkins.opendaylight.org/integration/job/integration-master-project-centralized-integration
17:20:00 <dfarrell07> CASP3R: Sweet, thanks for the info
17:20:09 <CASP3R> no problems
17:20:17 <dfarrell07> CASP3R: I'll look around for links to the old one and update them, I know of a few off the top of my head
17:20:45 <CASP3R> Awesome, i know Luis did the work Friday and was busy getting stuff ready for hackfest
17:21:51 <CASP3R> #info Robot The automation engine for our CSIT
17:22:37 <CASP3R> #info Robot is keyword driven testing
17:24:28 <CASP3R> #info reports are created in the following output .html, .log and .xml
17:25:16 <CASP3R> #info Extended natively using Java and Python
17:26:58 <CASP3R> #info pybot will execute all .txt file in a test suite directory.
17:28:30 <CASP3R> #info Test case format,   Setup - configuration detail, and topology used
17:28:49 <CASP3R> #info settings  Describe the test case and what imported resource to use
17:29:25 <CASP3R> #info  variables optional, created for the test case
17:29:58 <CASP3R> #info info test case - where you write the test cases
17:30:47 <CASP3R> #info Teardown - clean run for the next test case run
19:47:51 <CASP3R> #topic Core project testing - round table
19:49:21 <CASP3R> #info Openflow - flowMod (Vendor extension),  capabilities learning, Metering, grouping and TLS support
19:50:40 <CASP3R> #info switch consistency  (when there is a disconnection of switch to controller)
19:53:42 <CASP3R> #info Netconf - Netopeer install
19:55:02 <CASP3R> #info Netconf - Inventory get-config,  push-config,
20:04:58 <CASP3R> #info NetApp - Toaster, Ping
20:06:21 <CASP3R> #info Performance - Cbench
20:07:26 <CASP3R> #info Performance flows/sec,   number of flows (flows in data store)
20:08:15 <CASP3R> #info Performance Inventory (switches and links)
20:08:58 <CASP3R> #info performance RESTApi (number of transcation)
20:10:42 <CASP3R> #info BGP - neighbors , topology
20:12:58 <CASP3R> #info Neutron - Openstack (2 Compute)
20:13:14 <CASP3R> #info neutron (VTN/OVSDB)
20:15:48 <CASP3R> #info sonar/jacoco - code converge, api converge
20:25:47 <CASP3R> #info testopia - Document update, and Robot plugin
20:27:20 <catohornet1> #info Netconf testing: Install Netopeer on Test VM; Test cases: Get conf, Push Conf, Mod Conf, Remote RPC.
20:27:29 <CASP3R> :)
20:27:44 <catohornet1> #chair catohornet
20:27:44 <odl_meetbot> Current chairs: CASP3R LuisGomez catohornet catohornet1
20:29:01 <catohornet1> #info Sonar/ Jococo: Code coverage,  API coverage
20:30:01 <CASP3R> catohornet1 hey https://meetings.opendaylight.org/opendaylight-integration/2014/integration_hack_fest__brocade/opendaylight-integration-integration_hack_fest__brocade.2014-06-16-16.21.log.txt
20:30:10 <CASP3R> this is the current log of the channel
20:31:02 <catohornet1> Thanks :)
22:07:15 <catohornet1> #topic For tommorow: We'll be working on Documenting, Mediawiki plugins, Code Coverage, OpenFlow --metering / Group,  (CPQD), Netopeer install on test vm; Netconf Test cases, Net Apps: Toaster, ping; Performance: Cbench test, inventory swtch, links
22:07:24 <catohornet1> #endmeeting