17:08:28 <LuisGomez> #startmeeting cluster test
17:08:28 <odl_meetbot> Meeting started Wed Oct  7 17:08:28 2015 UTC.  The chair is LuisGomez. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:08:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:08:28 <odl_meetbot> The meeting name has been set to 'cluster_test'
17:08:49 <LuisGomez> #chair jamoluhrsen
17:08:49 <odl_meetbot> Current chairs: LuisGomez jamoluhrsen
17:09:46 <LuisGomez> #topic action points
17:10:26 <LuisGomez> #info action point: clean the car-people test as well as file bugs
17:13:56 <jamoluhrsen> #info need to debug the stable/lithium cluster jobs.  external problems in beryllium that are unrelated to clustering
17:14:22 <jamoluhrsen> #info bug 4037 is one of the cluster test failures
17:14:44 <jamoluhrsen> #link https://bugs.opendaylight.org/show_bug.cgi?id=4037
17:16:07 * dfarrell07_conf is watching IRC btw, but doesn't have a way to call in while international
17:19:46 <jamoluhrsen> #info ssaxena1 has fixed some test issues in the past.  still more to look at
17:24:11 <jamoluhrsen> #info -all cluster test for beryllium finally starting, but lots of failures.
17:27:01 <jamoluhrsen> #info "wait for controller up" is timing out, but it's not marking it as a failure.
17:37:44 <jamoluhrsen> #info checking cluster sync status is ok to know if clustering is ready, but doesn't indicate if application is ready for cluster configs.
17:39:19 <jamoluhrsen> #info each application needs to have their own way to determine if they are ready for cluster testing to start
17:39:53 <LuisGomez> #topic cluster test plan for projects
17:40:09 <jamoluhrsen> really?  what version of ff
17:41:52 <jamoluhrsen> #info LuisGomez has draft of cluster testplan in robot format
17:45:00 <jamoluhrsen> #info clustering concept of leader/follower is not coupled with SB concept (e.g. openflow) of master/slave
17:51:52 <jamoluhrsen> #action need to verify that first controller that a southbound device is connected to will become the master
17:52:49 <jamoluhrsen> #info four combinations to test for CRUD (leader/master, leader/slave, follower/master, follower/slave)
18:02:17 <jamoluhrsen> #info will talk more cluster testing in thursday integration call
18:03:03 <LuisGomez> #endmeeting