17:05:19 <LuisGomez> #startmeeting cluster test
17:05:19 <odl_meetbot> Meeting started Wed Oct 14 17:05:19 2015 UTC.  The chair is LuisGomez. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:05:19 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:05:19 <odl_meetbot> The meeting name has been set to 'cluster_test'
17:05:32 <LuisGomez> #topic review of action points
17:05:54 <LuisGomez> #topic clean up car-people
17:06:09 <jamoluhrsen> #info LuisGomez has made some cleanup and changes are merged.
17:08:19 <jamoluhrsen> #info cars/people cluster tests now passing in -only- job.  test issues resolved and we expect 100% passing.
17:08:52 <jamoluhrsen> #info bug 4037 not being seen any more
17:09:57 <odp-gerritbot> Jamo Luhrsen proposed a change to integration/test: iterating on patch 28386  https://git.opendaylight.org/gerrit/28405
17:27:45 <jamoluhrsen> #info need to add config-pusher checks to controller deploy scripts
17:28:03 <jamoluhrsen> #info maybe check for server unhealthy instead of config-pusher
17:28:21 <jamoluhrsen> #action jamoluhrsen to add server unhealthy check to deploy scripts
17:29:05 <LuisGomez> #topic cluster deploy scripts
17:30:53 <jamoluhrsen> #info cluster config script is needed.
17:32:26 <jamoluhrsen> #info test needed to start cluster first and then start features
17:42:59 <jamoluhrsen> #info a script local to each controller that will handle setting up cluster configs, starting karaf is one idea.
17:43:23 <jamoluhrsen> #info end user only needs to edit karaf features.cfg file and then provide the IPs of the controllers in the cluster.
17:46:06 <jamoluhrsen> #action ssaxena1 to write a POC script for cluster setup and controller start
17:46:45 <LuisGomez> #topic cluster test plan
17:47:32 <jamoluhrsen> #info ericcson testplan and LuisGomez testplan was shared.  need more reviews
17:49:05 <jamoluhrsen> #info different node failures (stop controller, kill java process, etc)
17:49:30 <jamoluhrsen> #info southbound scenarios should include cases where device only connects to 1, 2 or all
17:51:37 <jamoluhrsen> #info isolation keywords are there.  we need write test cases that *isolate* as a form of failover
17:59:00 <jamoluhrsen> #action LuisGomez testplan redo
17:59:46 <LuisGomez> #action LuisGomez will update testplan for car-people test
18:00:02 <LuisGomez> #endmeeting