17:01:45 <dfarrell07> #startmeeting Integration
17:01:45 <odl_meetbot> Meeting started Thu Dec 17 17:01:45 2015 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:45 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:45 <odl_meetbot> The meeting name has been set to 'integration'
17:02:11 <dfarrell07> #info Jamo is not here this week, dfarrell07 and Luis to run meeting
17:03:01 <LuisGomez> #topic News
17:04:05 <dfarrell07> #info Boron Dev Design Forum will be 2/29-3/1 in San Fran
17:04:41 <dfarrell07> #info Vratko sent a large update to the Integration/Test/Test Code Guidelines wiki. Others should also make contribs, give feedback.
17:04:54 <dfarrell07> #link https://wiki.opendaylight.org/view/Integration/Test/Test_Code_Guidelines Int/Test (Int/*?) code guidelines being refactoring
17:08:32 <dfarrell07> #topic Int/Dist Updates
17:08:38 <dfarrell07> #info zxiiro and dfrarell07 briefly talked about maybe trying to include ODL's systemd .service file in the distribution
17:08:44 <dfarrell07> #link https://github.com/opendaylight/integration-packaging/tree/master/rpm/unitfiles Current location of ODL's systemd .service files
17:13:11 <dfarrell07> #info distro was broken for a while, errors going to karaf console vs log issue was fixed by a patch from jamo, going to be painful to debug at this point (remove some projects, try to build, try with different set of projects, repeat)
17:13:40 <dfarrell07> #info Discussion about Jenkins delay, how to speed it up or reduce load
17:15:34 <dfarrell07> #info tykeal points out that good smoke tests to run often, then full stuff less frequently, would help a lot
17:17:25 <dfarrell07> #undo
17:17:25 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1eabc10>
17:17:27 <dfarrell07> #undo
17:17:27 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1fe8d90>
17:17:35 <dfarrell07> #topic RelEng Updates
17:17:40 <dfarrell07> #info Discussion about Jenkins delay, how to speed it up or reduce load
17:17:43 <dfarrell07> #info tykeal points out that good smoke tests to run often, then full stuff less frequently, would help a lot
17:17:52 <dfarrell07> #info Since there's a lot of overlap between RelEng and Integration/*, both ppl and work, giving RelEng a portion of the Int/* meeting
17:17:59 <dfarrell07> #info Thanh has autorelease running as of Monday
17:18:06 <dfarrell07> #link https://nexus.opendaylight.org/content/repositories/staging/org/opendaylight/integration/distribution-karaf/0.4.0-Test-beryllium-v201512150335/ First Be autorelease artifacts (tmp repo)
17:18:15 <dfarrell07> #info dfarrell07's large JJB docs refactoring patch has been merged, more edits welcome in follow-up patches
17:18:19 <dfarrell07> #link https://nexus.opendaylight.org/content/sites/site/org.opendaylight.releng.builder/master/jenkins.html Current JJB docs
17:19:20 <odp-gerritbot> Lori Jakab proposed a change to integration/test: LISP: Separate Lithium and Beryllium tests  https://git.opendaylight.org/gerrit/31304
17:29:16 <dfarrell07> #info Vratko points out that some people push many, many patch-sets for new changes. When they don't need tests, they should mark that frequently-updating change as a draft to avoid kicking off verify jobs.
17:30:20 <dfarrell07> #action Vratko to get that feedback/tip about reducing verify jobs using drafts into a wiki
17:31:00 <dfarrell07> #topic Int/Pack Updates
17:31:11 <dfarrell07> #info dfarrell07 created "Experimental Release Preview" (ERP) ODL RPM based on the first successful Be autorelease build artifacts
17:33:47 <dfarrell07> #info ERP RPM is designed to allow OPNFV testing projects to start consuming ODL Be well before OPNFV Brahmaputra, which gives them confidence to include a flag to install OPNFV with ODL Be vs Li
17:33:54 <dfarrell07> #info sudo yum install -y http://cbs.centos.org/repos/nfv7-opendaylight-4-testing/x86_64/os/Packages/opendaylight-4.0.0-1.20151215033.el7.noarch.rpm
17:34:40 <dfarrell07> #link https://github.com/dfarrell07/vagrant-opendaylight/blob/1c69f5839f2f15965557c32521c4250fc805939a/Vagrantfile#L74-L92 CentOS 7 Vagrant box that installs ERP via repo config
17:34:47 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/31376/1/rpm/example_repo_configs/opendaylight-4-testing.repo To-be-merged example repo config for installing Be ERPs
17:34:54 <dfarrell07> #info dfarrell07 would really appreciate it if someone would create a .deb package for ODL
17:35:08 <dfarrell07> #topic General updates, questions, etc
17:35:36 <dfarrell07> #info Vratko asks if there's a good way to auto-remove a feature from autorelease if it's removed from integration
17:38:12 <dfarrell07> #info Discussion about having autorelease working from the very start of Boron
17:38:47 <dfarrell07> #info zxiiro points out that master currently works, so we should have a working autorelease once we branch
17:40:19 <dfarrell07> #info tykeal points out that autorelease doesn't exist until mid-Li, hence the world-always-broken state before now
17:40:29 <dfarrell07> #undo
17:40:29 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2044390>
17:40:38 <dfarrell07> #info tykeal points out that autorelease didn't exist until mid-Li, hence the world-always-broken state before now
17:41:10 <dfarrell07> #info Discussion about new autorelease verify jobs that should help break autorelease breakages
17:41:56 <dfarrell07> #info LuisGomez points out that we need to make it clear that breaking autorelease == bad and we'll kick you out until you stop
17:42:21 <tykeal> beatings will continue until... ;)
17:42:25 <dfarrell07> ;)
17:43:17 <dfarrell07> #info LuisGomez points out that we need to make it clear when new projects need to be in autorelease. Maybe m2, since need to be in distribution by m3?
17:45:14 <dfarrell07> #info Discussion about opflex isn't really a part of the release "train" as zxiiro puts it, shouldn't really be a part of the SR
17:46:12 <dfarrell07> #info LuisGomez, dfarrell07, zxiiro  and others want to make it clear to new projects that being part of the SR isn't a bad thing if you don't need it, no need to take part if bad fit
17:46:35 <dfarrell07> #info Int/Dist hasn't sent out M4, anipbu points out
17:47:10 <dfarrell07> #action edwarnicke (or some other Int/Dist person?) to send Int/Dist M4
17:47:31 <dfarrell07> #info Discussion about how autorelease likely shouldn't be part of the SR, since every field is NA
17:48:28 <dfarrell07> #info Vratko points out that Int/Dist needs to have a primary contact other than PTL
17:50:13 <zxiiro> anipbu: maybe we should build a tool that people can run and answer the milestone questions and it automatically sends teh email to the mailing list for them
17:50:28 <dfarrell07> #agreed Next two Int/* meetings (12/24 and 12/31) are canceled due to Christmas and New Years
17:50:28 <zxiiro> anipbu: one issue i always have with the template is I forget where to get it
17:51:02 <anipbu> zxiiro: i would like to put such an app in  spectrometer do that.
17:51:30 <anipbu> zxiiro: that was one of the reasons I joined spectrometer =)
17:51:47 <dfarrell07> #info dfarrell07 asks if we can start using JIRA for issue tracking, not sure if it's still a pilot or ready-for-use
17:51:55 <dfarrell07> #info dfarrell07 is interested in getting Int/*'s many Meetbot minutes dirs `cp/mv`'d into a single one
17:52:05 <dfarrell07> #info dfarrell07 says it makes it hard to find minutes for a date, have to know which dir to check
17:52:14 <dfarrell07> #link https://meetings.opendaylight.org/opendaylight-integration/2015/ Meetings minutes for this IRC chan, split incorrectly into many different dirs b/c of inconsistent meeting name
17:52:40 <dfarrell07> #link https://trello.com/b/ACYMpTVD/opendaylight-integration Trello for Int/*
17:52:43 <tykeal> dfarrell07: JIRA is still in pilot there's open questions that must be answered still
17:52:59 <dfarrell07> tykeal: yeah, I thought there was something like that
17:53:15 <dfarrell07> tykeal: not a prio I guess, but I'd be great to start using it
17:53:21 <dfarrell07> it'd*
17:53:35 <tykeal> dfarrell07: what's the thing about meetbot minutes?
17:54:00 <dfarrell07> tykeal: they are spread out in many dirs with various names based on how we started the meeting
17:54:07 <dfarrell07> tykeal: so it's hard to find anything
17:54:20 <tykeal> yeah, I can't make it happen for a subset of meetings
17:55:17 <dfarrell07> tykeal: I'd rather incorrectly drop things into the same dir than have them spread out like they are, imho
17:55:57 <tykeal> dfarrell07: open a ticket ;)
17:56:14 <dfarrell07> tykeal: need to get agreement from this group first :)
17:56:19 <dfarrell07> tykeal: but yeah, +1, will do
17:56:20 <tykeal> lol
17:57:49 <tykeal> https://meetings.opendaylight.org/opendaylight-integration/2015/
17:59:20 * tykeal notes the TSC call starts in less then 1 minute
17:59:32 <dfarrell07> #action dfarrell07 to raise helpdesk ticket to refactor meeting minutes dir structure as described above
17:59:36 <dfarrell07> LuisGomez: TSC
18:01:33 <dfarrell07> #endmeeting