16:03:32 <dfarrell07> #startmeeting Integration Teem Weekly Meeting
16:03:32 <odl_meetbot> Meeting started Thu Jan 15 16:03:32 2015 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:32 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:32 <odl_meetbot> The meeting name has been set to 'integration_teem_weekly_meeting'
16:03:57 <dfarrell07> #chair LuisGomez
16:03:57 <odl_meetbot> Current chairs: LuisGomez dfarrell07
16:04:24 <LuisGomez> #topic news and updates
16:05:10 <dfarrell07> #info Integration team gathering on 1/27-28
16:06:27 <dfarrell07> #action LuisGomez will create agenda for gathering
16:07:52 <dfarrell07> #info Test plan was sent out last week. No push-back so far, looks good.
16:09:21 <dfarrell07> #info Future test work will likely be more use-case driven, per community input on important use-cases
16:17:36 <icbts> Will test distribution come with perf tools such as benchmark tests?
16:18:51 <dfarrell07> icbts: I doubt it
16:19:15 <icbts> dfarrell07: will it be clear to end users that test distro is not for general consumpton?
16:19:41 <dfarrell07> #info LuisGomez talks about ODL features, features needed by our team for testing that shouldn't ship to users, how to achieve that state
16:19:57 <dfarrell07> #info icbts asks about test distro and if it'll include perf tools
16:20:38 <dfarrell07> #info dfarrell07 suggests that a test distro wouldn't include perf tools, as those are likely best treated as external tools to stand up beside an ODL distro
16:20:55 <dfarrell07> icbts: I doubt we'd put it on the dl page
16:21:09 <dfarrell07> icbts: That should go a long way to keep users away
16:21:19 <dfarrell07> *from test distro
16:24:07 <icbts> dfarrell07: makes sense
16:30:08 <icbts> define profiles in the maven pom
16:30:47 <icbts> we use profiles in karaf for developer quick builds, release builds, standard builds, etc
16:31:01 <icbts> so set up Jenkins to watch the profile used for the build
16:31:16 <dfarrell07> LuisGomez: ^^
16:31:22 <icbts> http://maven.apache.org/guides/introduction/introduction-to-profiles.html
16:32:20 <icbts> #link http://maven.apache.org/guides/introduction/introduction-to-profiles.html <— use profiles to simplify your builds here
16:35:33 <dfarrell07> #info Need to put thought into how to do next gen of perf tests. Should run in CI for sure. Spirent perf tests could be done less frequently, not every merge.
16:37:36 <dfarrell07> #info Suggestion to ask projects about their perf test needs
16:45:49 <dfarrell07> #info Suggestion to create Vagrantfile to replace test tools VM
16:46:13 <dfarrell07> #info Tons of issues with having a full VM for test tools (can't reproduce, can't say exactly what's there, export issues, no version control)
16:46:43 <dfarrell07> #action dfarrell07 will create Trello card for test tools Vagantfile, to be completed fairly far down the road
16:48:19 <dfarrell07> #info Discussion about state of Spirent lab
16:48:57 <dfarrell07> #link https://github.com/dfarrell07/dfarrell07-opendaylight ODL Puppet mod dfarrell07 is working on
16:49:10 <dfarrell07> #action dfarrell07 to drop latest ODL RPM in int repo ASAP
16:56:33 <dfarrell07> phrobb: Great question :)
16:57:43 <dfarrell07> #info phrobb asks LuisGomez about interactions with other projects to get support for testing use-cases, periodic "releases", etc
17:03:17 <dfarrell07> #endmeeting