15:00:17 <dfarrell07> #startmeeting Integration Weekly Meeting
15:00:17 <odl_meetbot> Meeting started Thu May 21 15:00:17 2015 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:00:17 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:00:17 <odl_meetbot> The meeting name has been set to 'integration_weekly_meeting'
15:00:40 <dfarrell07> #link https://trello.com/b/ACYMpTVD/opendaylight-integration Trello with relevant tasks
15:07:49 <dfarrell07> #info LuisGomez gives updates on ONS plugfest. Represented ODL, went well.
15:08:26 <dfarrell07> #info There's a new "link switch" OVS-related thing that we might want to include in our testing boxes
15:09:55 <dfarrell07> #info ODL is now using enough Rackspace stuff that we have a dedicated rep
15:10:46 <dfarrell07> #topic Task updates
15:13:23 <dfarrell07> #info Long-run test basics are done. Need to do some infra work (stand up VA data center) before we can do the weekly 24 hour run we'd like to do initially.
15:14:00 <dfarrell07> #info tykeal suggests running Saturday early morning PT for now to avoid resource constraint above
15:16:32 <dfarrell07> #info torbit has some initial work done on the latest-OVS Mininet VM. dfarrell07 gave him a brain dump on releng/builder, he's now porting his work to that env.
15:17:35 <dfarrell07> #info tykeal recommends building Fedora or EL7 boxes when possible (relevant to new Mininet VM), Ubuntu support is a well-known TODO but not ready yet
15:19:46 <dfarrell07> #info We may also run Mininet in Docker containers if F20 or F21 doesn't work out for some reason. No one is actually sure if Mininet works in Docker.
15:20:52 <odp-gerritbot> Vratko Polák proposed a change to integration: Tools: Dummy play.py file added  https://git.opendaylight.org/gerrit/20905
15:21:42 <dfarrell07> #action dfarrell07 to create a wiki with available Python modules on test systems
15:22:16 <dfarrell07> #info Sandeep has an initial scale test under review
15:23:18 <dfarrell07> #info dfarrell07 and Jamo are working on adding some IP/MAC address-related Python modules to the test boxes. Please use those vs writing your own painful logic for working with addresses!
15:25:56 <odp-gerritbot> Vasanthan Balasubramaniyan proposed a change to integration: Added new testcases for FlowMeter,FlowGroupMetrics on both H2 and HBase DataStore. Modified TsdrUtils.txt to taken care of hbase server and stop  https://git.opendaylight.org/gerrit/20886
15:35:26 <dfarrell07> #link https://wiki.opendaylight.org/view/GettingStarted:Pulling,_Hacking,_and_Pushing_All_the_Code_from_the_CLI Main wiki on contributing patches
15:35:59 <dfarrell07> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Hack_Code Integration-spicific wiki on contributing code
15:36:22 <dfarrell07> #info Question about process of sending patches. Answer, see links above, ping us on IRC.
15:41:51 <dfarrell07> #info dfarrell07 has been working with OPNFV Genesis to get pre-release version of Arno stable enough for our consumption for a large Neutron test. Painful, but some progress.
15:42:26 <dfarrell07> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Hack_Code Under-dev ODL Ansible role dfarrell07 is working on (making quick progress releative to Puppet mod)
15:48:39 <dfarrell07> #info Good overview of cluster deploy scripts from LuisGomez
15:50:45 <dfarrell07> #info Just because people are already assigned to TODO-list Trello cards doesn't mean they own them and don't want/need contributions from others. They are just interested in the TODO/want it done. Please feel free to jump on any card. :)
15:52:07 <dfarrell07> #endmeeting