16:04:38 <dfarrell07> #startmeeting Integration Weekly Meeting
16:04:38 <odl_meetbot> Meeting started Thu Oct  1 16:04:38 2015 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:38 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:38 <odl_meetbot> The meeting name has been set to 'integration_weekly_meeting'
16:04:55 <dfarrell07> #topic int/dist updates
16:05:14 <dfarrell07> #info Vrakto reports that there are issues with the builds, taking a long time and failing
16:05:59 <dfarrell07> #info Build issues are being debugged, YANG changes may be related, Vrakto et al are on it
16:06:45 <dfarrell07> #topic int/pack updates
16:07:12 <dfarrell07> #info Not too much going on, still a large RPM refactoring patch on Gerrit that needs docs before merge
16:07:34 <dfarrell07> #info dfarrell07 is going to LinuxCon EU to speak on int/pack topics next week, will not be around IRC or email as much (no mobile data)
16:08:34 <dfarrell07> #topic int/test updates
16:09:40 <dfarrell07> #info zxiiro has been working an Ubuntu VM with a newer version of OVS, jamoluhrsen will consume the next iteration soon to test out recent changes
16:10:22 <dfarrell07> #info This new Ubuntu VM (with newer OVS versions) will become the default for many mininet/ovs tets
16:11:35 <dfarrell07> #action jamoluhrsen to go look at robot jobs and tell tykeal if they need the robot metadata (I kinda missed the details of this)
16:12:15 <dfarrell07> #action jamoluhrsen will test the new Ubuntu/OVS/Mininet VM
16:12:25 <dfarrell07> #info stable/<tags> will be discussed over email
16:14:39 <dfarrell07> #info An Ho asks about long job queue, zxiiro reports it's still long, a number of people clarify that things should speed up and clear out
16:15:27 <dfarrell07> #topic Trello
16:15:49 <dfarrell07> #info Vrakto reports that PCEP perf test is done and merged
16:17:54 <dfarrell07> #info jamoluhrsen reports that Docker container CI stuff is almost working, cleanup time. We can stand up multi containers on a CI VM and access them from other VMs. This is a big win, huzzah!
16:18:16 <dfarrell07> #info Fedora Mininet card abandoned because we're moving to Ubuntu for Mininet/OVS
16:18:53 <dfarrell07> #info Linux prompt discussion hasn't changed
16:19:07 <dfarrell07> #info Luis and Marcus aren't here today, can't cover their cards
16:19:42 <dfarrell07> #info There's a patch with proposals/discussions for better robot var names, hasn't changed much
16:26:04 <dfarrell07> #info There's a mailing list discussion about postman collections and adding them to the int/test repo
16:26:35 <dfarrell07> #topic cluster test group updates
16:26:54 <dfarrell07> #info Second cluster test group meeting was this past Wednesday
16:27:25 <dfarrell07> #link https://wiki.opendaylight.org/view/Meetings#Cluster_Test Cluster meeting details
16:27:55 <dfarrell07> #info Cluster test group is planning template/keyword/other infra to help projects write cluster tests
16:30:13 <dfarrell07> #link https://lists.opendaylight.org/pipermail/integration-dev/2015-September/004676.html Cluster test call minutes
16:30:13 <dfarrell07> test (IRC lag)
16:31:09 * dfarrell07 is back on IRC
16:32:23 <dfarrell07> #info Radika points out that OVSDB has done some Docker cluster work, jamoluhrsen may benefit from checking out what they've done
16:32:34 <jamoluhrsen> http://vishnoianil.github.io/2015/09/ovsdb-clustering-development-environment-setup/
16:33:06 <dfarrell07> #link http://vishnoianil.github.io/2015/09/ovsdb-clustering-development-environment-setup/ Docker cluster OVSDB work we may want to study
16:34:59 <dfarrell07> #info Still need someone to make a job to run the DSBenchmark tests in CI
16:35:24 <dfarrell07> #info Maven Sites docs is still a TODO, no updates this week that we know of, will be a good docs tool in the future
16:36:20 <odp-gerritbot> A change was merged to integration/distribution: Added topoprocessing top-level features  https://git.opendaylight.org/gerrit/27745
16:38:43 <zxiiro> jamoluhrsen: sorry i lost internet for a bit there
16:38:45 <dfarrell07> #info dfarrell07 pinged the Veryx perf testing tool eval thread to let the know we care, are talking about evaling the tool but don't have anyone with free cycles stepping up to do it
16:39:35 <Radhika> Please check this wiki link - https://wiki.opendaylight.org/view/OpenDaylight_Controller:Clustering
16:39:55 <dfarrell07> #link https://wiki.opendaylight.org/view/OpenDaylight_Controller:Clustering Radhika has some good clustering docs, please check them out
16:40:05 <dfarrell07> Radhika: ^^That's the format for adding a link to the minutes
16:40:30 <Radhika> Documents related to clustering is listed here
16:40:38 <zxiiro> jamoluhrsen: still working on getting maven-sites into a few projects. working on yangtools at the moment
16:41:29 <dfarrell07> #info zxiiro is working with the yangtools project to get maven-sites running
16:41:59 <dfarrell07> #action jamoluhrsen to follow up with zxiiro about standing up maven-sites docs stuff for int/test
16:42:54 <odp-gerritbot> Dileep Ranganathan proposed a change to integration/test: Init ODL controller for demo-symmetric-chain  https://git.opendaylight.org/gerrit/27574
16:44:16 <dfarrell07> thanks @ all :)
16:44:19 <dfarrell07> #topic cookies
16:44:21 <dfarrell07> #endmeeting