17:10:55 <tykeal> #startmeeting Weekly Integration Meeting
17:10:55 <odl_meetbot> Meeting started Thu Dec  3 17:10:55 2015 UTC.  The chair is tykeal. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:10:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:10:55 <odl_meetbot> The meeting name has been set to 'weekly_integration_meeting'
17:11:01 <tykeal> #chair dfarrell07 jamoluhrsen
17:11:01 <odl_meetbot> Current chairs: dfarrell07 jamoluhrsen tykeal
17:11:13 <dfarrell07> tykeal: thanks!
17:11:26 <dfarrell07> #info Meetbot was down
17:11:33 <tykeal> yep, probably fallout from the DDoS that Freenode experienced earlier this week
17:12:19 <dfarrell07> #info dfarrell07 has been working on puppet-opendaylight this week per OPNFV requests, adding config knobs and getting SR2 updates on CBS and in mod
17:12:24 <jamoluhrsen> #info opnvf wants more config knobs in puppet module and provided
17:12:30 <jamoluhrsen> #info want some system tests for packaging features
17:12:39 <jamoluhrsen> #action dfarrell07 ^^^
17:12:46 <jamoluhrsen> #info want autorelease to start providing Be pre-release
17:12:55 <dfarrell07> #info int/pack will need to turn autorelease crank to deliver Be ERP to OPNFV soon
17:13:10 <jamoluhrsen> #info SR3 is pending one question to SNMP before green light from Int/Test
17:14:57 <jamoluhrsen> #info question to the group about sticking with just master branch or having multiple branches to track differences in test
17:15:20 <jamoluhrsen> #info dfarrell07 hopes to find way to just stay with one branch
17:15:47 <dfarrell07> #info Vratko points out that should be able to add conditionals to deal with Be/Li test diffs
17:16:38 <jamoluhrsen> #info maybe check lisp orgbp for examples
17:17:31 <odp-gerritbot> Radovan Sajben proposed a change to integration/test: BGP application peer functional test suite  https://git.opendaylight.org/gerrit/30194
17:18:48 <jamoluhrsen> #info question about what does compatible-with-all really mean?
17:19:56 <jamoluhrsen> #info gvrangan notes that originally it was there because multiple features were trying to install incompatible flow entries
17:20:51 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Integration/Test/Mature_Graduation_Review
17:21:09 <jamoluhrsen> #info graduation review template for Mature status ^^
17:23:57 <jamoluhrsen> #action fix review template webex recording links
17:25:18 <jamoluhrsen> #action jamoluhrsen ^^
17:25:52 <jamoluhrsen> #info dfarrell07 asking tykeal about when autorelease can build and get Be pre-release (ask from opnfv)
17:26:08 <tykeal> #undo
17:26:08 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x204e510>
17:26:22 <tykeal> #info dfarrell07 asking zxiiro about when autorelease can build and get Be pre-release (ask from opnfv)
17:26:38 <jamoluhrsen> #info zxiiro says autorelease not giving clean build... yet
17:27:09 <dfarrell07> #info autorelease currently can't build, zxiiro points out that known blocking patches have been merged, just kicked off a build so will have feedback in ~8 hours
17:27:18 <tykeal> why is it I hear multi-patch and keep going "LiLu Dallas Multi-pass!" in my head?
17:27:41 <dfarrell07> #info jamoluhrsen has full-of-win multipatch job working!
17:28:24 <odp-gerritbot> Samuel Kontriš proposed a change to integration/test: add aggregation basic keywords and testcase  https://git.opendaylight.org/gerrit/29913
17:36:08 <dfarrell07> #info jamoluhrsen is working on JDK 8 coverage
17:37:07 <tykeal> zxiiro: we need to give the integration jobs the ability to sudo the java alternatives
17:38:02 <zxiiro> tykeal: I guess we need to add something to the spinup scripts for that?
17:38:14 <tykeal> zxiiro: yes
17:38:26 <zxiiro> tykeal: actually probably should do it for all vms since we'll be switching to JDK8 soon
17:38:37 <zxiiro> tykeal: i'll add it to my list
17:38:39 <tykeal> zxiiro: yeah, just do it in the base spin-up
17:40:00 <tykeal> yes it is
17:52:52 <ChUsama> Hi jamoluhrsen
18:01:58 <jamoluhrsen> hi ChUsama....  what's up?
18:05:11 <ChUsama> About the JDK8 work, I have bandwith and I'm interested to play with it. If you can give me some pointers
18:06:16 <ChUsama> What my understanding from that task is to have an option to choose the version like the one we have e.g mininet-vm
18:07:34 <ChUsama> We specify in the JJB which vm to use but the default is set to rk-c-el6-mininet in releng-defaults
18:36:59 <odp-gerritbot> Radovan Sajben proposed a change to integration/test: BGP application peer performance suite  https://git.opendaylight.org/gerrit/30256
18:39:51 <zxiiro> jamoluhrsen: I think we forgot ot endmeeting?
18:44:34 <jamoluhrsen> #endmeeting