17:02:03 <dfarrell07> #startmeeting Integration
17:02:03 <odl_meetbot> Meeting started Thu Jan 14 17:02:03 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:03 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:03 <odl_meetbot> The meeting name has been set to 'integration'
17:02:13 <dfarrell07> #chair jamoluhrsen LuisGomez
17:02:13 <odl_meetbot> Current chairs: LuisGomez dfarrell07 jamoluhrsen
17:05:47 <jamoluhrsen> #info need to remove lacp from distribution
17:06:01 <jamoluhrsen> #info vratko has a patch for lacp removal
17:06:34 <jamoluhrsen> #info sdninterfaceapp wants in distribution but they are not running single feature test
17:07:40 <jamoluhrsen> #info monday openflowplugin meeting to discuss how to deal with two plugin impls going forward?
17:11:43 <jamoluhrsen> #info patch 32248 looking to test distribution before merge job success
17:14:52 <jamoluhrsen> #info LuisGomez would like zxiiro to look at patch 32248, but it will be some time before zxiiro can look.
17:20:42 <jamoluhrsen> #info might be a way to remove submit from reviewers and give that task to jenkins who will do it after checks are made
17:21:18 <jamoluhrsen> #info snbi still does not have features in distribution.  anipbu has sent email
17:21:53 <anipbu> #link https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1401406837
17:22:43 <jamoluhrsen> can I undo that last note?
17:23:54 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-January/005537.html
17:24:59 <jamoluhrsen> #info packaging making technical progress.  upstream ODL puppet module is live
17:26:35 <jamoluhrsen> #info rpm changes being made and opnfv CI taking advantage
17:27:12 <jamoluhrsen> #info .deb packaging project added as a mentor project.
17:28:28 <jamoluhrsen> #info robot VMs are now only running with 2GB and no problems so far.
17:28:37 <jamoluhrsen> #info robot VM limit increased from 15 to 20
17:29:23 <jamoluhrsen> #info can we migrate the el6 mininet VMs to the ubuntu VMs?
17:29:39 <dfarrell07> #link https://github.com/redhat-openstack/openstack-puppet-modules/tree/master/opendaylight puppet-opendaylight in the OpenStack Puppet Modules project
17:30:40 <dfarrell07> #info Major updates to ODL RPM CentOS Community Build System stuff, adds nice features including ability to pin to an SR (vs just major version), finally approved by CentOS admins
17:31:35 <jamoluhrsen> #action jamoluhrsen create trello card to start changing CSIT jobs to use ubuntu mininet vms
17:32:23 <jamoluhrsen> #info moved JJB related jobs to it's own system off of the jenkins master
17:33:55 <LuisGomez> #info Jenkins looks really good now :)
17:35:38 <jamoluhrsen> #info Beryllium weekly sync discussed multi-openflowplugin impls, copyright headers, renaming features.
17:36:47 <odp-gerritbot> Radovan Sajben proposed a change to integration/test: basic eBGP peers functional suite:  https://git.opendaylight.org/gerrit/31778
17:38:41 <jamoluhrsen> #info new robot requests library causing issues with json data and headers
17:39:39 <jamoluhrsen> #info vrpolak thinks short term solution is to use yang+json header and then not worry to configure data to json.
17:40:16 <jamoluhrsen> #info vrpolak thinks long term solution is to contribute to requests library project to make this more consumable
17:40:47 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-January/005551.html
17:41:59 <jamoluhrsen> #action vrpolak to send email explaining the requestslibrary "retry" warnings; why it comes, how to fix, etc
17:42:55 <jamoluhrsen> #info please encourage community to broadcast emails.  seems like more unicasts are coming recently
17:45:34 <jamoluhrsen> #info test breakages recently.  verify python job fixed.  pep8 more strict, but fix believed to be in.
17:46:56 <LuisGomez> #info Vratko also fixed the verify library job
17:47:28 <jamoluhrsen> #info Boron release planning conversations happening now.  TWS calls.
17:52:27 <jamoluhrsen> #info congrats to radhika on career move.  thanks for all the contributions.
17:52:27 <LuisGomez> #info Radhika got a job, she will be less available in ODL, thanks Radhika for your contribution.
17:53:53 <odp-gerritbot> premnath sundarababu proposed a change to integration/test: Submitting Scripts for Openflow Metrics in HSQLDB Data Store.  https://git.opendaylight.org/gerrit/32603
17:54:57 <jamoluhrsen> #info dfarrell07 would like to move Int/Pak trello work to Jira.  tykeal says we need TSC to take care of stuff before we can move jira to production
18:00:39 <jamoluhrsen> #endmeeting