17:03:37 <dfarrell07> #startmeeting integration
17:03:37 <odl_meetbot> Meeting started Thu Feb 18 17:03:37 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:37 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:37 <odl_meetbot> The meeting name has been set to 'integration'
17:04:08 <dfarrell07> #char jamoluhrsen
17:04:13 <dfarrell07> #chair jamoluhrsen
17:04:13 <odl_meetbot> Current chairs: dfarrell07 jamoluhrsen
17:05:56 <dfarrell07> #info anipbu gives Be release updates
17:06:18 <dfarrell07> #info worries about infra issues reported during Be sync, sshpass and similar
17:06:20 <jamoluhrsen> #info infra issues was a concern earlier in week, but zxiiro has fixed this.  big thanks
17:06:25 <dfarrell07> #info no blocking bugs on Be
17:06:41 <dfarrell07> #info release reviews are still in progress
17:08:02 <jamoluhrsen> #info group agrees that documentation should be a higher priority
17:09:33 <anipbu> https://jenkins.opendaylight.org/releng/job/topoprocessing-csit-1node-topology-operations-only-beryllium/329/robot/report/log.html
17:11:01 <dfarrell07> #info jamoluhrsen has been auditing system tests, finding very poor examples for many projects
17:11:20 <dfarrell07> #info jamoluhrsen reports that some projects have tests, but they never pass, are generally crap
17:15:04 <LuisGomez> sorry joined late, some unexpected traffic
17:15:13 <jamoluhrsen> morning LuisGomez
17:15:33 <jamoluhrsen> #action jamoluhrsen to give link to An for system test expectations.
17:17:07 <dfarrell07> #info anipbu proposes three-phase testing checks for Boron release plan - 1) have tests 2) have functional coverage 3) have tests passing (or pointing at bugs that describe why they are failing)
17:18:45 <anipbu> https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=83290213
17:19:08 <odp-gerritbot> Tomas Cechvala proposed a change to integration/test: DO NOT MERGE devstack test  https://git.opendaylight.org/gerrit/32934
17:22:00 <jamoluhrsen> #action jamoluhrsen to start email about making system test a little more formal and top-of-mind for Boron
17:26:56 <jamoluhrsen> #action jamoluhrsen to send email for anipbu's tool for web crawling and reporting
17:28:02 <jamoluhrsen> #info not much news from distribution.
17:28:38 <jamoluhrsen> #info some bugs fixed in projects to stop full exception traces
17:29:58 <jamoluhrsen> #info of-config has bug in Be release where they give a 1M character single log line
17:30:51 <jamoluhrsen> #info vratko points out that autorelease is having trouble with lithium
17:31:16 <jamoluhrsen> #info distribution test CSIT jobs are triggered even when autorelease fails.
17:33:06 <jamoluhrsen> #info we need to configure autorelease to *NOT* trigger when unstable as well as fail.
17:33:28 <jamoluhrsen> #action zxiiro to make this change ^^^
17:34:01 <jamoluhrsen> #info packaging is keeping the flow of Be RC distros going to OPNFV
17:34:28 <jamoluhrsen> #info bootstrapping docs for packing... link below
17:35:33 <jamoluhrsen> #info packaging intern accepted and ramping up.
17:37:24 <dfarrell07> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Packaging:ODL_Bootstrap Int/Pack ODL bootstrap docs, may be useful for other Int/* projects
17:37:39 <jamoluhrsen> #action LuisGomez to send email to get topics for dev-forum.
17:39:50 <odp-gerritbot> Samuel Kontriš proposed a change to integration/test: Topoprocessing - reworked test Unification Termination Point Inside  https://git.opendaylight.org/gerrit/34922
17:40:33 <jamoluhrsen> #info vratko shaing his templated requests patch
17:40:35 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/33987/
17:41:31 <jamoluhrsen> #info super cool to have unittests for system test libraries
17:55:28 <dfarrell07> #endmeeting