17:06:57 <jamoluhrsen> #startmeeting integration
17:06:57 <odl_meetbot> Meeting started Thu Mar  3 17:06:57 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:06:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:06:57 <odl_meetbot> The meeting name has been set to 'integration'
17:07:33 <jamoluhrsen> #info distribution has no news
17:07:42 <jamoluhrsen> #info vratko points out there is an odl-jolokia feature
17:07:52 <jamoluhrsen> #action vratko to send email about using odl-jolokia feature
17:08:47 <jamoluhrsen> #info packaging talk went well at design forum
17:08:59 <jamoluhrsen> #info main action item was to add more features to CI
17:10:47 <jamoluhrsen> #info tykeal gives shortform version of what/why/how of zuul and nodepool.
17:12:38 <jamoluhrsen> #info zuul and nodepool have different mechanisms for triggering jobs and bringing up VMs
17:13:17 <jamoluhrsen> #info tykeal thinks it's still worth the effort to trim the job queue.
17:14:18 <jamoluhrsen> #info netconf job was changed to not use c6 VM so it can be deprecated
17:14:37 <jamoluhrsen> #action zxiiro to double check ^^ and remove c6 vm
17:15:05 <jamoluhrsen> #info Lithium SR4 is good to go.
17:18:10 <jamoluhrsen> #info kindly ask projects to start marking test cases for Beryllium with their bug ids
17:18:52 <jamoluhrsen> #info vratko asks if we can delete helium jobs
17:19:16 <jamoluhrsen> #action zxiiro to merge patch  https://git.opendaylight.org/gerrit/#/c/32928
17:22:26 <jamoluhrsen> #info new openstack + opendaylight sub group created at dev design forum
17:22:48 <jamoluhrsen> #link https://trello.com/b/T3U8seZx/opendaylight-openstack-system-test
17:25:34 <jamoluhrsen> #action Int/Dist to generate requirements for extra tools being pushed to distribution
17:27:31 <jamoluhrsen> #info perf/scale dashboard needed.  intern possibility from ghzao
17:28:53 <jamoluhrsen> #info mgkwill brought up the idea of having a release by release white paper outlining our perf/scale observations.
17:29:30 <jamoluhrsen> #info mgkwill confirms we are going to start a periodic call to find a set of metrics to use in this white paper
17:29:53 <jamoluhrsen> #info perf tracking group to meet tomorrow at 8am, maybe weekly after that.
17:30:11 <jamoluhrsen> #info mgkwill might have inside lead to some resources to help on a dashboard
17:30:52 <jamoluhrsen> #info jamoluhrsen wonders what format/where/how the white paper(s) would be maintained.
17:31:47 <jamoluhrsen> #info anipbu asks what the requirements are for the performance metrics?  can any project contribute?
17:34:59 <jamoluhrsen> #info upgrade story not well defined but when it is, it's important to get in CSIT
17:37:01 <jamoluhrsen> #info jamoluhrsen lobbies all projects to tighten up and clean all their current system test as top priority
17:39:03 <jamoluhrsen> #info vratko, jozef sending sporadic system test results and seems possible that it's working to create more visibility and probably better quality
17:39:45 <jamoluhrsen> #info anipbu gives big +1 on the sporadic test report
17:40:37 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-March/006008.html
17:41:21 <jamoluhrsen> #info anipbu points out that new projects with only 1 committer need to be made very aware of all the overhead, especially system test
17:45:13 <jamoluhrsen> #info jamoluhrsen asks where we should start keeping our docker containers?
17:45:26 <jamoluhrsen> #info mgkwill says maybe nexus, but tykeal says no way!
17:46:03 <jamoluhrsen> #info mgkwill wonders if we can just put the binary artifacts there?
17:46:58 <jamoluhrsen> #info dfarrell07 thinks Int/Pack can help figure this out.  maybe an official dockerhub account.
17:46:59 <odp-gerritbot> Vratko Polák proposed a change to integration/test: Rework of controller car/people cluster suite  https://git.opendaylight.org/gerrit/33358
17:47:46 <jamoluhrsen> #info mgkwill wants a local repo, but we need to wait until nexus v3 shows up.
17:48:37 <jamoluhrsen> #action jamoluhrsen and dfarrell07 to start email discussion about this docker stuff
17:49:19 <jamoluhrsen> #info mgkwill asks about spinning docker containers instead VMs in private cloud.
17:50:16 <jamoluhrsen> #info figure this out would be a serious chunk of work, and we can't start until we migrate to the private cloud.
17:51:25 <jamoluhrsen> #info vratko has releng/builder patch to add new variable to pybot to include ${stream} string.
17:52:35 <jamoluhrsen> #info action jamoluhrsen to look at sfc job, thinks it's broken based on ODL_VERSION
17:59:13 <jamoluhrsen> #endmeeting