16:03:37 <jamoluhrsen> #startmeeting integration
16:03:39 <odl_meetbot> Meeting started Thu Mar 24 16:03:37 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:39 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:39 <odl_meetbot> The meeting name has been set to 'integration'
16:04:28 <jamoluhrsen> #info vratko now Integration/Distribution PTL.  congrats!
16:04:37 <jamoluhrsen> #info SR1 Beryllium bumping finished.
16:05:24 <jamoluhrsen> #info some distro changes coming (e.g. python verify init file)
16:05:37 <dfarrell07> congrats Vratko!
16:05:56 <jamoluhrsen> #info bug 4296 being worked on and now some java code will end up in distribution
16:07:45 <anipbu> Congratulations Vratko!!!!!!!!!!!!!!!!
16:08:15 <jamoluhrsen> #info opnfv now consuming Be SR1 from packaging (rpms)
16:08:35 <jamoluhrsen> thanks for always staying on top of those things dfarrell07!
16:09:20 <jamoluhrsen> #info @ ONS, ODL was noticed as the easiest consumed by OPNFV
16:10:49 <jamoluhrsen> #info LuisGomez asks if there was any idea of what kind of features are consumed in downstream
16:11:08 <jamoluhrsen> #info jamoluhrsen knows that odl-ovsdb-openstack is one main feature in use.  sfc must be there too
16:14:31 <jamoluhrsen> #info LuisGomez recaps the performance/scale test report that was published and talked about at ONS
16:15:02 <jamoluhrsen> #info perf/scale numbers were all tested in at least 2 different labs
16:15:13 <jamoluhrsen> #info white paper was published.
16:15:17 <jamoluhrsen> does anyone have that link handy?
16:15:51 <jamoluhrsen> #link https://www.opendaylight.org/resources/odl-performance
16:16:17 <jamoluhrsen> #info tests not done in clustered environment, but it was asked for by others.
16:17:24 <jamoluhrsen> #info LuisGomez thinks just producing a white paper each release is best format
16:18:53 <jamoluhrsen> #info this kind of perf/scale work needs a little more time to produce a better report (maybe a month?)
16:19:39 <jamoluhrsen> #info high praise to everyone involved in that testing.  a great example of a broad community effort in a short time frame.
16:21:04 <jamoluhrsen> #info anipbu asks for a simple 1-page conclusion of white paper. (infographic)
16:21:53 <jamoluhrsen> #info this infographic would have been a cool thing to hand out at OpenDaylight booths at difference summits/conferences
16:23:28 <jamoluhrsen> #info gvrangan noticed that VTN jobs started failing because OVS/Mininet versions have changed on the backend
16:26:16 <jamoluhrsen> #info we have no answer as to why the versions changed, but gvrangan says he has a patch to deal with the change going forward
16:29:12 <jamoluhrsen> #info asks how Integration/Test wants to do committer status?
16:33:28 <jamoluhrsen> #action jamoluhrsen to get rid of committer names on main Integration page
16:35:03 <jamoluhrsen> #info jamoluhrsen complains that autorelease feels different than snapshot distributions.
16:36:23 <jamoluhrsen> #info LuisGomez notes that we might need a new strategy for what distributions we run all CSIT on.
16:39:03 <jamoluhrsen> #info autorelease (e.g., daily) does trigger distribution-test so we can at least start comparing vs snapshot (as far as CSIT goes)
16:41:03 <jamoluhrsen> #info vratko mentions that we should change our {periodic} jobs (aka daily) to run using autorelease distributions, instead of snapshot
16:41:31 <jamoluhrsen> #action jamoluhrsen to make a trello card for this idea (daily csit on autorel)
16:43:58 <jamoluhrsen> #info jamoluhrsen asks how we want to address features ending up as experimental at the end of the release?
16:44:13 <jamoluhrsen> #info start sending emails, start marking tests excluded now.
16:47:43 <jamoluhrsen> #info need to still run (maybe daily) the test cases that are marked "exclude"
16:49:37 <jamoluhrsen> #info need to make projects include their system tests in the distribution-test job
16:49:47 <jamoluhrsen> #action jamoluhrsen to add that to release plan (ASAP)
16:53:01 <jamoluhrsen> #info Int/Test does not need any other branches besides master
16:53:38 <jamoluhrsen> #info LuisGomez wants to organize an IRC meeting with all projects test contacts
16:53:44 <jamoluhrsen> #action LuisGomez to set that meeting up
16:56:26 <jamoluhrsen> #info jamoluhrsen got confused why non-master branches were there on github.  can be manually removed if needed (email helpdesk if it's important)
16:56:39 <jamoluhrsen> #action jamoluhrsen to send helpdesk
16:57:06 <jamoluhrsen> #info jamoluhrsen notes it's time to get rid of AD-SAL system tests
16:57:15 <jamoluhrsen> #action LuisGomez for the above
16:58:52 <jamoluhrsen> #info how do we want projects to figure out ports to use?
16:59:08 <jamoluhrsen> #info LuisGomez notes the port wiki is the one best place to enforce this.
17:00:58 <jamoluhrsen> #endmeeting