16:04:16 <jamoluhrsen> #startmeeting integration
16:04:16 <odl_meetbot> Meeting started Thu Mar 31 16:04:16 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:16 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:16 <odl_meetbot> The meeting name has been set to 'integration'
16:04:46 <jamoluhrsen> #topic distribution update
16:04:48 <dfarrell07> #info Vatko is now PTL of Int/Dist, congrats
16:05:03 <jamoluhrsen> #info rough draft created for Int/Dist release plan
16:06:08 <jamoluhrsen> #action jamoluhrsen to email Jaime about overrides.properties
16:06:18 <jamoluhrsen> #topic packaging
16:06:37 <jamoluhrsen> #info major refactor of vagrant basebox happening
16:07:00 <jamoluhrsen> #info new effort underway from DDF around creating tutorials and making things more "usable"
16:07:17 <jamoluhrsen> #info should have some help from LF interns, mentorship by dfarrell07
16:07:52 <jamoluhrsen> #info main idea is to improve vagrant base boxes, and then create tutorials around those (e.g. l2switch with mininet)
16:08:47 <jamoluhrsen> #topic builder
16:09:24 <jamoluhrsen> #info some outages happening, another one this saturday
16:09:37 <jamoluhrsen> #info gpg now available for us in gerrit
16:10:18 <jamoluhrsen> #info must use master key, subkeys don't work.
16:10:42 <jamoluhrsen> #info start using if your master key is also a signing key
16:10:51 <jamoluhrsen> #info need local git version of 2.6+
16:11:34 <jamoluhrsen> #info this is all done with a git config cmd (ask google how)
16:14:50 <jamoluhrsen> #topic misc
16:15:18 <jamoluhrsen> #info jamoluhrsen presented features as experimental when they dont meet system test expectations in monday's TWS
16:16:34 <jamoluhrsen> #info LuisGomez notes that there are other non system test release things can mark features experimental (e.g. documentation)
16:16:55 <jamoluhrsen> #info catohornet stepping down as committer in Boron
16:19:03 <jamoluhrsen> #info do we want to enable heapdumps by default in our release distribution, or only enable it when needed (like system test)
16:20:17 <jamoluhrsen> #action vratko to email release and discuss about heapdumps coming by default or not
16:21:27 <odp-gerritbot> A change was merged to integration/distribution: BUG 5070 move odl-vpnservice-core to incompatible  https://git.opendaylight.org/gerrit/36853
16:21:57 <jamoluhrsen> #info jamoluhrsen asks if we can analyze all the current ODL projects system tests and send a warning that they are not meeting system test expectations
16:24:02 <jamoluhrsen> #action jamoluhrsen to send email to Int/Test asking for volunteers to investigate each projects to see if their system test is ok or not
16:24:42 <jamoluhrsen> #info next week divvy out projects, the following week we'll have a full report
16:26:07 <jamoluhrsen> #info colindixon asked (via email) if we should put our packaging stuff on our release downloads page?
16:27:00 <jamoluhrsen> #info dfarrell07_sick notes two trains of thought.  1) we shouldn't post things there unless it's build in nexus.  2) we should put these things there anyway, because it really helps usability.
16:27:30 <jamoluhrsen> #action dfarrell07_sick to respond to colins email that we should start posting these things to downloads
16:27:58 <odp-gerritbot> A change was merged to integration/test: Modify CSIT test files and library file of VTN Manager.  https://git.opendaylight.org/gerrit/36041
16:28:28 <jamoluhrsen> #info jamoluhrsen does not think we should not put our deployment scripts there though as they are very specific to our infra needs and not made for usability
16:30:06 <jamoluhrsen> #topic YANG python bindings project
16:49:28 <jamoluhrsen> #info yang python binding project will push patches to Integration/Test, create wiki and make real examples in lisp
16:58:54 <jamoluhrsen> #info jamoluhrsen to continue working on port checker suite
17:00:01 <jamoluhrsen> #action vratko to give his comments about port variables (different order and need them for all branches) in gerrit itself
17:00:07 <jamoluhrsen> #endmeeting