16:01:28 <dfarrell07> #startmeeting integration
16:01:28 <odl_meetbot> Meeting started Thu Apr  7 16:01:28 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:28 <odl_meetbot> The meeting name has been set to 'integration'
16:02:31 <dfarrell07> #chair jamoluhrsen
16:02:31 <odl_meetbot> Current chairs: dfarrell07 jamoluhrsen
16:03:58 <tykeal> http://bluejeans.com/numbers
16:06:43 <jamoluhrsen> #topic packaging
16:07:28 <jamoluhrsen> #info lots of work getting vagrant things in line.  new patch to update all the docs
16:07:45 <jamoluhrsen> #info vagrant base boxes will be the basis for the tutorials work.
16:08:13 <jamoluhrsen> #info hoping this work will help with user facing tutorials, as opposed to dev focused things
16:09:01 <jamoluhrsen> #info python verify job now in place for Int/Pak
16:09:32 <jamoluhrsen> #info packing work (version bumping etc) really needs to get some automation around it.
16:10:47 <jamoluhrsen> dfarrell07, we could all hear you.
16:10:55 <jamoluhrsen> but, I don't think you can hear us.
16:11:04 <dfarrell07> jamoluhrsen: no, can't hear you
16:11:09 <dfarrell07> jamoluhrsen: humm
16:11:21 <jamoluhrsen> #action dfarrell07 will work with Phil to get whatever packing work we need on the downloads page
16:11:26 <jamoluhrsen> dfarrell07, dial back in
16:11:38 <jamoluhrsen> #topic distribution
16:12:05 <dfarrell07> jamoluhrsen: I'm back
16:12:43 <jamoluhrsen> #info LuisGomez creating bash script to disable persistence.  idea came out of performance testing work.
16:13:00 <jamoluhrsen> #info disabling persistence will increase performance with things like flow config
16:14:25 <jamoluhrsen> #info jamoluhrsen working on patch to configure custom sharding in cluster deployer .
16:14:32 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/37105/
16:14:56 <jamoluhrsen> #info all branches seem to be building properly
16:15:14 <jamoluhrsen> #topic builder
16:15:26 <jamoluhrsen> #info nexus problems are fully resolved now
16:15:42 <jamoluhrsen> #info sonar migration coming next, but not this weekend
16:19:23 <jamoluhrsen> #info CSIT jobs aborting
16:19:29 <jamoluhrsen> tykeal: http://jenkins.opendaylight.org/releng/view/CSIT-Jobs/job/bgpcep-csit-1node-userfeatures-only-beryllium/1239/console
16:20:46 <jamoluhrsen> #info jamoluhrsen thinks jobs are aborting too frequently right now, as compared to how it felt in the past
16:21:38 <jamoluhrsen> #info if slaves are not coming up because we've run out of ip addresses, that problem will go away when we move to the private cloud.
16:21:59 <LuisGomez> 1) RuntimeException on node DFW/353583c8-194a-4225-a5bb-6c64e32d952e:
16:21:59 <LuisGomez> java.lang.RuntimeException: org.jclouds.compute.callables.ScriptStillRunningException: time up waiting 300s for BlockUntilInitScriptStatusIsZeroThenReturnOutput{commandRunner=RunScriptOnNodeAsInitScriptUsingSshAndBlockUntilComplete{node=DFW/353583c8-194a-4225-a5bb-6c64e32d952e, name=bootstrap, runAsRoot=true}} to complete. call get() on this exception to get access to the task in progress
16:22:25 <jamoluhrsen> #info we don't know why jobs are aborting more so right now, but tykeal is informed now
16:23:19 <LuisGomez> #link https://jenkins.opendaylight.org/releng/view/CSIT-1node/job/openflowplugin-csit-1node-flow-services-lithium-redesign-only-beryllium/
16:23:33 <LuisGomez> you can see issues started at the beginning of the week
16:23:53 <jamoluhrsen> #info job abort problem might be happening in sandbox too.  reported by vrpolak
16:24:58 <jamoluhrsen> #topic release
16:25:14 <jamoluhrsen> #info onboarding reviews for projects happening currently
16:25:36 <jamoluhrsen> #link onboarding slide deck https://docs.google.com/presentation/d/1bHlGS4sTUcFKMj13vx_DdkD1SVDcFvo1URvHpVvSWQc/edit#slide=id.g11e66ce540_0_0
16:28:42 <anipbu> #link https://docs.google.com/spreadsheets/d/1d-Qay-9IAy5OIECPGHj-Xtw24ey6UEzIEk9RSJuD5uo/edit#gid=1240622178
16:28:57 <anipbu> ^^^ Link to list of all projects in Boron
16:32:50 <dfarrell07> anipbu: I think the old Integration project is archived, not inactive (line 84 of that link)
16:35:06 <anipbu> dfarrell07: integration project was never officially archived by TSC in a Termination Review as required by the lifecycle document (https://www.opendaylight.org/project-lifecycle-releases).  If I am wrong, please provide the TSC meeting minutes approving the Termination Review of Integration Project
16:35:38 <dfarrell07> anipbu: yeah, I thought we did a termination review but I'd have to dig for the minutes
16:36:44 <anipbu> #link https://www.opendaylight.org/project-lifecycle-releases
16:36:52 <jamoluhrsen> #info team will start looking at all project CSIT jobs in order to warn projects if they are going to have experimental features
16:37:11 <jamoluhrsen> #info anipbu notes that old integration project needs to have a termination review
16:38:10 <jamoluhrsen> #info dfarrell07 explains that you have a termination review to bring you to archive state
16:39:08 <gvrangan> #info pushed patch for devstack jobs https://git.opendaylight.org/gerrit/#/c/37280/
16:39:17 <gvrangan> #info currently in draft
16:39:38 <gvrangan> #info working on rediuucting time to deploy and ehtn enable the pybot command
16:39:48 <tykeal> anipbu: I'm not certain that integration actually needs a termination review. The agreement at the TSC when the project split was that the source project would enter archive state
16:39:57 <tykeal> since all the code evacuated
16:40:12 <odp-gerritbot> Jozef Behran proposed a change to integration/test: Add ability to use JAVA_HOME to find java  https://git.opendaylight.org/gerrit/37278
16:40:42 <anipbu> tykeal: I was not aware of that.  Thanks for pointing that out.
16:40:43 <odp-gerritbot> Jozef Behran proposed a change to integration/test: Replaced NetconfViaRestconf.robot with TemplatedRequests.robot  https://git.opendaylight.org/gerrit/37279
16:41:05 <tykeal> anipbu: I could be wrong, but that was my understanding
16:42:02 <dfarrell07> #link https://wiki.opendaylight.org/view/Archive_Proposals/Integration Wiki required for termination review to archived state
16:45:03 <jamoluhrsen> #info team walks through trello board
16:50:33 <jamoluhrsen> #action zxiiro to give Int/Test a demo of readthedocs
16:57:13 <dfarrell07> jamoluhrsen: did you say "the tsc feels like windows to me"?! BURN BURN BURN ;)
16:57:21 <zxiiro> dfarrell07: I added you as a collaborator on https://hub.docker.com/r/zxiiro/jjb-docker/ try seeing if you can update it.
16:57:29 <jamoluhrsen> dfarrell07, don't put a #info in front of that
16:57:36 <dfarrell07> jamoluhrsen: ;)
16:57:43 <dfarrell07> zxiiro: cool, looking now
16:58:19 <zxiiro> dfarrell07: the dockerfile for that is here https://github.com/zxiiro/jjb-docker
16:58:28 <zxiiro> dfarrell07: i haven't updated it in a long time so probably a good time to update it anyway :)
16:59:58 <jamoluhrsen> #endmeeting