16:03:03 <jamoluhrsen> #startmeeting integration
16:03:03 <odl_meetbot> Meeting started Thu Apr 21 16:03:03 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:03 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:03 <odl_meetbot> The meeting name has been set to 'integration'
16:04:07 <jamoluhrsen> #action LuisGomez jamoluhrsen to see why distribution-check is taking longer now, than it used to
16:08:39 <jamoluhrsen> #topic distribution
16:09:17 <jamoluhrsen> #info stable/lithium distribution deploy was failing because of port conflicts (e.g. port 8282 with iotdm and controller)
16:09:34 <jamoluhrsen> #info iotdm feature was disabled in stable/lithium
16:10:49 <jamoluhrsen> #info these port conflicts are probably still there in other branches, but the bindexpections are just not noticed in distribution-check.
16:12:25 <jamoluhrsen> #info port automation checker aprox 50% complete: https://git.opendaylight.org/gerrit/#/c/36795/
16:13:17 <odp-gerritbot> Jozef Behran proposed a change to integration/test: Add support for netconf entities  https://git.opendaylight.org/gerrit/37982
16:15:58 <anipbu> #link https://wiki.opendaylight.org/view/Weather#Nexus_URL_requires_HTTPS   <--- Weather item for Nexus URL
16:16:01 <jamoluhrsen> #info weather report was created around nexus and projects using https
16:16:06 <jamoluhrsen> ty anipbu
16:17:04 <jamoluhrsen> #info seems most projects could be affected by this weather item.
16:17:26 <jamoluhrsen> #info anipbu wonders if we should bring this action to projects via some milestone
16:18:29 <jamoluhrsen> #info projects are going to start getting more affected as artifacts age out after 3 weeks.
16:19:49 <jamoluhrsen> #info projects need to be checking and fixing their merge jobs.
16:22:07 <jamoluhrsen> #action zxiiro LuisGomez to send a mail to projects about checking/fixing their merge jobs
16:22:54 <jamoluhrsen> #info two new scripts merged in distribution.  persistence and cluster config
16:26:01 <jamoluhrsen> #info location of new distribution scripts: https://github.com/opendaylight/integration-distribution/blob/master/distribution-karaf/src/main/assembly/bin/
16:26:52 <jamoluhrsen> #info vratko points out that some projects have ports that can be used that are not on by default.
16:27:12 <jamoluhrsen> #topic packaging
16:27:40 <jamoluhrsen> #info opnfv is extremely active in consuming our rpms based on our daily autorelease (good news)
16:27:52 <jamoluhrsen> #info opnfv is reporting bugs/issues back to us.
16:28:43 <jamoluhrsen> #info our method of creating releases are not up to standards that some packaging requirements have
16:29:17 <jamoluhrsen> #info intern interviews recently and 3 will be hired to help get our user-focused tutorials up and running
16:30:19 <jamoluhrsen> #info dfarrell07 working to get a new tutorials project (i.e., a new repo) for this user-tutorials work.
16:30:54 <jamoluhrsen> #info CaseyODL notes that coretutorials is not against us renaming it to something more relevant (e.g. user_tutorials, etc)
16:31:14 <jamoluhrsen> #info still discussion for project specific tutorials to still live in those project repos
16:31:37 <jamoluhrsen> #topic builder
16:32:04 <jamoluhrsen> #info workflow created recently for projects that are not part of the autorelease build.
16:36:25 <jamoluhrsen> #info projects no longer have push permission to push to opendaylight repo.
16:36:33 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/release/2016-April/006268.html
16:37:04 <jamoluhrsen> #topic release
16:37:30 <jamoluhrsen> #info beryllium SR2 cut-off is this sunday.  SR2 coming in one week.
16:38:06 <jamoluhrsen> #info there is a request to have more frequent releases
16:38:51 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/release/2016-April/006282.html
16:40:18 <jamoluhrsen> #info just taking our daily autorelease is the first step, but those builds are not getting the full release style vetting (checking system tests, etc)
16:41:00 <jamoluhrsen> #info zxiiro points out that version bumping will be very cumbersome if more frequent releases are required.  it will only get worse as more projects come online
16:42:26 <jamoluhrsen> #info vratko points out that branches are frozen during the version bumping so if this happens more frequently, there will be more windows where branches are locked
16:44:14 <jamoluhrsen> #info int/packaging could potentially create their own releases which takes the burden off of releng
16:45:25 <jamoluhrsen> #info could we potentially get to the point where we are making sure daily autorelease distributions are up to standard as far as CSIT
16:45:53 <jamoluhrsen> #info one driving force for these faster releases is that downstream is finding bugs in ODL and wants them fixed.
16:46:55 <jamoluhrsen> #topic misc
16:47:26 <zxiiro> maybe we can write a bot that monitors a Gerrit topic for patches
16:47:51 <zxiiro> and continuously reruns recheck and merge patches
16:49:52 <jamoluhrsen> #info question around what jobs should be in distribution tests
16:50:23 <odp-gerritbot> Jozef Behran proposed a change to integration/test: Add support for netconf entities  https://git.opendaylight.org/gerrit/37982
16:50:24 <odp-gerritbot> Jozef Behran proposed a change to integration/test: Tell GetControllerSyncStatus to not spit out warnings  https://git.opendaylight.org/gerrit/37985
16:51:16 <jamoluhrsen> #info dfarrell07 thinks we dont want to include perf/stress/scale in distribution-test.  more just all fundamental system test
16:51:52 <jamoluhrsen> #info LuisGomez thinks we can probably just get by with the -only- jobs in distribution-test, but jamoluhrsen thinks we still need -all- test
16:52:13 <jamoluhrsen> #info vratko thinks we can have two versions of distribution-test.  one with just -only- and fundamental system tests
16:52:44 <jamoluhrsen> #info the other distrubtion test job could be run on a slower cadence with -all- and maybe some perf/stress/scale
16:55:44 <jamoluhrsen> #info vratko has an idea where each CSIT job definition can have a flag that tells us when/where to run those jobs.
16:56:48 <jamoluhrsen> #info main point is that we need some tooling that will help us automatically generate these bigger jobs that trigger all the system test, instead of asking projects to manually add their -csit- job to the distribution-test definition
16:57:58 <jamoluhrsen> #info CaseyODL asks that we starting taking more looks at ask.opendaylight.org to help answer questions.
17:00:51 <jamoluhrsen> #endmeeting