16:00:56 <dfarrell07> #startmeeting integration
16:00:56 <odl_meetbot> Meeting started Thu Apr 28 16:00:56 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:00:56 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:00:56 <odl_meetbot> The meeting name has been set to 'integration'
16:01:11 <dfarrell07> #chair jamoluhrsen LuisGomez anipbu zxiiro
16:01:11 <odl_meetbot> Current chairs: LuisGomez anipbu dfarrell07 jamoluhrsen zxiiro
16:02:23 <anipbu> Having trouble with webex at the moment...
16:02:54 <jamoluhrsen> #topic distribution
16:03:21 <jamoluhrsen> #info stable/lithium has features removed because there is port conflict
16:03:23 <tykeal> caught LuisGomez while he's eating breakfast ;)
16:03:48 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/37729
16:04:26 <jamoluhrsen> #info there is a very likely chance that we will not have a stable distribution.  there is probably no feature even close to being "stable"
16:05:07 <jamoluhrsen> #info it seems too hard for features to be stable.  tykeal notes that core projects need to get this ball rolling
16:05:57 <jamoluhrsen> #info vratko thinks the best option is a southbound only feature first.  they would depend only on yangtools and yangtools gets system test waiver.
16:06:50 <jamoluhrsen> #info actually, odlparent needs to be mature, then stable, before yangtools or mdsal or controller or mdsal...  on and on.
16:07:42 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Boron_Release_Plan#Stable_and_Extended_Features
16:09:02 <jamoluhrsen> #action vratko to send email to release notifying that we will not have stable distribution in Boron
16:09:42 <jamoluhrsen> #topic builder
16:10:26 <jamoluhrsen> #info archive.apache.org was starting to limit our downloads (5G daily max)
16:11:01 <jamoluhrsen> #info projects can try to use mirrors, but they only use latest version of packages.  so if our scripts need very specific versions the mirrors wont work.
16:11:41 <jamoluhrsen> #info the next option is to put those specific versions on ODL's nexus and then download from there.
16:12:15 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/tsdr-dev/2016-April/000780.html
16:15:58 <jamoluhrsen> #info LuisGomez points out that ideally these pieces of software are baked in to the VM to start with.
16:18:07 <jamoluhrsen> #info migration to private cloud still in the works.  sandbox system getting stood up now.
16:19:14 <jamoluhrsen> #info hoping to have sandbox migrated in 2 weekends from now and we'll cut over after that.
16:20:30 <jamoluhrsen> #info jamoluhrsen notes that VTN was having problem with "yum install" in sandbox but not releng.  this should not be a problem once everything is migrated to same private cloud
16:21:23 <jamoluhrsen> #topic packaging
16:21:54 <jamoluhrsen> #info plaurin adding fedora pipeline to packaging
16:23:03 <jamoluhrsen> #link https://hub.docker.com/r/opendaylight/odl/tags/
16:24:46 <dfarrell07> #link https://git.opendaylight.org/gerrit/38120 plaurin's patch to add Fedora 23 Vagrant base boxes (libvirt, vbox) and Docker images (all for 3.3, 4.0 and 4.1)
16:24:51 <jamoluhrsen> #topic release
16:24:53 <anipbu> https://wiki.opendaylight.org/view/Simultaneous_Release/Beryllium/SR2/Status
16:25:10 <jamoluhrsen> #info beryllium SR2 not coming out this week.  ovsdb has blocking issues
16:25:10 <plaurin> dfarrell07: typo -> 3.4 4.0 and 4.1
16:25:22 <plaurin> :)
16:25:34 <dfarrell07> plaurin: ack, thanks
16:25:52 <jamoluhrsen> #info bug to track https://bugs.opendaylight.org/show_bug.cgi?id=5809
16:26:02 <dfarrell07> #info dfarrell07 meant 3.4 (Li SR4), not SR3 in Packer ODL versions above
16:28:06 <jamoluhrsen> #info first blocker issue is that functionality is broken (can't update ovs port ip)
16:28:33 <jamoluhrsen> #info second issue is that ovsdb features are not coming up fast enough, so br-int is not created when system test is run.  if you wait longer, things will work.
16:29:06 <jamoluhrsen> #action jamoluhrsen will binary search distros to find when feature loading started taking longer
16:32:22 <jamoluhrsen> #info probably no real movement on ovsdb fix until monday since all devs are at openstack summit
16:33:04 <jamoluhrsen> #topic cluster keyword consolidation
16:34:20 <jamoluhrsen> #info we have multiple clustering libraries in robot.  we should try to consolidate.
16:36:10 <jamoluhrsen> #info goals for consolidation: 1) single clear library.  2) remove duplicate work.  3)  similar keywords can call each other (keyword doing more calls keyword doing less)
16:37:05 <jamoluhrsen> #info keywords are grouped such that some use an index in to a list of controller ips vs keywords that require a specific ip
16:37:21 <jamoluhrsen> #info all REST action keywords require index.
16:38:22 <jamoluhrsen> LuisGomez misses CASPER
16:39:38 <jamoluhrsen> #action LuisGomez to send cluster keyword consolidation questions to integration-dev list to get answers from team.
16:48:36 <jamoluhrsen> #info vratko points out that keeping ssh sessions open for reuse during entire suite has troubles (bugs in sshlibrary).  suggests that, even though slower, it probably is better to open and close ssh session for each action.
16:49:35 <jamoluhrsen> #info we can have ssh keywords that allow us to have both options.  1) to reuse already open session and 2) create and close a new one
17:01:36 <jamoluhrsen> #info no objections to granting system test waiver to neutron project
17:02:02 <jamoluhrsen> #info congrats to gvrangan on getting unanimous approval on promotion to committer
17:02:16 <jamoluhrsen> #action jamoluhrsen to email tsc to vote on gvrangan's promotion.
17:02:21 <jamoluhrsen> #endmeeting