16:01:34 <jamoluhrsen> #startmeeting integration
16:01:34 <odl_meetbot> Meeting started Thu May 12 16:01:34 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:34 <odl_meetbot> The meeting name has been set to 'integration'
16:02:02 <zxiiro> vorburger: I don't know, Unfortunately I think the only way to find out is to check as each project is different with how they handle checkstyle and don't always pull the recommended settings from odlparent
16:04:26 <jamoluhrsen> #info SR2 is released
16:04:48 <jamoluhrsen> #info SR2 rpms built and handed over to OPNFV.
16:05:18 <vorburger> zxiiro: OK.. FYI this checkstyle upgrade with my 3 open Gerrits is more of a mess than I thought, but now I finally fully understood why. We made a mistake and have an unholy mix of maven-checkstyle-plugin VS com.puppycrawl.tools:checkstyle (the core library), which I'm clearly separating now.  I think I'll send an email to odlparent-dev to spell this out a bit more clearly, for future reference.
16:05:27 <jamoluhrsen> #info build setup is fairly automated, but we can be better.  probably some better tools can be used.
16:05:59 <zxiiro> arch packages are pretty simple to create :)
16:06:29 <jamoluhrsen> #info version bump is still going on, should be done today.
16:06:30 <dfarrell07> zxiiro: we should get those in int/pack at some point
16:06:55 <jamoluhrsen> #info stable/beryllium branch still locked until version bump is done.  zxiiro sends emails when that is done;
16:07:53 <jamoluhrsen> #info jamoluhrsen points out that didm is still not part of Boron autorelease, but the ball is in their court to get it back in.  risk is they will not be part of the released distro.
16:09:05 <jamoluhrsen> #link https://bugs.opendaylight.org/show_bug.cgi?id=5821 jamoluhrsen asks about bug where autorelease distro is having troubles vs normal snapshot distro
16:09:44 <jamoluhrsen> #info one idea is to have autorelease build all the projects except int/dist
16:11:28 <vorburger> skitt: do you have a minute re. https://git.opendaylight.org/gerrit/#/c/37801/ & https://git.opendaylight.org/gerrit/#/c/37796/ & https://git.opendaylight.org/gerrit/#/c/38211/ ? I need to re-re-intro the version property you initially didn't like, and want to explain why.. or see if you have a better idea how to avoid it?
16:14:21 <skitt> vorburger, I'm knee-deep in Karaf entrails just now — ping me about it tomorrow morning after 10am (I have a Red Hat France meeting before then)
16:14:42 <jamoluhrsen> #action jamoluhrsen to update bug/trello with a task to analyze the files/folders between the different distribution
16:14:54 <jamoluhrsen> #topic distribution
16:15:28 <vorburger> skitt: OK sure NP. Just don't be surprised if I (have to) intro. another property in odl-parent.. I know you're not a fan at all, but due to https://issues.apache.org/jira/browse/MNG-2496, in this specific case I think it's unavoidable
16:15:43 <jamoluhrsen> #info port conflict is still there for every release.
16:15:52 <skitt> vorburger, OK
16:16:16 <jamoluhrsen> #info we don't want to see this port conflict test failure every time we release.
16:17:02 <jamoluhrsen> #info we will start pulling projects from distribution that have these port conflicts
16:18:53 <jamoluhrsen> #topic packaging
16:20:12 <jamoluhrsen> #info opnfv plugfest going well and packaging conversations happening and hoping to move opnfv installers toward more upstream packaging tools
16:22:28 <jamoluhrsen> #info brady from opnfv still looking for better/quicker/stable releases.
16:22:36 <tykeal> 2 months
16:22:44 <jamoluhrsen> #info dfarrell07 asks if we can keep our autorelease artifacts around longer.
16:23:06 <jamoluhrsen> #info autorelease can only be kept for aprox 60days, and we can't really keep more than that.
16:25:25 <jamoluhrsen> #info jamoluhrsen wants to create another distribution-test job that only contains 100% passing CSIT jobs
16:27:12 <jamoluhrsen> #info idea might just be to remove unstable tests from current distribution-test
16:29:03 <jamoluhrsen> #action jamoluhrsen to send email that CSIT jobs will be removed from distribution-test unless they meet test case expectations
16:29:16 <jamoluhrsen> #topic builder
16:29:49 <jamoluhrsen> #info jenkins webui was slow several times in the past week or so.
16:30:18 <jamoluhrsen> #info zxiiro kicked jenkins and now it seems better.
16:30:43 <jamoluhrsen> #info there are latency tests on the webui and releng folks do get alerts so they can know good times to restart
16:31:38 <jamoluhrsen> #info jamoluhrsen still needs to test that we don't need fedora21 in sandbox.
16:31:58 <jamoluhrsen> #info still blocked by rackspace on private cloud migration.
16:32:14 <jamoluhrsen> #info migration in two weekends maybe
16:32:42 <jamoluhrsen> #info vratko asks why the merge job keeps failing?
16:33:14 <jamoluhrsen> #info zxiiro points out that when jenkins is slow, the merge job will fail.  we need to move things off of jenkins (like archive artifacts)
16:35:10 <jamoluhrsen> #info no solution for moving artifacts to nexus yet, but zxiiro has a plugin that may help.
16:35:50 <zxiiro> #link https://lists.opendaylight.org/pipermail/spectrometer-dev/2016-May/000137.html Spectrometer Report Tool
16:37:16 <jamoluhrsen> #topic spectrometer
16:37:36 <jamoluhrsen> #info spectrometer now pulling useful stats.
16:37:41 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/spectrometer-dev/2016-May/000137.html Spectrometer Report Tool
16:38:10 <jamoluhrsen> #info some projects were not tagged correctly so stats were not accurate in initial report.
16:39:07 <jamoluhrsen> #topic system test waivers
16:39:31 <jamoluhrsen> #info jamoluhrsen asks if we can give documentation system test waiver
16:39:41 <jamoluhrsen> #agreed
16:39:43 <jamoluhrsen> #agree
16:39:55 <tykeal> you need to give a statement after that #agreed
16:40:10 <dfarrell07> #agreed Docs has a system test waver
16:40:11 <jamoluhrsen> #agreed documentation granted system test waiver
16:41:02 <jamoluhrsen> #topic vpn service system test patch
16:41:51 <jamoluhrsen> #info new patch is now using robot requests library
16:56:46 <jamoluhrsen> dfarrell07, what is the last msg you saw me write here?
16:57:02 <dfarrell07> jamoluhrsen: " #info new patch is now using robot requests library"
16:57:22 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/38662/ vpn service patch needs review
16:57:29 <jamoluhrsen> #info vpn service also is in need of a CSIT topology where there is a gateway router
16:57:34 <jamoluhrsen> #info mahendar will send out an email with a diagram of this topology so we can figure out how to accommodate
16:57:40 <jamoluhrsen> #topic performance update
16:57:44 <jamoluhrsen> #info there is a 2nd version of the performance document that we presented at ONF 2016
16:57:49 <jamoluhrsen> #info ONOS has since given a new version of their controller and asked ODL to re-test with that new version
16:57:58 <jamoluhrsen> #info there is a better script to run northbound flow config
16:58:03 <jamoluhrsen> #info only the openflow tests are redone.
16:58:08 <jamoluhrsen> #info results are similar, but ONOS is still a little bit better.
16:58:14 <jamoluhrsen> #info the new paper will give a better explanation on why we are doing tests the way we are (e.g. using REST to program flows vs using java api to push flows)
16:58:57 <jamoluhrsen> #endmeeting