16:04:36 <jamoluhrsen> #startmeeting integration
16:04:36 <odl_meetbot> Meeting started Thu May 26 16:04:36 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:04:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:04:36 <odl_meetbot> The meeting name has been set to 'integration'
16:05:15 <jamoluhrsen> #topic distribution
16:05:39 <dfarrell07> jamoluhrsen: I'm in
16:05:53 <jamoluhrsen> #info fix for failures in test suites for netconf suites that required changes in karaf
16:06:50 <jamoluhrsen> #info now while we compile distribution, we are having to edit some things in a jar file
16:07:11 <jamoluhrsen> #info migration of distribution towards using karaf parent
16:07:42 <jamoluhrsen> #info people are asking that ODL version is available outside of restconf
16:08:28 <jamoluhrsen> #info a new config file will be present in order to expose this ${version}
16:08:58 <jamoluhrsen> #info didm was removed from distribution
16:09:29 <jamoluhrsen> #topic packaging
16:09:45 <jamoluhrsen> #info dfarrell07 in spain :)
16:09:59 <jamoluhrsen> #info new rpms created with fixes for opnfv
16:10:10 <jamoluhrsen> #info bug fixes in ansible role made it this week
16:10:37 <jamoluhrsen> #info ODL interns starting monday, but packaging intern already working on .deb
16:11:17 <jamoluhrsen> #info tutorial group looking at l2switch as the first tutorial worked on by LF interns
16:14:54 <jamoluhrsen> #topic release
16:15:21 <jamoluhrsen> #info atrium & snmp4sdn asking for system test waivers
16:16:16 <dfarrell07> jamoluhrsen: can you turn off your screen share if you get a chance/not using it? eating my data and I don't think there's a way to turn it off from mobile app
16:16:43 <dfarrell07> jamoluhrsen: thanks :)
16:16:57 <jamoluhrsen> #info boron will see a restconf migration and CSIT jobs are going to be affected.
16:16:57 <jamoluhrsen> #info restconf deprecation will happen at the *end* of boron.
16:18:38 <jamoluhrsen> #info vratko suggests that in Carbon we a library that can detect the ODL_STREAM and then contstruct the proper URL
16:20:46 <jamoluhrsen> #info next Wed (6/1) @ 10am PST, we'll have a meeting for projects that have questions around M3 (e.g. how to add karaf features? how to create initial system test job? how to upload ascii outlines for docs?)
16:22:07 <jamoluhrsen> #topic builder stuff
16:22:38 <jamoluhrsen> #info sandbox is broken, and we don't know what's up.  something broken in last day or two
16:23:17 <jamoluhrsen> #info sandbox issue open with rackspace, but no ETA yet
16:24:17 <jamoluhrsen> #info releng migration can't happen until we know issues like we have in sandbox are not happening
16:25:31 <jamoluhrsen> #info zxiiro's builder patches still need to be rebased when pushing jobs to sandbox until releng migration happens and then those patches can be merged
16:26:42 <jamoluhrsen> #topic misc
16:27:28 <jamoluhrsen> #info sshpass issue after karaf upgrade still an issue.
16:28:06 <jamoluhrsen> #info LuisGomez points out sshpass issue is environment related (e.g. OS, jdk, etc)
16:30:09 <vrpolak> https://bugs.opendaylight.org/show_bug.cgi?id=5923
16:30:55 <jamoluhrsen> #link https://bugs.opendaylight.org/show_bug.cgi?id=5923 bug to track sshpass/karaf issue.
16:31:08 <jamoluhrsen> #info jamoluhrsen thinks this needs to be fixed before we release Boron
16:31:55 <jamoluhrsen> #info we have a plan to start publishing artifacts to nexus.
16:32:37 <jamoluhrsen> #info pushing to nexus still needs the work to happen, but should be feasible.
16:33:46 <jamoluhrsen> #info vratko has a new suite that is around controller upgrade
16:34:21 <jamoluhrsen> #info upgrade suite, copies data (snapshot and journal) from older version of controller and starts newer version and validates that the data is seen there.
16:38:26 <jamoluhrsen> #topic system test waivers
16:39:22 <jamoluhrsen> #info SNMP4SDN granted system test waiver, but the request is there that we get external system test results in a periodic manner if possible
16:40:39 <jamoluhrsen> #info anipbu points out that we are expecting these external results to be reported in the system test report
16:41:20 <jamoluhrsen> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group/Project_System_Test_Report  system test report info
16:42:18 <dfarrell07> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template system test feature report template
16:42:20 <dfarrell07> jamoluhrsen:^^
16:42:28 <jamoluhrsen> ah!  thanks.
16:42:46 <jamoluhrsen> #action jamoluhrsen to put link to system test template at top of reports landing page
16:43:14 <jamoluhrsen> #action jamoluhrsen too add section to system test template for projects to report their external results
16:45:17 <jamoluhrsen> #info ATRIUM project is from ONF and uses multiple switch vendors for the data plane and that is not possible in our CI environment
16:45:44 <jamoluhrsen> #info ATRIUM granted system test waiver
16:46:43 <jamoluhrsen> #info suggested that ATRIUM could possibly trigger their system test on gerrit patches, but that would be a long term goal.  In the short term we'll get test result dumps
16:46:58 <jamoluhrsen> #action jamoluhrsen to inform projects about waivers
16:47:36 <jamoluhrsen> #topic open items
16:48:03 <jamoluhrsen> #info jamoluhrsen pushed patches to remove unstable CSIT jobs from distribution-test
16:51:13 <dfarrell07> jamoluhrsen: where's this patch?
16:51:53 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/39451 patch to remove unstable tests from beryllium distribution-test job
16:52:12 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/39453/ patch to remove unstable tests from boron distribution-test job
16:52:44 <jamoluhrsen> #action jamoluhrsen to get patches merged and email relevant projects and release list about what's happening
16:55:28 <jamoluhrsen> #info robot framework install on robot VM is being removed from jenkins scripts, because it's being done in venv now
16:55:55 <vrpolak> https://git.opendaylight.org/gerrit/39341
16:56:29 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/39341 patch to remove robot install
16:57:02 <jamoluhrsen> #endmeeting integration