16:02:31 <jamoluhrsen> #startmeeting integration
16:02:31 <odl_meetbot> Meeting started Thu Jun  2 16:02:31 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:31 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:31 <odl_meetbot> The meeting name has been set to 'integration'
16:05:27 <jamoluhrsen> #topic packaging
16:05:55 <jamoluhrsen> #info Be SR2 docker/vagrant stuff finally built and available
16:06:10 <jamoluhrsen> #info ODL puppet module maintenance happening
16:07:09 <jamoluhrsen> #info skitt helping clarify specifics around creating .deb packaging
16:07:45 <dfarrell07> dropped
16:07:47 <jamoluhrsen> dfarrell07, you just got dialed out
16:07:50 <dfarrell07> idk
16:07:55 <dfarrell07> I was almost done
16:07:56 <dfarrell07> lol
16:08:05 <jamoluhrsen> #topic distribution
16:08:07 <dfarrell07> reminder about hackfest in June, that's it
16:08:37 <dfarrell07> jamoluhrsen: webex call-in is dropping me as soon as I connect :|
16:08:39 <jamoluhrsen> #info controller merge job blocking issue is fixed.
16:09:37 <jamoluhrsen> #info for M3 we want to merge the new config feature, but we need change in controller for it to work.
16:10:32 <jamoluhrsen> #info this new config feature is the enhancement to allow us to externally check the versoin of ODL
16:11:35 <jamoluhrsen> #action vratko to remind controller about their change to be merged
16:12:48 <jamoluhrsen> #info sandbox not able to build distribution at this point
16:13:53 <jamoluhrsen> #topic builder
16:14:15 <dfarrell07> jamoluhrsen: got call-in working
16:14:22 <jamoluhrsen> #info sandbox workaround in place to allow us to push jobs to sandbox... which works.
16:14:49 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-June/006945.html small issues pointed out by vratko
16:15:33 <jamoluhrsen> #info sandbox private cloud cannot access resources in releng public cloud
16:16:16 <jamoluhrsen> #info migration for releng cloud to private cloud planned for 3 weeks from now (tentatively)
16:16:48 <vrpolak> Example of settings file missing on Sandbox: https://jenkins.opendaylight.org/sandbox/job/integration-distribution-merge-boron/3/console
16:18:54 <jamoluhrsen> #info seems that there are some differences/problems in sandbox that we do/don't see in releng.  And it seems that maybe new problems are now happening that were ok before the recent breakage on Rackspace side.
16:20:03 <jamoluhrsen> #action jamoluhrsen to send email release list to request projects to test their CSIT jobs in the new sandbox (aka private cloud) before we get to the releng migration
16:20:34 <jamoluhrsen> #info differences in sandbox 1) newer version of jenkins 2) plugins updated 3) all slave images are now updated
16:20:55 <jamoluhrsen> #info another difference, moved to jclouds plugin from openstack plugin
16:21:20 <jamoluhrsen> #info secondary changes are jjb related (e.g. naming)
16:23:52 <jamoluhrsen> #info LuisGomez asks if we can upgrade the openjdk version in releng now, or do we have to wait for migration to private cloud?
16:25:12 <jamoluhrsen> #info need openjdk upgraded in order to verify the sshpass, /bin/client breakage is fixed with newer version
16:25:50 <jamoluhrsen> #info we can validate this sshpass, /bin/client issue is fixed in the sandbox
16:29:07 <jamoluhrsen> #topic release
16:29:47 <jamoluhrsen> #info M3 working session via IRC happened with some success helping new projects
16:30:05 <jamoluhrsen> #info autorelease has not been successful for a *very* long time.
16:30:38 <jamoluhrsen> #info anipbu suggests we need to start removing projects from Boron autorelease.  We've hit M4 already.
16:31:17 <jamoluhrsen> #info M3 milestone is today, so we should get a better idea of features that will end up in distribution.
16:31:57 <jamoluhrsen> #action anipbu will start checking autorelease daily and we may start removing projects on a daily basis
16:33:20 <jamoluhrsen> #topic misc
16:33:53 <jamoluhrsen> #info hackfest is coming up (6/29-6/30)
16:34:09 <jamoluhrsen> #link https://www.opendaylight.org/events/2016-06-29-000000-2016-06-30-000000/opendaylight-june-hackfest-2016 hackfest registration
16:34:37 <jamoluhrsen> #action LuisGomez to send email to integration-dev to get a list of topics/agenda for hackfest
16:36:13 <jamoluhrsen> #info cluster/perf friday meeting was ok via bluejeans (8:30am PST every friday)
16:36:44 <jamoluhrsen> #info we will also discuss this bulkomatic feature on the friday call.
16:37:16 <jamoluhrsen> #info demo next week from intern doing Longevity test work.
16:40:24 <jamoluhrsen> #action LuisGomez  to put aaa CSIT back in distribution-test after double checking that it's truly stable
16:41:40 <jamoluhrsen> #action gvrangan  VTN coordinator job failing in releng (oddly, not in sandbox) so we need to remove it from distribution-test
16:44:07 <jamoluhrsen> #info vratko suggests we could create another verify job that only builds offset 0 projects
16:45:17 <jamoluhrsen> #action vratko can give it a try, but can't test in current sandbox state
16:47:43 <jamoluhrsen> #action LuisGomez to check/merge version patch https://git.opendaylight.org/gerrit/#/c/37210/
16:48:31 <odp-gerritbot> A change was merged to integration/distribution: Bug 4296: Add config subsystem file with versions  https://git.opendaylight.org/gerrit/37210
16:55:35 <jamoluhrsen> #action vratko to check if the heapdump patch is merged in all the right branches
16:57:44 <jamoluhrsen> #endmeeting