16:03:02 <dfarrell07> #startmeeting integration
16:03:02 <odl_meetbot> Meeting started Thu Jun  9 16:03:02 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:02 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:02 <odl_meetbot> The meeting name has been set to 'integration'
16:03:18 <edwarnicke> adetalhouet: I suspect customers find it familiar
16:03:24 <edwarnicke> And their familiarity can be a good reason
16:03:34 <edwarnicke> But my guess is that familiarity is their underlying reason
16:03:36 <dfarrell07> adetalhouet: good to know, glad I didn't make some off-the-wall call about /opt ;)
16:03:55 <dfarrell07> #chair jamoluhrsen LuisGomez
16:03:55 <odl_meetbot> Current chairs: LuisGomez dfarrell07 jamoluhrsen
16:04:54 <jamoluhrsen> #topic distribution
16:05:14 <tykeal> using /opt is defined as a location for "vendor" distribution. Things in packages shoud, however, be scattered around the filesystem if being packaged and can properly be spread around...
16:05:36 <jamoluhrsen> #info version support job is there, but the actual string is not ready pending merge in controller project
16:05:50 <jamoluhrsen> #info migrating dist-karaf under karaf-parent
16:06:27 <jamoluhrsen> #info system test template has been filled for distribution project
16:06:59 <jamoluhrsen> #info documentation coming next. (e.g. those config scripts, etc)
16:07:17 <jamoluhrsen> zxiiro: ball please
16:08:45 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/Distribution-Jobs/job/distribution-csit-1node-userfeatures-all-boron/  <-- job for controller version check
16:09:27 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Weather#Karaf-parent_upgraded_to_use_karaf-plugin <-- weather report for karaf-parent migratoin
16:10:45 <jamoluhrsen> #info LuisGomez notes that this release our distribution jobs are not breaking as frequently
16:10:54 <jamoluhrsen> #topic packaging
16:11:46 <jamoluhrsen> #info we deleted all of our code in the old Integration git repo.  This helped immediately because OPNFV was still consuming it.  They have been fixed :)
16:12:13 <jamoluhrsen> #info boron autorelease completed twice recently, so now we have a boron rpm to consume
16:13:50 <jamoluhrsen> #topic release
16:14:43 <anipbu> https://wiki.opendaylight.org/view/CrossProject:NetVirt_VPNService_Migration
16:14:57 <jamoluhrsen> #link https://wiki.opendaylight.org/view/CrossProject:NetVirt_VPNService_Migration <-- netvirt vpnservice migration weather item
16:15:58 <jamoluhrsen> #topic builder
16:16:13 * dfarrell07 can't find the host key
16:17:44 <jamoluhrsen> #info jamoluhrsen points out that new sandbox is giving different results than what we see in the current releng silo
16:20:39 <jamoluhrsen> #action jamoluhrsen to send email with list of sandbox issues.
16:23:09 <jamoluhrsen> #info migration for releng silo to new private cloud is scheduled for June 25th.
16:24:04 <jamoluhrsen> #info thanhs review patch now uses the new openstack plugin, not jclouds plugin
16:24:08 <tykeal> 1.5 years now
16:25:12 <jamoluhrsen> #info all the VMs are now 4G instead of 8G and all periodic jobs passed with this smaller setup
16:26:22 <jamoluhrsen> #info autorelease job now will now be doing "release candidate" builds.  instead of "daily".
16:27:32 <jamoluhrsen> #info JJB 1.6.1 released this morning.  fixes issue on windows.
16:28:40 <jamoluhrsen> #info VM lifecycle question -->  the VMs are destroyed if idle after only 1m
16:29:00 <dfarrell07> zxiiro: so making sure I understand, latest builds from master branch will not include things like Lithium-SR3, just SNAPSHOT? Releases will look the same (but tagging a bit easier)? And autorelease jobs will not have dates?
16:29:20 <dfarrell07> zxiiro: the dates thing may be a problem, how would the versions of snapshots be determined?
16:29:50 <zxiiro> dfarrell07: you can date it on your end, but the staging repos will now always produce for example Beryllium-SR3
16:31:27 <zxiiro> dfarrell07: https://lists.opendaylight.org/pipermail/release/attachments/20160609/59c3290a/attachment-0001.png
16:32:32 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/release/attachments/20160609/59c3290a/attachment-0001.png <-- new autorelease branch visual
16:35:54 <dfarrell07> jamoluhrsen: can you put that lnk here?
16:36:14 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-boron/lastSuccessfulBuild/artifact/deploy-staged-repository.log  <-- how to find staging repository
16:36:50 <jamoluhrsen> #info dfarrell07 points out that we aren't sure if this helps external projects grab daily distros that we know are stable (based on CSIT results)
16:55:10 <jamoluhrsen> #topic demos
16:55:38 <jamoluhrsen> #info Kumar gave demo of longevity testing work where we can collect JVM metrics and create plots
16:57:01 <jamoluhrsen> #info Rohit demos dashboard project.
16:57:21 <jamoluhrsen> #link http://52.88.253.242:8080/main/ <-- temp dashboard URL
17:00:50 <jamoluhrsen> #info please provide feedback on dashboard project.  we'll spend some time at hackfest talking about it as well.
17:16:40 <jamoluhrsen> #topic misc
17:17:08 <jamoluhrsen> #info didn't get to a few items
17:18:23 <jamoluhrsen> #info 1) karaf ssh issue coming in next update (https://issues.apache.org/jira/secure/ReleaseNote.jspa?projectId=12311140&version=12334639)
17:18:48 <jamoluhrsen> info 2) OPFLEX and INFRAUTILS system test waiver requested.  will work on that via email
17:18:58 <jamoluhrsen> #info 2) OPFLEX and INFRAUTILS system test waiver requested.  will work on that via email
17:19:34 <jamoluhrsen> #info 3) didn't get to talk about hooking external CI in to gerrit review path
17:20:11 <jamoluhrsen> #info 4) natapp was removed from compatible-with-all list
17:20:15 <jamoluhrsen> #endmeeting