16:01:54 <jamoluhrsen> #startmeeting integration
16:01:54 <odl_meetbot> Meeting started Thu Jun 16 16:01:54 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:54 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:54 <odl_meetbot> The meeting name has been set to 'integration'
16:03:10 <jamoluhrsen> #topic distribution
16:03:13 <zxiiro> doh someone's doing laundry
16:03:47 <jamoluhrsen> #info we have a patch for distribution documentation (cluster config and persistence config scripts)
16:04:36 <jamoluhrsen> #action LuisGomez  to document the version API.
16:05:12 <jamoluhrsen> #info small changes in distribution this week (projects adding features)
16:05:22 <jamoluhrsen> #info version api changes in stable/beryllium now
16:06:04 <jamoluhrsen> #info Vratko working on a project that will use the latest greatest karaf version (SNAPSHOT) and not a static released version
16:08:39 <jamoluhrsen> #info anipbu wants to know if we'll be getting a "stable distribution" this release.  LuisGomez notes that there is no stable feature yet, so probably no chance to get a "stable distribution"
16:09:45 <jamoluhrsen> #info Vratko confirms he doesn't expect any stable features this release either.
16:17:14 <jamoluhrsen> #info LuisGomez argues the reasoning behind creating a stable distribution (only containing stable features) might not be worth it.
16:17:30 <jamoluhrsen> #info dfarrell07 points out the idea of a stable distro came from user advisory group.
16:19:20 <zxiiro> I think having multiple distroes is confusing to the end user. it's better to mark it inside the single distro
16:20:11 <jamoluhrsen> #info another idea is that we can create two feature repos where one is the stable repo, but the artifacts you download as the ODL .zip would still have every feature.
16:20:32 <jamoluhrsen> zxiiro: agreed.
16:20:48 <jamoluhrsen> #topic packaging
16:21:07 <jamoluhrsen> #info we now have a .deb package that can be built from Int repo.  w00t!
16:21:38 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/40350 Patch to remove code from old Int repo li branch
16:21:45 <jamoluhrsen> #info patches are ready to wipe the other branches in the old Integration repo
16:21:49 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/40349 Patch to remove code from old Int repo master branch
16:22:38 <jamoluhrsen> #topic release
16:23:07 <jamoluhrsen> #info lots of weather items this week, so maybe some choppy waters for us?
16:23:41 <jamoluhrsen> #topic builder
16:23:51 <zxiiro> #info submodule timeout during cloning bumped to 60 minutes due to slow network
16:24:15 <dfarrell07> #agreed vrpolak, dfarrell07 (and consent by silence from others) that it's okay to just remove code from old Int repo's master and li branch, not he and h (had because branches are locked)
16:24:17 <jamoluhrsen> #info signal15 issue seen randomly because of slow network causing timeouts.
16:24:59 <jamoluhrsen> #info network slowness is believed to be the pipe between the public and private clouds, so we will wait to see if it goes away after we migrate releng to private cloud
16:26:03 <jamoluhrsen> #info VM sizes were all reduced earlier this week, but there so many jobs that needed 8G for builder that it's now back to the default.
16:26:51 <jamoluhrsen> #info testing CSIT jobs with small (4G) VMs
16:27:47 <jamoluhrsen> #info jamoluhrsen suggest to run openflowplugin switch scalability with small VM
16:29:16 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/view/openflowplugin/job/openflowplugin-csit-1node-periodic-sw-scalability-daily-lithium-redesign-only-beryllium/  <--- mininet VM goes to 500 switches.  might need extra memory for that mininet vm
16:29:21 <jamoluhrsen> zxiiro: ^^^
16:31:23 <zxiiro> #info JJB needs admin rights to query plugins info
16:31:24 <zxiiro> #info current workaround is to disable it via configuration
16:31:24 <zxiiro> #link https://review.openstack.org/326722/ Potential Fix for admin rights
16:32:29 <zxiiro> #info Started looking into pushing logs off of Jenkins, seems to work but need a web frontend to handle gzipped text files
16:33:45 <zxiiro> https://spectrometer.opendaylight.org/
16:34:10 <jamoluhrsen> #info still on track for the 25th to migrate releng to private cloud
16:34:42 <jamoluhrsen> #info vratko points out some failures starting VMs earlier in week, but now fixed.
16:35:54 <jamoluhrsen> #info we now have a log of what changes made it in to the current distro (inside .zip)
16:36:03 <jamoluhrsen> #topic misc
16:36:19 <zxiiro> #link https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-lithium/lastSuccessfulBuild/artifact/patches/taglist.log/*view*/ taglist.log
16:36:42 <jamoluhrsen> #info no disagreement to granting systest waiver to opflex and infrautils
16:38:12 <vrpolak> This is the file that ended up in latest Lithium autorelease .zip: https://jenkins.opendaylight.org/releng/view/autorelease/job/autorelease-release-lithium/lastSuccessfulBuild/artifact/patches/taglist.log
16:39:06 <jamoluhrsen> #action jamoluhrsen to update wiki, send email about system test waivers being granted
16:40:03 <jamoluhrsen> #info question about whether we have a CSIT job that uses the persistence config script?
16:40:15 <jamoluhrsen> #info no CSIT job uses it yet, but it will be coming.
16:41:23 <jamoluhrsen> #info work was coming to change the 200 status code on PUT calls which would affect CSIT jobs that are expecting that.
16:41:47 <jamoluhrsen> #info the patch to change this 200 response code got a -1 so not sure if it will come in Boron or not.
16:43:06 <jamoluhrsen> #info netconf EOS suite has been merged recently.
16:48:16 <jamoluhrsen> #info we need more consistent 100% passing CSIT verify jobs.
16:59:08 <jamoluhrsen> #info some conversation around longevity tests.  one idea is that we let those jobs burst back to the public cloud and not use resources in our faster private cloud
17:00:01 <jamoluhrsen> #endmeeting