16:02:55 <jamoluhrsen> #startmeeting integration
16:02:55 <odl_meetbot> Meeting started Thu Jul  7 16:02:55 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:55 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:55 <odl_meetbot> The meeting name has been set to 'integration'
16:04:05 <jamoluhrsen> #topic distribution
16:04:39 <jamoluhrsen> #info m4 status report has been updated with missing items.  e.g. all top level features need dev guide.
16:05:51 <jamoluhrsen> #info maven central requirements not quite done.  (e.g. meta data in pom files)
16:06:53 <jamoluhrsen> #action vratko to send quick email for help, and hopefully someone can jump in to help
16:07:37 <jamoluhrsen> #info probably not pushing artifacts to maven central this release, so probably not biggest priority anyway
16:08:43 <jamoluhrsen> #info jamoluhrsen notes that beryllium was not building earlier this week, because of a merge job failure in USC project
16:09:53 <jamoluhrsen> #info LuisGomez asks about the nexus conn timeout issues.
16:11:09 <vorburger> (sorry if I jump in here, is that OK?) do we know what is actually missing re. pushing artifacts to maven central this release? I may be motivated to help with some of that - but what needs to be done?
16:11:53 <jamoluhrsen> vorburger: this is just news from zxiiro on our meeting right now.  don't know the details.
16:12:37 <jamoluhrsen> #info there is a helpdesk ticket for nexus timeout.
16:12:50 <jamoluhrsen> #topic packaging
16:13:20 <jamoluhrsen> #info lots of good rpm work happened at the hackfest.  good automation done.
16:13:21 <vorburger> jamoluhrsen: elpdesk ticket for nexus timeout is [opendaylight.org #25098]
16:13:23 <zxiiro> vorburger: https://bugs.opendaylight.org/show_bug.cgi?id=5630
16:13:42 <jamoluhrsen> #info packaging wiki improvements made.
16:13:50 <zxiiro> vorburger: we just need someone to do the work. i haven't had any cycles this release with all the work we've been doing :(
16:13:59 <jamoluhrsen> #info plaurin still working on vagrant base boxes
16:14:23 <jamoluhrsen> #info tutorials interns pushing patches now.
16:14:56 <jamoluhrsen> #info .deb work committed now and automation for new builds is in progress.
16:16:01 <jamoluhrsen> #topic release
16:16:31 <jamoluhrsen> #info Be SR3 coming up in less than a month.  (3 weeks before cut off date)
16:16:47 <jamoluhrsen> #info build test failures in bgpcep
16:17:05 <jamoluhrsen> #info ietf yang type upgrade happening late in Boron release, but lots of people working on it.
16:17:33 <jamoluhrsen> #info boron autorel *still* failing, also because bgpcep
16:18:53 <jamoluhrsen> #info looks like there is email visibility for bgpcep for Boron in compilation error
16:19:26 <jamoluhrsen> #info not sure if anyone is looking at Beryllium bgpcep test failures.
16:22:39 <jamoluhrsen> #info probably an IRC working session coming to help power through ietf yang stuff.  maybe next wed
16:22:46 <zxiiro> anipbu: can you send me invite to that ietf meeting?
16:22:49 <jamoluhrsen> #topic builder
16:23:17 <jamoluhrsen> #info jenkins seems to be relatively stable finally, since we began migration.
16:23:59 <jamoluhrsen> #info still tuning the minions (aka slaves) to maximize the number of jobs we can run in parallel without running out of resources
16:24:42 <zxiiro> #info new wrapper macro opendaylight-infra-wrappers with parameter build-timeout
16:24:42 <zxiiro> #link https://git.opendaylight.org/gerrit/41421/ opendaylight-infra-wrappers macro
16:24:45 <jamoluhrsen> #info all jobs are single use for nodes, so jobs are thrown away after every job.
16:25:14 <jamoluhrsen> #info single use might help with jobs that were hanging before.  instances do get brought up quickly so this is not much of a problem.
16:25:45 <jamoluhrsen> #info new job types should always use the new opendaylight-infra wrapper
16:26:03 <jamoluhrsen> #action zxiiro to send an email about using this new opendaylight-infra wrapper
16:26:34 <zxiiro> #info SSH credentials are now opendaylight-jenkins-ssh instead of {ssh-credentials} variable
16:26:34 <zxiiro> #link https://git.opendaylight.org/gerrit/41424/ simplify ssh-credentials
16:27:32 <odp-gerritbot> Marcus G K Williams proposed a change to integration/test: Add OVSDB Max Nodes Test  https://git.opendaylight.org/gerrit/37639
16:32:46 <jamoluhrsen> #info sandbox has 64 cores
16:32:53 <jamoluhrsen> tykeal, how many robots can run in the sandbox
16:33:09 <tykeal> jamoluhrsen: depends upon the lab size...
16:33:30 <jamoluhrsen> tykeal, oh, I thought we had some max in parallel.  ok
16:33:52 <tykeal> jamoluhrsen: I would need to look at how we have the minion provider tuned
16:34:50 <jamoluhrsen> #info we now have 2 external CI systems that now have access to vote on projects
16:36:00 <jamoluhrsen> #info LuisGomez thinks we might need a new, separate set of resources just to run our performance tests.
16:37:54 <zxiiro> #info Docs now themed now with bootstrap
16:37:54 <zxiiro> #link http://docs.opendaylight.org/
16:39:28 <dfarrell07> jamoluhrsen: can you put the link here?
16:40:02 <jamoluhrsen> #link http://opendaylight.readthedocs.io/en/latest/_static/integration/robot/Utils.robot.html robot library docs now online.
16:40:30 <jamoluhrsen> #topic new gerrit workflow being proposed
16:43:28 <jamoluhrsen> #info basic workflow,  gerrit submission -> +1 verify -> +2 code-review -> next it new category for "approve".  if "approve" is given +1 then project defined set of jobs is then run (e.g. CSIT).  if these jobs come back clean, "approve" gets +2 and then automatically the patch is submitted and merged.
16:44:21 <jamoluhrsen> #info this new workflow would allow CSIT to gate patches, which is something people have wanted in the past, but others have not
16:46:01 <jamoluhrsen> #info singlefeature test now has a 10m timeout for features to come up, which is needed for some projects (e.g. netvirt) with the smaller VMs after migration (went from 4 to 2 cores)
16:47:31 <jamoluhrsen> #info one idea is to figure out if we can give larger VMs to specific projects build jobs, and zxiiro is looking for ways.
16:48:50 <jamoluhrsen> #info should we give the multipatch test job more cores, since it's infrequently used, but when it is used we don't like to wait so long for it to complete.
16:49:32 <jamoluhrsen> #action jamoluhrsen to figure out if we can just give a one off larger slave for the multipatch job
16:51:04 <jamoluhrsen> #info do we want to give build rights to project committers or not?  with migration, some committers lost those rights.
16:51:57 <jamoluhrsen> #info LuisGomez thinks we should grant access to all committers, maybe on an "as requested" basis.
16:52:40 <jamoluhrsen> #info tykeal notes that we lost a lot of permissions in the migration and we need to just work through and add permissions back.
16:55:00 <jamoluhrsen> #info releng will be going back to get permissions back for build rights
16:56:17 <jamoluhrsen> #info TSDR noticed issues with unit test reports after migration, but not sure whats going on.  they can still get reports in some fashion, and their tests *are* running
16:58:21 <jamoluhrsen> #endmeeting