16:01:11 <jamoluhrsen> #startmeeting integration
16:01:11 <odl_meetbot> Meeting started Thu Jul 14 16:01:11 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:11 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:11 <odl_meetbot> The meeting name has been set to 'integration'
16:04:09 <jamoluhrsen> #topic distribution
16:04:59 <jamoluhrsen> #info maven central requirements work happened this past week.  one question on how to do developers section?
16:05:38 <jamoluhrsen> #info distribution jobs were broken for over a week.  distro size was too big.
16:06:04 <jamoluhrsen> #info reason too large, other projects pulling in duplicate dependencies.
16:06:43 <jamoluhrsen> #info distribution changes coming that should help with overall size
16:07:57 <jamoluhrsen> #info tykeal still emphatic that we will not increase the nexus upload cap at 512MB
16:09:14 <jamoluhrsen> #info jamoluhrsen points out that it seems we are always going to be building bigger and bigger distros, so even if well behaved, as we add more projects to ODL we will eventually hit this cap anyway.
16:09:52 <jamoluhrsen> #info tykeal notes we probably need a new paradigm, with minimal distro that pulls new features from external resources as needed.
16:14:52 <jamoluhrsen> #info we need to find out how much we can reduce the size for now, and then go from there.
16:15:36 <jamoluhrsen> #topic packaging
16:16:02 <jamoluhrsen> #info opnfv sfc project was trying to use recent boron distro, but it was broken
16:16:21 <jamoluhrsen> #topic builder
16:17:07 <jamoluhrsen> #info our log archive will keep artifacts for 6 months.
16:17:28 <jamoluhrsen> #info plan is to get all jobs to push their artifacts to the log server
16:18:22 <jamoluhrsen> #info hoping to get gerrit comments and emails to report links to log server
16:19:10 <jamoluhrsen> #info currently not worried about storage space for log server
16:19:28 <jamoluhrsen> #info we have plenty of disk space
16:20:31 <jamoluhrsen> #info LuisGomez points out that we do use artifacts from one job to pass to another job, so can those end up on log server?
16:20:46 <jamoluhrsen> #info plot data is not an artifact, so we don't need to worry about those.
16:22:19 <jamoluhrsen> #info so if we want to get everyone off of jenkins we do need to figure out a way to stop viewing plots on jenkins
16:23:23 <jamoluhrsen> #info no more python scripting wrapping around JJB as of this week.  everything is pure JJB
16:24:07 <jamoluhrsen> #info now it should be easier to allow projects to pick build slaves specifically
16:24:40 <jamoluhrsen> #info down the road, all jobs might move to regular free style jobs, removing maven and matrix jobs.
16:26:06 <jamoluhrsen> #info it can potentially be hard to convert from maven/matrix to freestyle, but zxiiro thinking of ideas.
16:30:01 <jamoluhrsen> #info one benefit should be faster jobs compared to maven job types.
16:30:58 <jamoluhrsen> #info public cloud work still underway, but one problem remains.
16:31:41 <jamoluhrsen> #info when public cloud is available, we'll just need to use a different "label" in order to know which cloud the jobs will run.
16:32:30 <jamoluhrsen> #info new ETA for public cloud access is unknown.  depends on RackSpace solution
16:34:19 <jamoluhrsen> #info some issues we still have are random networking issues (rejected connections) and nexus upload rejects.
16:35:07 <jamoluhrsen> #info no clue on networking issues, but some things in progress to help with nexus (e.g. moving ldap)
16:37:35 <jamoluhrsen> #info mgkwill asking about running containers directly in infra, but we can run docker instances inside the VMs we get from infra
16:39:06 <jamoluhrsen> #info jamoluhrsen knows how to use sshuttle to access docker instances in one vm from external system
16:41:44 <jamoluhrsen> #info we have a demo repo ready for testing new gerrit workflow, but it's been on hold.
16:42:26 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/test: <DO NOT MERGE> DEbug the Netvirt CSIT Failures  https://git.opendaylight.org/gerrit/41735
16:49:04 <jamoluhrsen> #info releng folks thinking about building their own pipeline system...
16:49:22 <jamoluhrsen> #topic release
16:50:07 <jamoluhrsen> #info ietf upgrade happened yesterday, but still one patch waiting (atrium), and two other issues to figure out.
16:50:59 <jamoluhrsen> #info is there a deadline for deciding traditional release plan or fast phased for Carbon.
16:51:52 <jamoluhrsen> #info best idea to get to fast phased is to start with one root project, but there feels like no real momentum so seems likely that Carbon will stick with traditional release plan
16:52:55 <jamoluhrsen> #info SR3 cutoff in 10 days, release hopefully in 2 weeks?
16:54:18 <jamoluhrsen> #info for Boron there are 3 projects not in distribution, but time is running out and they are at risk to miss the release.
16:54:48 <jamoluhrsen> #info zxiiro points out that if he removes tcpmd5 from boron, because they are not participating, it will break other project.  there is a weather item for htat.
16:56:04 <jamoluhrsen> #topic misc
16:56:55 <jamoluhrsen> #info mgkwill advertises performance report work kickoff meeting tomorrow morning and should meet every week on Fridays 8:30.
16:58:24 <mgkwill> #info Meeting details for perf report plan kickoff "Cluster & S3P Test" Meet https://wiki.opendaylight.org/view/Meetings
16:58:37 <jamoluhrsen> #info how do we want to trigger CSIT?  probably easiest just to take all offset 2 projects and have them only trigger on offset 1.
17:00:03 <jamoluhrsen> #action LuisGomez or zxiiro to send email about these trigger consolidations.
17:00:56 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Meetings Meeting details for perf report plan kickoff "Cluster & S3P Test" Meet
17:00:59 <jamoluhrsen> #endmeeting