16:02:20 <dfarrell07> #startmeeting integration
16:02:20 <odl_meetbot> Meeting started Thu Jul 21 16:02:20 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:20 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:20 <odl_meetbot> The meeting name has been set to 'integration'
16:02:50 <dfarrell07> #chair jamoluhrsen LuisGomez anipbu zxiiro
16:02:50 <odl_meetbot> Current chairs: LuisGomez anipbu dfarrell07 jamoluhrsen zxiiro
16:03:39 <jamoluhrsen> #topic distribution
16:04:35 <jamoluhrsen> #info Boron distro failures in singlefeaturetest recently, but not good visibility on why the failures are happening
16:07:28 <jamoluhrsen> #info two features from distro from test-index (snmp4sdn and tsdr) have been removed now to make distribution build pass
16:09:43 <jamoluhrsen> #info new patch coming in odlparent that should help gain a little more visibility in to these failures.
16:11:23 <jamoluhrsen> anipbu, can you list those projects in irc, so I can make a note of it?  I missed one of them.
16:12:39 <jamoluhrsen> #info opflex next yangide are not in distribution, but we don't expect them to be.
16:13:29 <anipbu> #info projects missing from distribution: atrium, didm, of-config, vbd, eman, uscplugin
16:15:04 <jamoluhrsen> #info if these projects are not in the distribution by RC time, then they are not in the common karaf distribution
16:16:44 <jamoluhrsen> #info Beryllium SR3 is coming, and autorelease is fine for Beryllium so no major concerns from Int/Dist on Beryllium
16:18:16 <jamoluhrsen> #info LuisGomez points out that we should all take a look at the karaf logs as we approach Boron RC to file bugs for exceptions and errors
16:18:35 <odp-gerritbot> Vratko Polák proposed a change to integration/test: WIP: Create binding-parent.robot  https://git.opendaylight.org/gerrit/41970
16:18:38 <jamoluhrsen> #topic packaging
16:19:17 <jamoluhrsen> #info rpm building automation is upstream.  should let us build custom rpms using jenkins
16:19:44 <jamoluhrsen> #info next step is to get autorelease triggering this job so each autorel creates an rpm.  w00t!
16:20:46 <jamoluhrsen> #info intern projects for tutorials are making progress.
16:21:13 <jamoluhrsen> #info trying for a demo on this integration call for these tutorials in two weeks time (8/3)
16:22:23 <jamoluhrsen> #topic builder
16:23:01 <jamoluhrsen> #info new ldap server is up and mirrors old server and should fix a few infra issues (nexus timeout, auth errors)
16:23:48 <jamoluhrsen> #info the public cloud is now working and we can start moving jobs back there.
16:24:29 <zxiiro> https://git.opendaylight.org/gerrit/#/c/42186/
16:24:54 <jamoluhrsen> #info the first proposal is that our robot VMs will be in our private cloud, but all the other VMs (ODL, mininet, etc) will exist in the public cloud.
16:25:32 <jamoluhrsen> #info the networking between both clouds should be wide-open, so we do not expect any networking issues between the two clouds.
16:26:04 <jamoluhrsen> #info LuisGomez asks about network performance.  downloading ODL in public cloud used to take a long time sometimes so that might be an issue.
16:30:05 <odp-gerritbot> Vratko Polák proposed a change to integration/test: WIP: Create binding-parent.robot  https://git.opendaylight.org/gerrit/41970
16:31:01 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/42186  <----  example of how to run things in the public cloud
16:34:36 <jamoluhrsen> #info there are new node labels will not apply to the new public cloud because we can't fully control the size of those VMs.
16:36:06 <jamoluhrsen> #info first step is to start running our other VMs in the public cloud.  once that is working we can worry about adding new node labels to more accurate to what is running in the public cloud.
16:37:34 <zxiiro> #link https://git.opendaylight.org/gerrit/#/q/project:releng/builder+topic:remove-matrix remove-matrix verify jobs
16:37:38 <jamoluhrsen> #info matrix verfiy jobs are being deprecated for freestyle jobs
16:38:18 <jamoluhrsen> #info the job type runs a little faster (aprox 4m)
16:39:13 <jamoluhrsen> #info currently we can't do vagrant builds in public cloud, but packer seems to work, so all the vagrant profiles are now all packer.
16:39:38 <jamoluhrsen> #info another benefit is that our packer build will now build in both clouds at the same time.
16:40:36 <jamoluhrsen> #info we'll get a job that can hopefully verify and build the packer builds on merges
16:42:01 <jamoluhrsen> #info at some point we want to move all jobs to start installing their specific python dependencies so that we don't have to install ALL for every job; but this probably wont happen until after Boron.
16:42:06 <zxiiro> #link https://git.opendaylight.org/gerrit/42175 build matplotlib with packer
16:44:05 <jamoluhrsen> #topic release
16:44:40 <jamoluhrsen> #info branch cutting/version bumping happening at M5
16:45:42 <jamoluhrsen> #info Beryllium SR3 release candidate coming next week, so CSIT jobs will have to be monitored and understood.
16:46:11 <jamoluhrsen> #info it's hard to figure out the distribution-test job per autorelease job.
16:49:00 <jamoluhrsen> #topic misc
16:50:17 <jamoluhrsen> #info new build failure management plugin available in jenkins (sandbox now).  not sure how useful it is yet
16:50:48 <jamoluhrsen> #info new plugin requires user input.
16:52:16 <jamoluhrsen> #info when do we want to move our CSIT verify to using boron, as it's currently using beryllium?
16:52:39 <jamoluhrsen> #info we need to wait until when we think Boron is stable before we move.
16:54:02 <jamoluhrsen> #info should the distribution be able to run when not connected to the internet?    answer is yes, but currently that is not the case
16:55:04 <jamoluhrsen> #action jamoluhrsen to file a bug for offline distro not working
16:55:18 <jamoluhrsen> #action LuisGomez to send email about offline distro not working?
16:55:20 * dfarrell07 has to drop to get food before TSC
16:57:02 <jamoluhrsen> #info jvm monitoring demo in two weeks time as well.
16:57:27 <jamoluhrsen> #endmeeting