16:03:19 <dfarrell07> #startmeeting integration
16:03:19 <odl_meetbot> Meeting started Thu Jul 28 16:03:19 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:19 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:19 <odl_meetbot> The meeting name has been set to 'integration'
16:11:59 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/41183/ Gerrit with L2 Switch tutorial docs, dfarrell07 requests feedback from everyone
16:12:28 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/41110/ Vagrantfile with L2Switch tutorial, LuisGomez to review for use in ODL Summit
16:12:52 <dfarrell07> #info dfarrell07 and LuisGomez talk about combining efforts to build ODL Summit tutorial envs with intern tutorial work
16:13:32 <dfarrell07> #action LuisGomez,  phrobb and dfarrell07 to talk about Summit tutorials and how to get more value with modern tools/tutorials effort
16:14:59 <dfarrell07> #info tykeal and zxiiro are still having to restart Jenkins a lot, but things are moving fairly quickly otherwise
16:15:37 <dfarrell07> #info tykeal talks about timeout issue Jenkins/Nexus, is about to move to new LDAP server which ~"should" fix this
16:17:48 <dfarrell07> #info anipbu reports that there are still 8 projects not in distro, has sent emails and CC'd LuisGomez and Vratko
16:18:10 <dfarrell07> #info anipbu notes that TSC can start dropping projects at RC0, and maybe should
16:18:26 <dfarrell07> #info all projects are in autorel, but it's breaking (and has been for a loooongg time)
16:18:42 <dfarrell07> #info SDNI issue has been resolved, can likely add back to distro
16:20:23 <dfarrell07> #info discussion about us patching to add SDNI to distro or them sending patch, without setting precedent we'll do it this time, expect projects to do it themselves in the future
16:20:48 <dfarrell07> #info Some bugs still failing in Be SR3
16:23:04 <dfarrell07> #info Discussion about impact of bugs in SR3, if we can release with them, what is downstream of NIC and SXP
16:23:26 <dfarrell07> #info LuisGomez thinks non-responsive projects shouldn't block a release
16:23:39 <anipbu> https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1820514274
16:24:03 <dfarrell07> #link https://docs.google.com/spreadsheets/d/1hci5TMUPyB6PX8Al-fwfVqvs5SQVa2wZLja_7rKWN6o/edit#gid=1820514274 SR3 tracking spreadsheet with bug info
16:29:42 <dfarrell07> #info Discussion about needing support network for projects, like collaboration groups for core/plugins/support/apps/mature/core, to help projects along with rel process
16:30:35 <dfarrell07> #info Discussion about how TSC refactoring goes perfectly with this idea of support between projects, can use RGs, have weekly/monthly meetings for RGs
16:31:03 <dfarrell07> #info Clustering work is making progress, LuisGomez also has new clustering lib in places and tests moved over to it, will do TWS on it when ready
16:31:33 <dfarrell07> #info LuisGomez reports that work for clustering for Boron for Int/Test is mostly done, projects now need to take this lib we've build and use in system tests
16:31:51 <dfarrell07> #info Now starting on perf work via S3P group, to do Boron whitepaper by Summit
16:32:35 <dfarrell07> #info S3P group needs to build all test automation between now and release, then do all tests and write paper between release and summit (3 weeks)
16:33:01 <dfarrell07> #info LuisGomez asks Vratko about OF and other plugin testing, please share on list
16:33:12 <dfarrell07> #info mgkwill is driving ODL S3P efforts
16:37:05 <dfarrell07> #info dfarrell07 talks about how Apex is hitting no-internet karaf bug, fairly big deal, Vratko is working it and will ++ prio
16:37:53 <dfarrell07> #info dfarrell07 talks about no existing Boron autorel builds for OPNFV to test, very few successful builds, the three that worked (175-177) didn't publish artifacts to Nexus so still not aval for testing
16:38:16 <dfarrell07> #info dfarrell07 knows people are working on getting autorel building, just wanted to add info that OPNFV is looking/needing
16:40:00 <dfarrell07> #link https://paste.fedoraproject.org/396889/69717053/ Apex log for non-internet karaf bug
16:40:16 <dfarrell07> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-July/007548.html HEAD of email thread about no-internet karaf bug
16:40:27 <dfarrell07> #link https://bugs.opendaylight.org/show_bug.cgi?id=6187 No-internet karaf bug
16:42:00 <dfarrell07> #info LuisGomez reports that JVM monitoring framework is ready, both for single node and cluster
16:42:43 <dfarrell07> #info LuisGomez needs to talk to impact about intern of any perf impact of framework, likely nbd
16:42:54 <dfarrell07> #undo
16:42:54 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x23de950>
16:43:02 <dfarrell07> #info LuisGomez needs to talk to intern about impact of any perf impact of framework, likely nbd
16:43:23 <dfarrell07> #info People should start playing around and using this JVM framework
16:43:49 <dfarrell07> #info There is a wiki about JVM stuff, LuisGomez will send out link in email (or dfarrell07 will find before)
16:44:39 <dfarrell07> #info LuisGomez gives a demo of JVM framework output, seems cool, dfarrell07 can't see because booo WebEx
16:45:06 <dfarrell07> #info this JVM mon stuff will be great for perf tests
16:46:53 <dfarrell07> #info Vratko reports that suite to test maven plugin is ready for merge, sandbox needs a patched version of plugin so can't <do something dfarrell07 didn't follow>
16:47:16 <dfarrell07> #info Vratko also has some updates to make SSH keywords lib better involving smarter working dirs
16:47:40 <dfarrell07> #info Also some changes going in to robot libs about working in py venvs
16:48:10 <dfarrell07> #info Will be able to use this lib to install whatever you want with pip in venv
16:49:27 <dfarrell07> #info LuisGomez talks about docing libs people should use, standardize which libs to use, consolidate
16:51:52 <dfarrell07> #action Vratko and LuisGomez to sort out which libs are modern and should be used, doc in appropate place (textfile in repo? readthedocs?), maybe move tests to use only new libs
16:56:54 <dfarrell07> #action dfarrell07 to stub out readthedocs page with modern, old and unsorted libs, with links from libs to auto-gen'd docs, others to update into right sections via patches
16:58:36 <dfarrell07> #info Venkat talks about some jobs failing, may be infra, will send details to mail
17:00:42 <dfarrell07> #info dfarrell07 asks for help from LuisGomez et al about L2Switch issue with hosts not being found sometimes
17:00:55 <dfarrell07> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-July/007597.html link to email from intern with bug discussion^^
17:01:04 <dfarrell07> #action LuisGomez to help those interns^^
17:01:07 <dfarrell07> #endmeeting