16:02:48 <dfarrell07> #startmeeting integration
16:02:48 <odl_meetbot> Meeting started Thu Aug  4 16:02:48 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:48 <odl_meetbot> The meeting name has been set to 'integration'
16:02:48 <LuisGomez> let me see
16:03:02 <dfarrell07> #chair jamoluhrsen LuisGomez anipbu zxiiro
16:03:02 <odl_meetbot> Current chairs: LuisGomez anipbu dfarrell07 jamoluhrsen zxiiro
16:03:09 * dfarrell07 is called in
16:04:30 <jamoluhrsen> #topic packagin
16:04:36 <jamoluhrsen> #topic packaging
16:05:09 <jamoluhrsen> #info now building fedora packages (thanks to plaurin)
16:05:53 <jamoluhrsen> #info l2switch tutorial is now done, but sporadic behavior noticed
16:06:43 <jamoluhrsen> #info clustering tutorial coming next.
16:08:13 <jamoluhrsen> #info was a mention of tutorial using python cluster deployer, but suggestion is that we use the new cluster deployer scripts shipped in the distribution
16:09:50 <jamoluhrsen> #info new patch coming for cluster config scripts to make it slightly easier (don't need to give controller index)
16:10:26 <jamoluhrsen> #link https://opendaylight.readthedocs.io/en/latest/getting-started-guide/common-features/clustering.html?highlight=clustering   <--- clustering config docs
16:13:16 <jamoluhrsen> #info the list of tutorials is now listed for the summit and hopefully we can leverage some of these l2switch/clustering/etc tutorials for the summit
16:17:25 <jamoluhrsen> #topic distribution
16:17:57 <jamoluhrsen> #info saw temp issue with karaf not starting.   fixed now.
16:18:06 <odp-gerritbot> Peter Gubka proposed a change to integration/test: Add functional suites for bgpcep using exabgp  https://git.opendaylight.org/gerrit/38667
16:18:25 <jamoluhrsen> #info distribution is WAY TOO BIG and now it will not upload to nexus, which breaks everything in CI
16:18:41 <jamoluhrsen> #info no system tests are running
16:19:19 <jamoluhrsen> #info autorelease can not produce anything for us.
16:19:58 <jamoluhrsen> #info LuisGomez thinks we cannot go much longer with this problem or we have to delay release or we have to change upload size limit on nexus
16:20:30 <jamoluhrsen> #info one solution is to revert patch to allow us to start offline, which brought in apache cxf
16:20:50 <jamoluhrsen> #info skitt notes that some of the biggest jars are coming from atrium
16:21:42 <jamoluhrsen> #info tykeal does not want to change upload limit, but if TSC chooses so we will change it.
16:23:15 <skitt> #info atrium is just an example among many
16:23:37 <zxiiro> public cloud appears to be working again
16:23:43 <jamoluhrsen> #info the distribution increased in size by nearly 80M just recently.
16:23:48 <zxiiro> releng is starting to process csit
16:24:31 <skitt> I'm entering a bug right now
16:24:33 <jamoluhrsen> #info we need a blocking bug for this distribution size issue.
16:24:41 <jamoluhrsen> #action skitt to file the dist size blocking bug
16:26:19 <skitt> #info the bug is https://bugs.opendaylight.org/show_bug.cgi?id=6341
16:26:35 <tykeal> skitt make that a #link instead
16:26:41 <skitt> #link https://bugs.opendaylight.org/show_bug.cgi?id=6341
16:27:18 <jamoluhrsen> #action LuisGomez, vratko to revert this patch https://git.opendaylight.org/gerrit/#/c/42842
16:27:45 <jamoluhrsen> #info LuisGomez suggests that we add some tests to check for distribution growth
16:28:08 <skitt> revert is https://git.opendaylight.org/gerrit/43136
16:28:36 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/43136 <--revert of 42842
16:31:49 <jamoluhrsen> #info we should change distribution to use odl-parent, then revert patch.
16:32:35 <jamoluhrsen> #action jamoluhrsen to reopen the offline distro bug and make it a blocker
16:33:17 <jamoluhrsen> #info basic growth test can be to check if distro size is > 500M to at least give us a warning that we are close to the nexus limit
16:35:06 <jamoluhrsen> #info it should now be safe to remove tcpmd5 from autorelease....
16:35:27 <jamoluhrsen> #info zxiiro notes it's already been removed since july 22nd
16:35:44 <jamoluhrsen> #info beryllium SR3 distro ready to ship
16:36:02 <jamoluhrsen> #topic infra/builder
16:36:32 <jamoluhrsen> #info public cloud now seems to be working again now.  close to 24hour outage
16:37:16 <jamoluhrsen> #info not sure how things happened, but rackspace was doing maintenance and maybe that was part of the reason
16:38:14 <jamoluhrsen> #info similar problems have happened in the past
16:39:41 <jamoluhrsen> #info the nexus timeout issue is still happening, even after LDAP mirror is in place.  Feels like it's happening less often though.
16:42:04 <jamoluhrsen> #info jamoluhrsen points out that we are still seeing the ssh EOFError issues.
16:46:15 <jamoluhrsen> #info ssh EOFError started happening when we migrated to private cloud.  are still happening now that we have moved test VMs to public with robot VM still in private
16:46:53 <zxiiro> I think adding a retry on the ssh attempts will make the job more resilient to intermittent issues too
16:47:18 <jamoluhrsen> zxiiro: ack
16:47:34 <jamoluhrsen> #info no major infra changes coming now, so hopefully we can stabilize going forward
16:47:43 <jamoluhrsen> #topic misc
16:48:59 <jamoluhrsen> #info robot library organization was brought up last week....   we need better docs for these, and we better structure to be able to help new people coming to CSIT
16:49:30 <jamoluhrsen> #info also other projects are starting to use our robot tests.
16:50:53 <jamoluhrsen> #info overall questions around what Integration/* can/should do about helping fast and/or phased release strategy.
16:51:31 <jamoluhrsen> #info things like more automation around packaging, a working autorelease...
16:54:20 <odp-gerritbot> Luis Gomez proposed a change to integration/distribution: Pull karaf from odlparent  https://git.opendaylight.org/gerrit/43139
16:54:31 <jamoluhrsen> #info dfarrell07 points out that ODL dev design forum is there in Sep to help plan some kind of pilot for fast/phased.
16:55:14 <jamoluhrsen> #info vratko notes that now is the deadline for us to decide if we are creating a stable distro, and it's pretty clear that we are NOT creating this.
16:56:11 <jamoluhrsen> #info odlparent needs to get the ball rolling in order for us to get any kind of stable release...  first odlparent needs to become mature.  skitt is driving this.
16:57:10 <jamoluhrsen> #info jamoluhrsen and LuisGomez on PTO next thurs.  might cancel the meeting or dfarrell07 can run.  will decide later
16:57:16 <jamoluhrsen> #endmeeting