16:01:23 <dfarrell07> #startmeeting integration
16:01:23 <odl_meetbot> Meeting started Thu Aug 25 16:01:23 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:23 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:23 <odl_meetbot> The meeting name has been set to 'integration'
16:01:34 <dfarrell07> #chair jamoluhrsen anipbu
16:01:34 <odl_meetbot> Current chairs: anipbu dfarrell07 jamoluhrsen
16:02:15 <dfarrell07> I like to start it to make sure we use the same name, so dirs get created correctly and we don't have to bother tykeal about it again ;)
16:02:30 <tykeal> lol
16:03:29 <jamoluhrsen> #info dfarrell07 requires anyone starting these irc meeting notes to ONLY call it "integration"
16:04:03 <jamoluhrsen> #action jamoluhrsen to put a link to robot libs in readthedocs on wiki
16:04:34 <jamoluhrsen> #action jamoluhrsen figure out what/where we are going to do about robot lib organization
16:05:41 <jamoluhrsen> #info vratko verified that boron snapshot is using karaf version 3.0.7, but latest autorel build is using 3.0.6.  it's possible that new version is available but autorel is having trouble recently.
16:07:08 <jamoluhrsen> #info current autorelease not triggering distro test jobs.  workaround is that we have to manually kick-off jobs.
16:07:21 <jamoluhrsen> #action jamoluhrsen to send email to [releng] about this looking for a fix.
16:07:53 <jamoluhrsen> #action vrpolak to add some minor comment about version feature in dev guide
16:08:04 <jamoluhrsen> #topic distribution
16:09:21 <jamoluhrsen> #info question if we can close the distro size too big bug?
16:10:53 <vrpolak> https://bugs.opendaylight.org/show_bug.cgi?id=6341
16:11:24 <dfarrell07> #link http://cbs.centos.org/repos/nfv7-opendaylight-43-release/x86_64/os/Packages/ ODL Be SR3 RPM is 269MB
16:11:24 <jamoluhrsen> #action tykeal to put nexus file size limit back to where it was before bug 6341 was filed
16:11:42 <jamoluhrsen> #link https://bugs.opendaylight.org/show_bug.cgi?id=6341  <-- distro size too big bug
16:12:02 <jamoluhrsen> #info LuisGomez points out that Beryllium was in the 300M range, but Boron is well over 400M
16:13:37 <jamoluhrsen> #action LuisGomez to give us a trello card for us to add some test around checking size limit
16:14:26 <jamoluhrsen> #topic release
16:14:45 <jamoluhrsen> #info release reviews starting tomorrow
16:16:07 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020   <-- release review schedule
16:16:35 <jamoluhrsen> #info projects CSIT needs to be analyzed to see if they meet expectations.
16:17:35 <jamoluhrsen> #info Boron RC2 coming today, meaning one more week until RC3 which is normally what we want to present to TSC
16:17:53 <jamoluhrsen> #info RC1 did have some CSIT with failures which have (may have) bugs filed
16:18:38 <jamoluhrsen> #info anipbu points out that we are still seeing new features coming in to Boron although we are in RC timeframes
16:19:39 <jamoluhrsen> #info TSC seemed open to allowing this kind of development, so it is what it is.
16:20:12 <jamoluhrsen> #topic builder
16:20:37 <jamoluhrsen> #info still having nexus timeout issues and no idea why it's happening.
16:21:00 <jamoluhrsen> #info still have open tickets (without RackSpace response) for issues in the public cloud.
16:21:56 <jamoluhrsen> #info jamoluhrsen noticed that he didn't hit any of the typical public cloud issues while using the sandbox extensively yesterday (8/24)
16:23:17 <jamoluhrsen> #info tykeal has a new idea to get rid of jclouds with something like heat/cloud-orchestration from the robot VM
16:24:47 <jamoluhrsen> #info standing issues might just be the nexus timeout and maybe public cloud VM connectivity
16:26:15 <jamoluhrsen> #topic packaging
16:27:09 <jamoluhrsen> #info internships are ending, so final outcomes were 1 L2Switch tutorial, and a gerrit that needs work to get .deb packaging working
16:27:57 <jamoluhrsen> #info dfarrell07 looking in to hosting rpms on nexus, which could help downstream partners like apex from opnfv.  looking for help to get that done.
16:28:20 <jamoluhrsen> #info finding autorelease builds is hard.  we need an easier way
16:30:18 <jamoluhrsen> #info tutorial involving netvirt in the works
16:30:24 <plaurin> +1
16:30:38 <jamoluhrsen> #topic misc
16:31:00 <vrpolak> My e-mail about the autorelease deploy issue: https://lists.opendaylight.org/pipermail/dev/2016-August/002638.html
16:32:04 <jamoluhrsen> #info jamoluhrsen points out that distribution-check is no longer giving us the distro .zip  could this be happening be coming from the migration to freestyle job?
16:32:36 <jamoluhrsen> #info we need to add the distribution to the right place for the new archive tool.
16:34:26 <jamoluhrsen> #action LuisGomez to check if we are storing the artifacts in jenkins the right way, so that depended jobs can use it.
16:36:41 <jamoluhrsen> #info is it ok to disable the Lithium csit jobs now?  the patch vrpolak gave did not work.
16:37:45 <jamoluhrsen> #info LuisGomez asks can we just delete the Lithium jobs?
16:38:05 <jamoluhrsen> #info let's just wait until Boron to release and then we'll delete (just a few more weeks).
16:38:32 <jamoluhrsen> #info question if we can change csit verify jobs to use Boron now?  vrpolak says yes
16:38:43 <jamoluhrsen> #action LuisGomez to change verify jobs to use Boron
16:40:14 <jamoluhrsen> #info do we have or not a VM with ovs 2.3 or higher?  We have a vm with a label that says 2.3 but we get emails that say it's only 2.0
16:41:50 <jamoluhrsen> #info tykeal says what we have in packer is what we will get.  and the comment in packer is that it's installing ovs 2.3.1
16:43:08 <jamoluhrsen> #info LuisGomez suggests that we just move to ovs 2.5
16:46:39 <jamoluhrsen> #info LuisGomez notes that there is not much difference with performance jobs in public cloud the state of persistence (on or off) does not seem to matter.
17:02:46 <jamoluhrsen> #endmeeting