16:02:57 <jamoluhrsen> #startmeeting integration
16:02:57 <odl_meetbot> Meeting started Thu Sep  8 16:02:57 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:02:57 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:02:57 <odl_meetbot> The meeting name has been set to 'integration'
16:04:46 <jamoluhrsen> #info new cluster/entity changes require changes in test code
16:06:06 <jamoluhrsen> #info question around how we want to address this in test code.
16:06:56 * dfarrell07 is looking for the Gerrit
16:07:04 <jamoluhrsen> #info since it's affecting all projects using clustering, so probably best to put in Cluster Management library
16:07:42 <dfarrell07> LuisGomez: when you get a chance, can you link in the gerrits
16:08:51 <dfarrell07> makes sense
16:09:03 <jamoluhrsen> #info vratko has an idea where the tests can work for both boron (with this new change) as well as Beryllium which will not have this change.
16:10:40 <jamoluhrsen> #action vrpolak to look at Priya's patch to see if that's the approach we want to use.
16:11:03 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/45363/ <--- Priya's patch
16:12:21 <jamoluhrsen> #info this change only impacts tests that check entity owner
16:14:01 <jamoluhrsen> #info will take aprox 2 days to get cluster tests changed and jobs rerun and analyzed
16:15:09 <jamoluhrsen> #topic release
16:15:37 <jamoluhrsen> #info Boron will be delayed still.  still two issues pending.
16:16:11 <jamoluhrsen> #info DLUX has 20 patches they want to merge, but push back from community.  some blocker bugs they want to fix for their new feature "yangman"
16:16:28 <jamoluhrsen> #info release missed these because blockers were not made known until very late
16:16:45 <jamoluhrsen> #info blocker bug in OFP  (6638).  one line patch ready to merge
16:17:29 <jamoluhrsen> #info vbd had blockers but they were fixed and verified.
16:18:44 <jamoluhrsen> #info hopefully a respin will happen shortly after TSC call.
16:19:17 <jamoluhrsen> #info any new blockers coming after today, we recommend projects talk to TSC
16:19:48 <jamoluhrsen> #info means the build will be ready tomorrow (Friday), and then projects vote GO/NO-GO which takes a couple days.
16:20:40 <jamoluhrsen> #info conclusion is that we hope to release would happen closer to the 13th
16:22:08 <dfarrell07> #info ODL marketing release is targeted at 21st to sync with OPNFV and to give us breathing room
16:24:17 <jamoluhrsen> #info phrobb points out that this group should really weigh in to the TSC about the DLUX blocker bug 20 patch issue
16:25:27 <jamoluhrsen> #info dfarrell07 notes that the safest plan is to put DLUX patches in to SR1
16:26:24 <jamoluhrsen> #info anipbu points out that this new feature "yangman" is already there in Boron, and that these 20 patches are just bug fixes to this new feature.
16:27:32 <jamoluhrsen> #info the UI version of anipbu thinks the patches are ok.
16:27:46 <jamoluhrsen> #info the release manager version of anipbu is very anxious about this.
16:29:31 <jamoluhrsen> #info there are zero tests in place for these dlux features.  nothing upstream.  these features are not even loaded in distribution test, so we have nothing.
16:30:59 <dfarrell07> #info Since we don't have UT/ST for GUI, we'd need to do manual retesting, and there's more risk
16:32:22 <dfarrell07> #info The applications that build on DLUX would be the people who would need to retest, not so easy to do
16:32:53 <dfarrell07> lost audio
16:33:21 <dfarrell07> back
16:34:39 <jamoluhrsen> #topic distribution
16:35:36 <jamoluhrsen> #info some Carbon issues recently.  single feature test was taking really long, had OOM issues and then still passed.
16:37:07 <jamoluhrsen> #info distro size for RCs is ~400M which is much lower than the 550+
16:37:52 <jamoluhrsen> #info vrpolak points out that Beryllium distro jobs are failing because TSDR merges are failing.
16:38:12 <jamoluhrsen> #action jamoluhrsen, LuisGomez, or vrpolak to email TSDR about there Be merge job failure
16:40:03 <jamoluhrsen> #info LuisGomez asks if it's ok that we are building things by pulling artifacts from external repos?
16:42:23 <jamoluhrsen> #action LuisGomez to send an email about these failures when pulling from external repos.  may be a sporadic problem.
16:43:40 <jamoluhrsen> #info we do have CSIT to check version feature for Boron RC.
16:44:02 <jamoluhrsen> #info we do NOT have automation around the cluster config script that we ship with the distro.
16:45:00 <jamoluhrsen> #undo
16:45:00 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x25a0cd0>
16:45:22 <jamoluhrsen> #info we do have CSIT jobs that use the cluster config script
16:45:40 <jamoluhrsen> #info we do have jobs that *use* the "set persistence" script from the distribution
16:46:00 <jamoluhrsen> #topic packaging
16:46:38 <jamoluhrsen> #info lots of rpms for opnfv and now that work is done with jenkins jobs
16:47:41 <jamoluhrsen> #topic builder
16:48:10 <plaurin> dfarrell07, sorry didn't catch that
16:48:23 <dfarrell07> plaurin: np, was just asking if you had any updates you wanted to give
16:48:28 <jamoluhrsen> #info still investigating the nexus timeout issues.  speed issues are there too.
16:49:12 <plaurin> dfarrell07, I don't, still planning on building tools vm on packer but didn't have the time to start anything yet
16:49:47 <jamoluhrsen> #info tykeal notices that he can bypass some of the network and not see the speed issues.
16:49:48 <dfarrell07> plaurin: cool, that's what I assumed/reported:)
16:50:50 <jamoluhrsen> LuisGomez, are you trying to sell Brocade switches to RackSpace?
16:50:56 <dfarrell07> lol
16:51:20 <LuisGomez> we have ADX load balancer :)
16:51:45 <jamoluhrsen> #info we still have the ssh key copy timeout.  not sure if it's related.
16:52:13 <LuisGomez> ADC actually: http://www.brocade.com/en/products-services/software-networking/application-delivery-controllers.html
16:53:22 <jamoluhrsen> #info all other infra issues seemed to have been hunted down and resolved.
16:54:20 <jamoluhrsen> #info releng/builder committers have a vote to promote Anil to committer
16:54:32 <jamoluhrsen> #topic misc
16:55:19 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Events:Carbon_Dev_Forum  <--- topics for DDF at ODL Summit.  Sign yourself up.
16:56:54 <jamoluhrsen> #info we did have log file size issues with ODL VMs setting 100G log file size on VMs with smaller disks
16:57:14 <jamoluhrsen> #info we need to fix cluster jobs though because they first copy the logs to robot VM then archive them.  need a patch for that.
16:57:43 <jamoluhrsen> #endmeeting