16:01:34 <jamoluhrsen> #startmeeting integration
16:01:34 <odl_meetbot> Meeting started Thu Oct  6 16:01:34 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:01:34 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:01:34 <odl_meetbot> The meeting name has been set to 'integration'
16:05:29 <jamoluhrsen> #topic builder
16:06:22 <jamoluhrsen> #info jobs were aborting earlier in the week, but cleared orphans seemed to fix that.
16:07:19 <jamoluhrsen> #info contract signed with Rackspace to increase cloud infra size
16:07:45 <jamoluhrsen> #info when the new infra is online, we'll move CSIT back to private cloud (as much as we can)
16:08:06 <jamoluhrsen> #info if/when we see ODL forge in heavy use, CSIT will go back to the public cloud if needed.
16:10:08 <jamoluhrsen> #info we do have the ability to test CSIT jobs in both clouds using the sandbox, so we can use that to figure out if jobs are ok to migrate back and forth.
16:11:43 <jamoluhrsen> #info sanity check jobs can first move to the private cloud
16:12:42 <jamoluhrsen> #info zxiiro|pto gone until next week, and tykeal and anil gone starting next week
16:13:33 <jamoluhrsen> #topic release
16:14:00 <jamoluhrsen> #info Beryllium SR4 (last Be release) in 1.5 weeks
16:14:16 <jamoluhrsen> #info Beryllium passing autorel and seems healthy
16:15:05 <jamoluhrsen> #info Boron SR1 in 3 weeks.  no idea the health there or if a lot of patches coming in.
16:21:00 <jamoluhrsen> #info autorelease is too hard to debug!  we/anipbu needs help
16:22:26 <tykeal> anipbu: https://logs.opendaylight.org/releng/jenkins092/autorelease-release-boron/17/_console-output.log.gz do a search for 'Reactor Summary'
16:22:47 <jamoluhrsen> #topic distribution
16:22:56 <tykeal> scrolling through that I then see that bmp-mock failed and then all the modules after that were SKIPPED
16:24:41 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/46258/ <--- better distro verification
16:24:44 <tykeal> anipbu: and then just above the reactor summary you'll see the bmp-mock failed tests
16:25:52 <jamoluhrsen> #info master failing distro check.
16:27:11 <jamoluhrsen> #action jamoluhrsen to point Vishal to helpdesk for distro check issue
16:27:42 <odp-gerritbot> Lydia Buckuliakova proposed a change to integration/test: Improving TemplatedRequests to support stream specific template  https://git.opendaylight.org/gerrit/46627
16:28:40 <jamoluhrsen> #topic misc
16:32:34 <jamoluhrsen> #info at the summit it was pointed out that the Integration group is not very "test" focused.  talked about ways to fix it.  one idea is to create a "test" mailing list and "test" meeting.
16:35:34 <jamoluhrsen> #info anipbu thinks this existing Int/* meeting is more internally focused, and maybe we need a more externally focused meeting.
16:36:06 <odp-gerritbot> Lydia Buckuliakova proposed a change to integration/test: Improving TemplatedRequests to support stream specific template  https://git.opendaylight.org/gerrit/46627
16:43:01 <jamoluhrsen> #info LuisGomez asks if we need to add anything from Int/* to the Carbon release plan?
16:45:12 <jamoluhrsen> #info the "experimental" label did seem to help in the Boron release, and really gave a good view in to the projects that really care about system test and those that do not care
16:45:44 <jamoluhrsen> #info for Carbon, we want to start implementing "sanity" jobs that run quickly and ALWAYS pass.  if they fail, it means that something is totally broken.
16:46:42 <jamoluhrsen> #info we still need to define what a "sanity" test case is.  basically if a sanity test fails, we should think there is some critical/blocking bug
16:48:50 <jamoluhrsen> #info another summit takeaway was that we should start pointing our dashboard ideas to the spectrometer project
16:49:37 <jamoluhrsen> #info one summit session was asking (again) for ssh access to the vms as they are running tests
16:51:31 <jamoluhrsen> #info there may be some infra changes in the near future (especially in networking) and may allow us to possibly grant certain people access to our cloud systems via shell (so ssh access may be possible soon).  sandbox systems
16:54:14 <jamoluhrsen> #info another idea we are trying out from a summit session is to run nested vms inside a CSIT VM to run our openstack jobs.
16:57:30 <jamoluhrsen> #action dfarrell07 to send email to release formally stating that Int/Pak will not participate in Carbon SR
17:04:01 <jamoluhrsen> #endmeeting