17:01:28 <jamoluhrsen> #startmeeting integration
17:01:28 <odl_meetbot> Meeting started Thu Nov 10 17:01:28 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:28 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:28 <odl_meetbot> The meeting name has been set to 'integration'
17:03:32 <jamoluhrsen> #topic release
17:04:18 <jamoluhrsen> #info no major release news.
17:05:10 <jamoluhrsen> #info probably a good idea for Integration team to analyze project CSIT at some point and give report if they are meeting expectations.
17:07:03 <jamoluhrsen> #info probably best to wait for M5 to send the full CSIT analysis per project
17:10:49 <jamoluhrsen> #info anipbu wondering how we can make the system test plan better?
17:10:57 <jamoluhrsen> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template  <---  existing test plan
17:13:13 <jamoluhrsen> #info one reason to have better test plans is to help understand if "blocker" bugs are really blockers.
17:16:43 <jamoluhrsen> #action anipbu to provide a wiki/doc with these ideas about projects giving better test plans
17:17:13 <jamoluhrsen> #topic packaging
17:17:45 <jamoluhrsen> #info dfarrell07 working a lot on downstream/internal packaging
17:18:25 <jamoluhrsen> #info any upstream packaging work is slowly moving along via internship projects
17:18:38 <odp-gerritbot> Peter Gubka proposed a change to integration/test: updating bgp userfeatures suites to support openconfig peer configuration  https://git.opendaylight.org/gerrit/48159
17:19:37 <jamoluhrsen> #info ODL intern projects can now be submitted by mentors
17:20:27 <jamoluhrsen> #info we need to get autorelease for carbon working sooner rather than later
17:21:12 <jamoluhrsen> #info might not be anyone looking at it.
17:21:38 <jamoluhrsen> #action zxiiro and/or anipbu will try to see what's wrong with it.  maybe an email already went out
17:22:08 <jamoluhrsen> #info dfarrell07 added a bunch of trello cards and more coming.
17:22:20 <jamoluhrsen> #topic distribution
17:23:07 <jamoluhrsen> #info distribution is late with M1 status.  no release plan yet, but probably nothing specific for carbon
17:23:56 <jamoluhrsen> #topic builder
17:25:03 <jamoluhrsen> #info lots of new patches in builder repo to set "defaults" instead of our existing static values.  ie. varialbe for email receipients instead of jenkins-user
17:25:36 <jamoluhrsen> #info patch test jobs are now slightly higher priority.
17:25:55 <jamoluhrsen> #info also patch test jobs are now running concurrently.
17:26:50 <jamoluhrsen> #info should be ok to change our CSIT jobs to run concurrently.
17:27:43 <jamoluhrsen> #action jamoluhrsen to give example patch for running csit concurrently on integration-dev list
17:28:07 <jamoluhrsen> #info historically, our prioritization was not as good as it is now, so running in parallel should be ok.
17:29:27 <jamoluhrsen> #info this label: ubuntu-trusty-mininet-ovs-23-2c-2g seems to not be coming up
17:31:24 <jamoluhrsen> #info jamoluhrsen points out that some projects like netvirt are trying to move forward with automatic gating with CSIT
17:32:51 <jamoluhrsen> #link https://jenkins.opendaylight.org/releng/job/genius-csit-1node-genius-only-boron/  <--- job that shows the ubuntu-trusty-ovs23 label not working
17:33:03 <odp-gerritbot> Peter Gubka proposed a change to integration/test: updating bgp userfeatures suites to support openconfig peer configuration  https://git.opendaylight.org/gerrit/48159
17:33:48 <jamoluhrsen> #action zxiiro to check in to ubuntu-trusty-mininet-ovs-23-2c-2g node not coming up
17:34:05 <jamoluhrsen> #topic misc
17:37:27 <jamoluhrsen> #action zxiiro and jamoluhrsen to take a look at https://git.opendaylight.org/gerrit/#/c/48211/
17:39:36 <jamoluhrsen> #endmeeting