17:02:05 <jamoluhrsen> #startmeeting integration
17:02:05 <odl_meetbot> Meeting started Thu Dec  1 17:02:05 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:05 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:05 <odl_meetbot> The meeting name has been set to 'integration'
17:03:38 <jamoluhrsen> #topic release
17:04:00 <jamoluhrsen> #info boron SR2 cutoff coming in 2 weeks
17:04:23 <jamoluhrsen> #info boron autorelease was broken but recently fixed.
17:04:40 <jamoluhrsen> #info carbon autorelease broken and waiting on centinel
17:06:02 <jamoluhrsen> #info autorelease is always building the next release, so for example boron autorelease is currently giving us SR2
17:07:44 <jamoluhrsen> #info there has only been one system test waiver request (odlparent).  expecting more to come
17:11:40 <jamoluhrsen> #info questions around projects requiring sys test for user-facing or top-level features
17:11:58 <jamoluhrsen> #link https://wiki.opendaylight.org/view/CrossProject:Integration_Group:Feature_Integration_System_Test_Template   <--- system test template
17:12:39 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Simultaneous_Release:Beryllium_Release_Plan#Features  <-- top level feature definition
17:13:36 <jamoluhrsen> #info we need to revisit odlparent's waiver request because they do have top level features that we may want to require CSIT
17:14:20 <jamoluhrsen> #action jamoluhrsen to respond to odlparent waiver request
17:14:28 <jamoluhrsen> #topic distribution
17:16:02 <jamoluhrsen> #info new contributions in progress (karaf 4, netconf feature incompatibility, and bug 4296)
17:16:37 <jamoluhrsen> #info bug 4296 is around the version feature and should be good before boron SR2
17:18:55 <jamoluhrsen> #info anipbu wonders if we should start pushing odlparent to help us get to a stable distribution.
17:20:40 <jamoluhrsen> #info even if odlparent gives us a stable feature(s) it's not giving us anything usable so maybe we should wait until we have more "useful" stable features?
17:22:07 <jamoluhrsen> #info the distribution team should wait until other projects with useful features are stable should we do the work to actually create the stable distribution
17:22:20 <jamoluhrsen> #topic packaging
17:22:46 <jamoluhrsen> #info deb support added in ansible role.
17:23:55 <jamoluhrsen> #info puppet opendaylight CI (travis) being looked at by possible new ODL intern.
17:24:44 <jamoluhrsen> #info AAA patch merged to help change ODL user passwords via NB REST without restarting controller
17:25:27 <jamoluhrsen> #info packaging trello cards are now freshly updated and current
17:27:03 <jamoluhrsen> #info incorrect explanation about AAA patch.  it's actually a jar file to manipulate
17:27:08 <jamoluhrsen> #topic builder
17:28:08 <jamoluhrsen> #info recent RackSpace upgrade issues (orphaned ports, new image creation) should now be resolved
17:28:31 <jamoluhrsen> #info RackSpace is now on Liberty
17:30:52 <jamoluhrsen> #info jamoluhrsen asks where we should store custom cirros images for our openstack CSIT jobs.
17:31:31 <jamoluhrsen> #info idea is that we find a way to *build* the image in our infra and then store it on our nexus
17:31:47 <jamoluhrsen> #info BUT, we can just directly pull it down from the internet as well.
17:33:02 <jamoluhrsen> #info we can put the packer definition in the builder repo and then directly pull it from our private cloud swift, or put it on nexus
17:33:56 <jamoluhrsen> #info jamoluhrsen asks about using a groovy script to generate a custom email report from robot results
17:34:46 <jamoluhrsen> #info the answer is that it would require manual work every time a job is updated.  groovy scripts are a pain to maintain.
17:36:11 <odp-gerritbot> Matej Perina proposed a change to integration/test: clustering test for GBP  https://git.opendaylight.org/gerrit/46473
17:37:15 <tykeal> #link https://gerrit.zephyrproject.org/r/#/admin/projects/ci-management Zephyr Project ci-management. Check the zephyr sub-project for custom email examples
17:37:26 <jamoluhrsen> #topic infra collab initiative
17:37:38 <jamoluhrsen> #link https://drive.google.com/open?id=1WwK-49QfFBz1PeAKFg4dyCUDj-EYc_jeEqpgzsLLEbw   <--- google doc
17:41:31 <jamoluhrsen> #info infra collab group has a weekly meeting.
17:42:13 <jamoluhrsen> #action LuisGomez to send email invites to interested folks ( anipbu and zxiiro )
17:50:35 <jamoluhrsen> #topic misc
17:51:22 <jamoluhrsen> #info vrpolak points out beryllium is failing because of a circular dependency, but fix is in place
17:53:16 <jamoluhrsen> #info jamoluhrsen wondering if we have any way to exclude certain robot.tidy tox failures, like we see in this one:   https://git.opendaylight.org/gerrit/#/c/48646/7/csit/libraries/Netvirt.robot
17:54:28 <jamoluhrsen> #info vrpolak mentions that karaf 4 is coming and some files are formatted in different ways, so our releng builder scripts may need some work to make this easier on odlparent folks
17:54:47 <jamoluhrsen> #action vrpolak can share a concrete example of this problem via mailing list
17:56:03 <jamoluhrsen> #info we had collateral damage from a recent CSIT patch in a library file:   https://git.opendaylight.org/gerrit/#/c/48602/
17:57:06 <jamoluhrsen> #info tl;dr a utils keyword started returning 2 values instead of 1 so some consumers broke.  but not all
17:57:57 <jamoluhrsen> #action LuisGomez jamoluhrsen to double check all jobs using this library to see if we have too many failures and should revert
17:59:11 <jamoluhrsen> #endmeeting