17:03:00 <jamoluhrsen> #startmeeting integration
17:03:00 <odl_meetbot> Meeting started Thu Dec 15 17:03:00 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:03:00 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:03:00 <odl_meetbot> The meeting name has been set to 'integration'
17:03:18 <odp-gerritbot> A change was merged to integration/distribution: DluxApps project features  https://git.opendaylight.org/gerrit/48953
17:05:05 <jamoluhrsen> #topic packaging
17:05:21 <jamoluhrsen> #info lots of intern activity, which is awesome
17:06:16 <jamoluhrsen> #info not all of the current intern activity will result in official internships
17:06:57 <jamoluhrsen> #info rpm build logic will now be able to find latest snapshot distro and create and rpm...  helpful for opnfv we think
17:07:21 <jamoluhrsen> #info coala linter now available
17:07:43 <jamoluhrsen> #info so good linting on things like json, md, etc
17:08:33 <jamoluhrsen> #info puppet modules are being updated now.  more tests
17:08:52 <jamoluhrsen> #info opnfv/apex consuming rpms constantly.
17:10:11 <jamoluhrsen> #topic builder
17:10:49 <jamoluhrsen> #info we now store console logs with timestamps on log server
17:13:38 <jamoluhrsen> #action jamoluhrsen to send email why robot logs are showing local timezone?
17:15:14 <jamoluhrsen> #info infra folks hoping to minimize changes as we approach the end of the year
17:15:27 <jamoluhrsen> #info odlforge still has slow progress towards getting online
17:16:26 <jamoluhrsen> #topic release
17:17:15 <jamoluhrsen> #action LuisGomez to look at L2Switch failures in SR2
17:17:25 <jamoluhrsen> #link https://docs.google.com/spreadsheets/d/1zImtd764e-hOgJAxoJKl85fxHCPu2agLfqsBtf13zQY/edit#gid=1708916020   <--- Boron SR2 status
17:17:43 <jamoluhrsen> #info hopefully try to approve SR2 today
17:17:52 <jamoluhrsen> #topic distribution
17:18:30 <jamoluhrsen> #info cardinal failures in SFT for carbon because of a change in odlparent.
17:18:50 <jamoluhrsen> #info vrpolak looking at these failures, but no simple solution yet.
17:19:21 <jamoluhrsen> #info worst case is that cardinal might need to be removed from distribution
17:19:34 <jamoluhrsen> #info dlux apps are now being added to distribution
17:19:59 <jamoluhrsen> #info vorburger has patches to make all features created the same way.  vrpolak reviewing those patches
17:20:41 <jamoluhrsen> #topic misc
17:22:57 <jamoluhrsen> #info jamoluhrsen asks if we should start purging logs with the same cadence (every Sat) as we do jobs
17:24:25 <jamoluhrsen> #info current method is to delete logs when they are 7 days old, so there is some overlap that could cause confusion when people create jobs with the same name.
17:25:30 <odp-gerritbot> Alon Kochba proposed a change to integration/test: Add SNAT test to netvirt CSIT  https://git.opendaylight.org/gerrit/49217
17:26:20 <jamoluhrsen> #action jamoluhrsen to give PSA about how logs are purged...
17:27:43 <jamoluhrsen> #info vrpolak would prefer logs to be purged on Sat like the jobs
17:29:56 <jamoluhrsen> #action jamoluhrsen to open helpdesk ticket for log purging.
17:31:25 <jamoluhrsen> #info LuisGomez noticed that yangtools merge job is failing for Beryllium so we cannot build a distro at this point.
17:32:04 <jamoluhrsen> #info since we will *probably* not release another Beryllium release it may not be a big deal, but there is the possibility that a security issue could force another release.
17:35:04 <jamoluhrsen> #info LuisGomez proposes that we move all of our periodic jobs away from running daily on SNAPSHOT distros and only to run on autorelease distros
17:36:29 <jamoluhrsen> #info problem with running periodic jobs on autorelease, is that master is not creating the distro hardly ever
17:38:21 <jamoluhrsen> #action LuisGomez to come up with a plan for running periodic jobs on autorelease taking in to account that master autorelease is not successful most of the time
17:42:17 <jamoluhrsen> #info vrpolak points out that autorelease is probably not triggering enough CSIT jobs
17:43:51 <jamoluhrsen> #info jamoluhrsen points out that we have to use the older version of paramiko because the newer version broke the robot framework SSHLibrary.
17:44:46 <jamoluhrsen> #action jamoluhrsen to create trello card to investigate the paramiko issue and see if we can find a solution so we can use the newer lib
17:47:04 <jamoluhrsen> #endmeeting