16:03:48 <jamoluhrsen> #startmeeting performance and cluster test
16:03:48 <odl_meetbot> Meeting started Fri May  6 16:03:48 2016 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
16:03:48 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
16:03:48 <odl_meetbot> The meeting name has been set to 'performance_and_cluster_test'
16:04:30 <jamoluhrsen> #info first performance related focus can be to get our one off tests that people are running locally pushed to test repo and running in releng
16:05:13 <jamoluhrsen> #info we need a dashboard.  there is an intern working in this area
16:06:42 <jamoluhrsen> #info pramod from intel has a sort of dashboard that collects tempest results
16:07:33 <jamoluhrsen> #link http://pramodrj07.github.io/odl/  pramod's dashboard
16:08:13 <jamoluhrsen> LuisGomez, mgkwill gvrangan taking notes here, btw
16:09:52 <jamoluhrsen> #info should we get access to a physical performance lab hosted by LF?
16:11:54 <jamoluhrsen> #info this would be a separate effort than CPERF in OPNFV.  CPERF is controller agnostic, whereas this LF perf lab would be ODL specific
16:14:21 <jamoluhrsen> #action mgkwill to start more conversations on mailing list
16:17:59 <jamoluhrsen> #info mgkwill can submit a CFP for performance numbers as we assume we will be collecting numbers and again like we did at the end of Beryllium release.
16:22:23 <jamoluhrsen> #info vratko notes that peter is retesting ONOS with new version and ONOS performance is much better.
16:22:30 <jamoluhrsen> #info mgkwill confirms those findings
16:23:20 <jamoluhrsen> #info ONOS added batch flow programming in newest version.
16:26:33 <jamoluhrsen> #info next week we will try to present/summarize all the different upstream releng performance tests
16:27:01 <jamoluhrsen> #topic cluster testing
16:27:41 <jamoluhrsen> #info cluster tests should start moving to clustermanagment.robot library from clusterkeywords.robot
16:28:24 <jamoluhrsen> #info in otherwords, clusterkeywords.robot should be considered "deprecated"
16:32:03 <jamoluhrsen> #info sanjib points out that a new feature is introduced in boron to do bulk requests via REST.
16:34:00 <jamoluhrsen> #info still not sure what this new feature is providing, need more info.
16:36:24 <jamoluhrsen> #info vratko describes three ways to create a lot of flows 1) restconf with container with lots of items.  2) batch method that may be unreliable.  3) openflow has implemented RPC batch method, bulk-o-matic.
16:40:33 <jamoluhrsen> #action jamoluhrsen to look in to issue where slowly bringing up controllers in a cluster means clustering is broken.
16:41:33 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2016-May/006616.html to see discussion about controllers not able to be in a healthy cluster if they come up too far apart
16:52:32 <jamoluhrsen> #info jamoluhrsen points out that OVSDB cluster tests consistently fail, but no traction from project to get the bugs fixed
16:57:37 <jamoluhrsen> #info openflowplugin clustering CSIT has some failures and bugs are filed for them.
16:58:29 <jamoluhrsen> #info new netconf suite for clustering has been merged.  open bug is there for the failures.
16:59:48 <jamoluhrsen> #info jozef may be going away from test work.
17:02:28 <jamoluhrsen> #endmeeting