15:32:46 <dfarrell07> #startmeeting s3p
15:32:46 <odl_meetbot> Meeting started Fri Aug  5 15:32:46 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:32:46 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:32:46 <odl_meetbot> The meeting name has been set to 's3p'
15:32:55 <dfarrell07> #chair mgkwill jamoluhrsen LuisGomez
15:32:55 <odl_meetbot> Current chairs: LuisGomez dfarrell07 jamoluhrsen mgkwill
15:33:44 <dfarrell07> #info dfarrell07 took a deep-dive into existing NetVirt CSIT, what's working/broken/usable
15:33:49 <dfarrell07> #info dfarrell07 is starting to base a new job on {project}-csit-1node-openstack-{openstack}-{functionality}-{stream} template
15:33:53 <dfarrell07> #info dfarrell07 sync'd with Marcus about ongoing Intel NetVirt scale work
15:33:58 <dfarrell07> #info Marcus and team seem to be making good progress, see CPerf minutes for details
15:34:03 <dfarrell07> #info Starting to look like Maracus et al will drive quick-results/big-numbers tests in private lab, dfarrell07 will drive in CSIT
15:34:07 <dfarrell07> #info Great discussion on integration-dev mailing list about Luis' OpenFlow tests, feedback from Al et al about timing/metrics/tests
15:38:39 <dfarrell07> #link https://wiki.opendaylight.org/view/Integration/Test/S3P/Performance_Test_Reports/Boron_Performance_Test_Report_Plan Main Boron whitepaper link
15:38:51 <dfarrell07> #info mgkwill starts off going over that link^^,reviewing past discussions
15:39:03 <dfarrell07> #info LuisGomez talks about switch scale tests, maybe with Veryx, maybe mininet
15:39:45 <dfarrell07> #info mgkwill asks Vratko about NetConf/BGP tests
15:40:15 <dfarrell07> #info NetConf/BGP tests will be done with existing upstream tests, shouldn't take too much time, week or two, they are starting on this in next day or two
15:42:17 <dfarrell07> #action dfarrell07 to create stub readthedocs for whitepaper
15:45:17 <LuisGomez> #link https://wiki.opendaylight.org/view/Integration/Test/S3P/OpenFlow
15:45:31 <LuisGomez> this is OpenFlow test initial discussion ^^^
15:52:02 <dfarrell07> #info Discussion about Netvirt scale tests
15:52:39 <dfarrell07> #info Min sim: OVS instance, ports/routers etc get added to simulate neutron config, start programming flows
15:55:46 <dfarrell07> #info Can ignore VMs, traffic, etc for now jamoluhrsen says, just scale to a large number of ovs instances with the right connections, create ~20 ports each, next level make sure we can send traffic
15:57:46 <dfarrell07> #info mgkwill talks about existing code he has upstream, spins up OVSs, sets up connections, would need to add logic to install netvirt and do some network/port creation
15:59:44 <dfarrell07> #info discussion about benefits of full-vm-node tests intel is doing on their hw, how that tests other things like NBB, different traffic
16:01:18 <dfarrell07> #info mgkwill and dfarrell07 will work on getting ovs instances spinning up in containers against NetVirt CSIT jobs this coming up week
16:01:38 <dfarrell07> #info mgkwill talks about moving these tests into OPNFV CPerf eventually, would be able to scale much larger
16:05:34 <dfarrell07> #info Discussion about OF testing LuisGomez and Al are talking about metrics/timing on-list, discussion will continue on-list, should doc these timing details in report
16:05:42 <dfarrell07> #info LuisGomez is out next week, jamoluhrsen is out part of next week
16:07:00 <dfarrell07> #info Sanjib is working on bulk-o-matic this week
16:11:37 <dfarrell07> #info Vratko and mgkwill talk about netconf/bgp tests, Vratko will support with bug fixes if test results find problems
16:17:44 <dfarrell07> #endmeeting