15:32:43 <dfarrell07> #startmeeting s3p
15:32:43 <odl_meetbot> Meeting started Fri Sep 16 15:32:43 2016 UTC.  The chair is dfarrell07. Information about MeetBot at http://ci.openstack.org/meetbot.html.
15:32:43 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:32:43 <odl_meetbot> The meeting name has been set to 's3p'
15:33:09 <dfarrell07> #chair jamoluhrsen mgkwill phrobb
15:33:09 <odl_meetbot> Current chairs: dfarrell07 jamoluhrsen mgkwill phrobb
15:35:08 <dfarrell07> #info Discussion about when we should target report for release
15:35:29 <dfarrell07> #info There are clustering fixes in the works, we thought they would land for SR1, but now seems like not until Carbon
15:35:43 <dfarrell07> #info There are new OF tests we would like to run/include
15:36:09 <dfarrell07> #info Luis, Marcus et al think timing is tight for Summit, so SR1 is nice in that regard
15:36:32 <dfarrell07> #info Can focus on jobs in CI, show public graphs, for this report
15:39:05 <dfarrell07> #info dfarrell07 asks for tech details on why clustering is slow, Luis says slow part in current clustering is backend pipeline
15:40:15 <dfarrell07> #info Phil, Colin, Robert et all have been following this, Phil gives more info, we're currently syncing and locking one transaction across the cluster, need pipelineing and batching to improve that
15:40:41 <dfarrell07> #info Pipelining is best solution but hard, short term option may be to do transparent batching, which maybe could happen for SR1
15:41:00 <dfarrell07> #info OF also needs ability to use transparent batching, then we'd have big perf increase
15:41:22 <dfarrell07> #info Colin is figuring out if we have resources for that work, if it can be done for SR1
15:41:41 <dfarrell07> #info jamoluhrsen asks how bad we are now, and how that compares to clustering exactly
15:42:50 <dfarrell07> #info Luis says bulk-o-matic and NB API tests are the relevant ones, because they touch the data store, in first runs he's seeing 4x less for cluster, still getting data for proper results
15:43:41 <dfarrell07> #info Latency and flows per second are of course major considerations, but Luis also seeing instances die when you try to slam it with many flows, doesn't see this with single instance (so maybe bugs+perf issues)
15:44:20 <odp-gerritbot> Vratko Polák proposed a change to integration/test: WIP: Netconf config stress HA suite  https://git.opendaylight.org/gerrit/44728
15:45:05 <dfarrell07> #info Luis asks phrobb for recommendation, Phil isn't sure, gathering opinions
15:47:39 <dfarrell07> #info dfarrell07 suggests focusing on CI tests, describing what they are doing, what they mean, that we're trying to drive perf work towards stuff in CI
15:48:41 <dfarrell07> #info Discussion about how we really should do this after the release, so we can build/run tests against stable ODL
15:49:07 <dfarrell07> #info Luis suggests getting as much infra automatic as possible, target SR1 for paper
15:50:38 <dfarrell07> #info phrobb asks about perf tests of ODL through OpenStack, mgkwill says that's what they are doing internally, setting up ODL+O/S and benchmarking with Rally, comparing to default neutron networking
15:53:43 <dfarrell07> #link https://git.opendaylight.org/gerrit/#/c/45714/ Boron perf report stub gerrit by dfarrell07
15:54:09 <dfarrell07> #agreed We will complete the stub perf report below to describe tests we're doing in CI, what they do and mean, put them in context
15:54:57 <dfarrell07> #info Luis points out we might could create a dashboard with his intern's project to show all the perf results we care about, intern may be able to do for us
15:55:28 <dfarrell07> #action Luis to contact dashboard intern to see if they can do this, tell them which jobs we want to track on dashboard
15:59:12 <dfarrell07> #info Party line for clustering perf is that we've been focused on clustering functional tests this release, has gotten much more stable in Boron, are adding perf tests as well, we know perf currently sucks and we know why and we're planning on fixing it in SR1 or Carbon
16:02:30 <dfarrell07> #agreed Not going to do big-machine, big-number perf tests for Summit, will monitor cluster perf via CI jobs and see if possible for SR1
16:02:47 <dfarrell07> #info We should be honest, as an open source project, about clustering not being where we want to be
16:03:44 <dfarrell07> #info Our more marketing-focused peers will likely not be nice ;), but we should just do the right thing
16:12:20 <dfarrell07> #action phrobb will send out email about status of perf testing, plans
16:13:59 <phrobb> #info, a party line  alternative...Party line for clustering perf is that we've been focused on clustering functional tests this release, has gotten much more stable in Boron, are adding perf tests as well, we know perf currently is lacking and we know why.  We have plans in place to improve clustering performance and to construct tests to validate and
16:13:59 <phrobb> measure those improvements in the next release.
16:14:35 <dfarrell07> #info (cont) ...measure those improvements in the next release.
16:15:07 * dfarrell07 got dropped
16:16:01 <dfarrell07> #info Discussion about groups we know are using clustering, that it works okay when not pushing it hard for perf testing it seems
16:16:29 <odp-gerritbot> A change was merged to integration/test: Add Boron perf report stub  https://git.opendaylight.org/gerrit/45714
16:16:39 <jamoluhrsen> dfarrell07: merged the stub.  https://git.opendaylight.org/gerrit/#/c/45714/
16:16:52 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/45714/  <--- patch with perf report stub
16:16:52 <dfarrell07> jamoluhrsen: thanks :)
16:20:31 <dfarrell07> #endmeeting