07:38:38 <jamoluhrsen> #startmeeting integration
07:38:38 <odl_meetbot> Meeting started Fri Jan  6 07:38:38 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
07:38:38 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
07:38:38 <odl_meetbot> The meeting name has been set to 'integration'
07:38:50 <jamoluhrsen> #topic packaging
07:38:50 <jamoluhrsen> #info still good progress happening from prospective interns
07:39:07 <jamoluhrsen> #info new jobs coming online, like testing the rpm, creating snapshot builds
07:39:07 <jamoluhrsen> #info maybe some refactoring in the work for how .deb and .rpm logic are sharing code
07:39:07 <jamoluhrsen> #info jamoluhrsen wondering if there is some demo worthy packaging work?
07:39:07 <jamoluhrsen> #info  a good demo would showing how the rpm and deb packaging works.
07:39:07 <jamoluhrsen> #info we want to extend the packaging internship to include 2 interns instead of 1.
07:39:08 <jamoluhrsen> #topic distribution
07:39:18 <jamoluhrsen> #info karaf 4 work is starting to happen now, but nothing landing yet.
07:39:18 <jamoluhrsen> #info beir project verification is failing due to possible issues in ietf models.
07:39:18 <jamoluhrsen> #info seems that only the beir project is hitting these issues.
07:39:18 <jamoluhrsen> #info anipbu thinks it possible that the beir issue is resolved for autorelease, but vrpolak points out this is a failure in distribution not autorelease
07:39:19 <jamoluhrsen> #topic release
07:39:25 <jamoluhrsen> #info autorelease is still failing in carbon, but fine with boron
07:39:25 <jamoluhrsen> #info karaf 4 migration is going to need some push for projects to migrate sooner rather than later.
07:39:28 <jamoluhrsen> #info if the plan is to only release carbon with karaf4, we need to figure out how we will deal with those projects that are in maint. mode and wont be able to do this migration on their own.
07:39:31 <jamoluhrsen> #info do we drop them from release, do the work for them, other?
07:39:33 <jamoluhrsen> #info we need to know how much work is really needed per project. requesting a TWS for this.
07:39:36 <jamoluhrsen> #info autorelease for carbon now failing with of-config
07:39:38 <jamoluhrsen> #topic builder
07:39:40 <jamoluhrsen> #info no infra changes the past few weeks, but updates coming (e.g., jenkins upgrade to 2.x, gerrit update to 2.12, security updates, and more...)
07:39:43 <jamoluhrsen> #info the releng periodic jobs are now removed
07:39:45 <jamoluhrsen> #info the jenkins queue is very large and it's mostly CSIT jobs.
07:39:47 <jamoluhrsen> #info one problem we have now is that we have a lot more CSIT jobs and we cannot start any more simultaneous robot jobs without jenkins crashing.
07:39:50 <jamoluhrsen> #info the issue is with RackSpace API + jclouds, not with the available resources
07:39:54 <jamoluhrsen> #info one effort we can try is to use heat to spin up nodes, instead of jclouds.
07:39:56 <jamoluhrsen> #info initial investigation by zxiiro is promising.
07:39:58 <jamoluhrsen> #info another advantage from heat is it would make it easier to do multi-network VMs
07:40:00 <jamoluhrsen> #info tykeal wants to make it known that the main consumer of this large jenkins queue is netvirt
07:40:03 <jamoluhrsen> #info zxiiro thinks maybe another big user of CSIT resources are these post merge jobs and periodic jobs
07:40:06 <jamoluhrsen> #info short term solution is to find and stop any unnecessary CSIT jobs.
07:40:09 <jamoluhrsen> #info long term is to get heat working
07:40:10 <jamoluhrsen> #info also we need to really sit and think through all that is happening with CSIT and make sure we are really doing what we want.
07:40:13 <jamoluhrsen> #info maybe a short/small hackfest only focused around the jenkins jobs is in order.
07:40:15 <jamoluhrsen> #action jamoluhrsen to start an email on this.
07:40:17 <jamoluhrsen> #info internally, LF has a new public repo coming in with useful tools that are being used in other LF projects (e.g. version bumping)
07:40:20 <jamoluhrsen> #topic misc
07:40:24 <jamoluhrsen> #info should we grant system test waivers to odlparent, infrautils and neutron nb as we did in Boron?
07:40:27 <jamoluhrsen> #link https://wiki.opendaylight.org/view/Simultaneous_Release/Boron/Waiver/System_Test  <--- boron system test waiver approval
07:40:30 <jamoluhrsen> #info vrpolak wonders if odlparent might actually have top level features that should have some system test
07:40:33 <jamoluhrsen> #info we need a more explicit test description for next release
07:40:35 <jamoluhrsen> #info skitt points out that some odlparent features can break in subtle ways that it would be nice to have automation around.
07:40:38 <jamoluhrsen> #info vrpolak thinks infrautils could use small system tests as well.
07:40:40 <jamoluhrsen> #info anipbu agrees that infrautils could/should have system test.
07:40:43 <jamoluhrsen> #action jamoluhrsen to ask for a report of other projects consuming infrautils and if their CSIT is really testing features of infrautils
07:40:45 <jamoluhrsen> #info also we should consider their IT/UT coverage as well.
07:40:47 <jamoluhrsen> #info will approve neutron NB and odlparent.  then email infrautils
07:40:49 <jamoluhrsen> #topic karaf4 migration
07:40:53 <jamoluhrsen> #info skitt thinks the migration work is not too hefty, and mostly mechanical
07:40:55 <jamoluhrsen> #info this work is done already for most of offset-0
07:40:57 <jamoluhrsen> #info most time consuming part is testing all the features.
07:40:59 <jamoluhrsen> #info most breakages are hopefully already fixed in odlparent
07:41:01 <jamoluhrsen> #info biggest dependency is the number of features a project has
07:41:04 <jamoluhrsen> #info some non-responsive projects should be fairly easy to migrate if they are using features-parent
07:41:06 <jamoluhrsen> #info projects that are not using single feature test are going to be hard to migrate
07:41:08 <jamoluhrsen> #info we need to poll these projects to get an idea of how painful this migration might be
07:41:11 <jamoluhrsen> #info LuisGomez asks how critical this migration would be, and it seems from community emails that it's a pretty big deal
07:41:14 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2017-January/008819.html
07:41:16 <jamoluhrsen> #endmeeting