17:02:15 <jamoluhrsen> #startmeeting integration
17:02:15 <odl_meetbot> Meeting started Thu Jan 12 17:02:15 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:15 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:15 <odl_meetbot> The meeting name has been set to 'integration'
17:03:49 <jamoluhrsen> #topic distribution
17:04:25 <jamoluhrsen> #info configure_cluster script discussion ongoing because it has broken recently because controller project did not know about it.
17:04:51 <jamoluhrsen> #info vrpolak thinks we should probably move the controller script to the controller project
17:05:41 <jamoluhrsen> #info if it does move to controller project, hopefully we can keep it in /bin still
17:06:05 <odp-gerritbot> Ursicio Javier proposed a change to integration/test: SFC - Logical SFF: Developing Full Deploy Test Case  https://git.opendaylight.org/gerrit/49667
17:06:06 <jamoluhrsen> #info beir project is having trouble putting their features in integration. some yang model conflict
17:06:58 <jamoluhrsen> #info honeycomb/vbd is also seeing this issue
17:07:21 <jamoluhrsen> #info vrpolak will have a bug for these issues and md-sal project can hopefully take care.
17:09:37 <jamoluhrsen> #info controller project has reverted their akka conf change so clustering should not be broken. the cluster_config script change has also been reverted.
17:10:50 <jamoluhrsen> #info vrpolak has an email out for int/dist about moving the cluster_config script to controller project.
17:12:16 <jamoluhrsen> #topic packaging
17:12:48 <jamoluhrsen> #info intern applications are finalized and we will have two packaging interns.
17:13:24 <jamoluhrsen> #info ansible linting done and some ansible test framework potential being investigated
17:14:03 <jamoluhrsen> #info readthedocs patch coming to move wiki content to readthedocs (still open for review)
17:14:22 <jamoluhrsen> #info no autorelease for boron for ~1week.
17:14:41 <jamoluhrsen> #info boron autorelease blocker should be fixed today (it was of-config)
17:15:06 <jamoluhrsen> #topic release
17:15:58 <jamoluhrsen> #info waiting for AAA, controller and netconf feature freeze.
17:16:24 <jamoluhrsen> #info system test waiver came from bier project. anipbu recommends we do not approve the waiver without more info from the project
17:17:05 <jamoluhrsen> #info anipbu asked beir project for more info. waiting on their response?
17:17:19 <jamoluhrsen> dfarrell07, I can't hear anyone.
17:17:23 <jamoluhrsen> can you hear me?
17:17:52 <jamoluhrsen> anipbu, vrpolak, dfarrell07 dialing back in ...
17:18:36 <anipbu> https://lists.opendaylight.org/pipermail/integration-dev/2017-January/008922.html
17:19:07 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2017-January/008922.html  <--- email to beir asking for more info about sys test waiver
17:23:00 <jamoluhrsen> #info carbon autorelease still failing and we continue to hound projects to help unbreak it.
17:23:15 <jamoluhrsen> #info builder
17:23:24 <jamoluhrsen> #undo
17:23:24 <odl_meetbot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x27f38d0>
17:23:27 <jamoluhrsen> #topic builder
17:23:43 <zxiiro> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/opendaylight-infra-stack.sh opendaylight-infra-stack
17:23:43 <jamoluhrsen> #info all csit jobs that used  to spin up with jclouds are now using heat
17:26:41 <zxiiro> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/integration/integration-macros.yaml#L264-L284 integration-infra-stack
17:29:44 <dfarrell07> zxiiro https://developer.rackspace.com/docs/cloud-servers/v2/general-api-info/flavors/
17:30:13 <jamoluhrsen> #link https://developer.rackspace.com/docs/cloud-servers/v2/general-api-info/flavors/ <--- shows all the VM flavors we can get from RackSpace public cloud
17:32:06 <jamoluhrsen> #info even with this flexibility now to more easily get VM flavors, we still want to use the smallest vm possible
17:32:20 <jamoluhrsen> #info heat will fail a lot faster now, which is good :)
17:33:02 <zxiiro> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/integration/integration-templates.yaml#L81-L88 integration template heat changes
17:34:41 <zxiiro> #link https://github.com/opendaylight/releng-builder/blob/master/jjb/releng-defaults.yaml#L30-L42 default variables related to heat
17:42:15 <jamoluhrsen> thanks zxiiro!
17:42:46 <jamoluhrsen> #info vrpolak wondering about the ssh issue and wondering if we can add an entropy check in the spinup scripts?
17:44:39 <zxiiro> havegd
17:44:56 <jamoluhrsen> #action jamoluhrsen to look in to installing/running havegd in spinup scripts.
17:45:07 <vrpolak> To see current entropy: cat /proc/sys/kernel/random/entropy_avail
17:45:32 <jamoluhrsen> #info maybe it can be inside packer too
17:47:59 <jamoluhrsen> #info we need a script that calls an ssh command/script to vote on a gerrit. it would be a macro to end up as a last step in a job
17:48:40 <jamoluhrsen> #info we would also need some work in the patch test job to know if it should be a -1,0,+1
17:55:11 <odp-gerritbot> Abbas P Pareedkunju proposed a change to integration/test: HWVTEP Initialization Tests  https://git.opendaylight.org/gerrit/50084
17:58:36 <odp-gerritbot> Ursicio Javier proposed a change to integration/test: SFC - Logical SFF: Developing Full Deploy Test Case  https://git.opendaylight.org/gerrit/49667
18:02:48 <jamoluhrsen> #endmeeting