17:02:19 <jamoluhrsen> #startmeeting integration
17:02:19 <odl_meetbot> Meeting started Thu Feb  2 17:02:19 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:02:19 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:02:19 <odl_meetbot> The meeting name has been set to 'integration'
17:03:57 <jamoluhrsen> #topic builder
17:04:12 <odp-gerritbot> Vratko Polák proposed a change to integration/test: WIP: Add clustering documentation stub  https://git.opendaylight.org/gerrit/51253
17:04:17 <jamoluhrsen> #info there has been a lot of work for how our heat stack create is working
17:04:41 <jamoluhrsen> #link https://git.opendaylight.org/gerrit/#/c/51276/  <--- new heat patch
17:05:53 <jamoluhrsen> #info there is still trouble with our openstack config file plugin, so still looking for a workaround
17:07:14 <jamoluhrsen> #info this plugin fix needs to be there for the openstack api limit checks to work.
17:07:52 <jamoluhrsen> #info RackSpace doubled our api limits from 5k to 10k
17:08:37 <zxiiro> https://git.opendaylight.org/gerrit/51321
17:08:57 <jamoluhrsen> #link  https://git.opendaylight.org/gerrit/51321 coming soon, log server URL in jenkins emails
17:09:06 <jamoluhrsen> #topic distribution
17:09:27 <tykeal> zxiiro: have a merge :)
17:09:39 <zxiiro> tykeal: great!
17:10:16 <jamoluhrsen> #info karaf 4 migration under way, but not done yet
17:10:47 <jamoluhrsen> #info still need other core projects to migrate anyway
17:11:39 <jamoluhrsen> #topic release
17:12:21 <jamoluhrsen> vrpolak, can you pass the ball?
17:13:10 <jamoluhrsen> #info controller karaf 4 patch has been merged, so we hope to see a lot of other projects migrate now
17:13:29 <jamoluhrsen> #info today is M4 (API FREEZE!!!)
17:13:49 <jamoluhrsen> #info in the middle of M5 we are going to have a boron release SR3
17:14:15 <vrpolak> jamoluhrsen: ball passed
17:14:34 <jamoluhrsen> #topic misc
17:14:37 <vrpolak> Will we be talking about https://wiki.opnfv.org/display/INF/Infra+Collaboration#InfraCollaboration-CollectionofthePresentations
17:17:29 <jamoluhrsen> #info now that we run CSIT daily on snapshot and autorelease we can potentially be using 19hours of robot resources
17:17:49 <LuisGomez> #link https://jenkins.opendaylight.org/releng/view/integration/job/integration-distribution-test-boron/103/
17:21:01 <jamoluhrsen> #info csit job list is auto updated on builderpatch merges
17:21:37 <jamoluhrsen> #info LuisGomez points out that other groups/consumers are really wanting to see a way to *know* if a distribution is good, so sanity job will be important
17:23:16 <zxiiro> #link https://trello.com/c/EGYoCYXX Autorelease build failure email notification automation
17:24:01 <jamoluhrsen> #info also worked on some patches to get patch differences between distros to be output in the distribution job
17:24:26 <jamoluhrsen> #topic cluster doc
17:24:40 <vrpolak> #link https://git.opendaylight.org/gerrit/#/c/51253/
17:25:07 <dfarrell07> jamoluhrsen: sorry, had head buried in work and missed meeting start, here now
17:25:23 <jamoluhrsen> dfarrell07, mornin'
17:25:26 <dfarrell07> :)
17:30:53 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/test: Test for Networks Scaling  https://git.opendaylight.org/gerrit/49985
17:38:03 <zxiiro> jamoluhrsen: I want to ask about upgrading out mininet's to 16.04 if there's time.
17:38:15 <jamoluhrsen> zxiiro, ack
17:44:51 <jamoluhrsen> #action jamoluhrsen to make a trello card to auto publish robot testdoc (note: we already do this for libdoc)
17:47:05 * jamoluhrsen wonders if we should start asking for testplans in robot files? the impl can be done at a later time
17:48:27 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/test: Test for Networks Scaling  https://git.opendaylight.org/gerrit/49985
17:50:01 <odp-gerritbot> Venkatrangan Govindarajan proposed a change to integration/test: Test for Networks Scaling  https://git.opendaylight.org/gerrit/49985
17:51:15 <rovarga> I am probably very biased here, as I am dealing with controller specifically
17:51:49 <rovarga> and it is the bottom-most part of the stack, so it deals mostly with APIs and java stuff rather than outside functionality
17:59:47 <jamoluhrsen> #info zxiiro asks if we can upgrade our ubuntu from 14.04 to 16.04 mininet VM?
18:00:28 <jamoluhrsen> #info I think it's safe to test on sandbox and then upgrade in releng if relevant CSIT jobs are ok
18:00:32 <jamoluhrsen> #endmeeting