17:01:36 <jamoluhrsen> #startmeeting integration
17:01:36 <odl_meetbot> Meeting started Thu Feb  9 17:01:36 2017 UTC.  The chair is jamoluhrsen. Information about MeetBot at http://ci.openstack.org/meetbot.html.
17:01:36 <odl_meetbot> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
17:01:36 <odl_meetbot> The meeting name has been set to 'integration'
17:07:19 <jamoluhrsen> #topic distribution
17:07:28 <jamoluhrsen> #info sdninterface app features are back in integration.
17:07:36 <jamoluhrsen> #info no support for karaf 4 yet, no milestone reports yet
17:08:07 <jamoluhrsen> #info anipbu says that it's not really until M5 when we probably will have to worry about the distribution milestone reports
17:08:58 <jamoluhrsen> #topic packaging
17:09:28 <jamoluhrsen> #info debian work for puppet module work making good progress
17:09:52 <jamoluhrsen> #info rpms soon to be triggered from autorelease. patch yet to be merged
17:10:18 <jamoluhrsen> #info single click cluster setup project given to us from alexis in int/packaging/tutorials.
17:11:17 <jamoluhrsen> #info tsc gave approval for us to create new repos under int/pak without creating new projects. this will let us import ansible and puppet github repos to be hosted in int/pak
17:13:03 <jamoluhrsen> #topic release
17:13:31 <jamoluhrsen> #info lots of projects that have not reported M3. this is feature freeze
17:14:15 <jamoluhrsen> #info offset 0 and 1 only have one missing projects. all other delayed projects are offset 2 which are easier to drop from release if needed
17:17:53 <jamoluhrsen> #topic builder
17:18:22 <jamoluhrsen> #info RackSpace 503 errrors we saw in some jobs were on their side and now reported to be fixed.
17:19:00 <jamoluhrsen> #info jenkins minion image list is now auto-updated in our docs
17:19:39 <jamoluhrsen> #info there are still "private" images that are not listed in the docs, but we can use those in the sandbox
17:21:03 <jamoluhrsen> #info LuisGomez and jamoluhrsen point out that there are more errors to talk about
17:21:31 <jamoluhrsen> #info ubuntu mininet upgrades underway. current plan is to keep old OVS on 14.04, but all newer ovs will be on 16.04
17:22:09 <jamoluhrsen> #info zxiiro asks if we can change our default from java7 to java8?
17:23:40 <jamoluhrsen> #info we do have some csit tools using java7, but they should detect and switch to the right version, so changing the default to java8 should be fine
17:25:17 <jamoluhrsen> #info packer builds are now detecting failed installs of packages (e.g. yum install failures). this wont fail a packer patch verify job, but will fail the merge job so we wont get borked images at least
17:26:41 <jamoluhrsen> #info all builds will now run a git status to show projects which might be editing their git repo during a build. this might be unintentional and will help projects find thta.
17:27:18 <jamoluhrsen> #info autorel and builder scripts are starting to move to a shared LF repo to be used by other LF projects (e.g. OPEN-O)
17:27:57 <jamoluhrsen> #info initial committers for this new repo/project is just zxiiro, but it will need more.
17:30:51 <jamoluhrsen> #info autorelease auto-email should be coming soon
17:30:53 <zxiiro> #link https://git.opendaylight.org/gerrit/51096 Autorelease Auto Notify Patch
17:31:32 <anipbu> busy month for builder =)
17:34:04 <jamoluhrsen> #info discussion around jobs aborting (red dots)
17:37:10 <jamoluhrsen> #info we can put some retries in our jobs for those times when infra is intermittently not coming up, but LuisGomez points out that we are just hiding the issue.
17:37:22 <jamoluhrsen> #info another issue is that the "lab" comes up, but we cannot ssh to the VMs
17:39:03 <jamoluhrsen> #info LuisGomez wants us to collect more concrete data on when we are having trouble and what kinds of trouble they are
17:39:24 <jamoluhrsen> #info how we get this data is a different, maybe not easy, problem.
17:42:24 <jamoluhrsen> #action jamoluhrsen or zxiiro to look in to a retry for stacking scripts
17:44:13 <jamoluhrsen> #action zxiiro to send patch/email about ideas for collecting data on job aborts
17:44:35 <jamoluhrsen> #topic misc
17:45:02 <jamoluhrsen> #info vrpolak brings up cluster acceptance test request
17:45:46 <jamoluhrsen> #link https://lists.opendaylight.org/pipermail/integration-dev/2017-February/009069.html  <-- cluster acceptance test email for projects to respond to
17:46:45 <jamoluhrsen> #action jamoluhrsen to respond to cluster acceptance email for ovsdb
17:46:55 <jamoluhrsen> #action gvrangan to respond to cluster acceptance email for netvirt
17:48:37 <jamoluhrsen> #info we do have a 3node jenkins tab to quickly see cluster csit status.
17:48:55 <jamoluhrsen> #info we still have our friday 3sp + cluster call. we should get back to going through results
17:49:49 <jamoluhrsen> #endmeeting